XML Schema Browser - generalInvoiceRequest Version 500

Documentation
generalInvoiceRequest V500

produced by Forum Datenaustausch

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and the schema file is not altered.

The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.
This is a draft version of the Forum Datenaustausch for
the purpose of a public consultative procedure.

Data, data structures and the hierarchy of the XSD schema file
may still change as a result of this public consultative process.

Copyright (©) by Forum Datenaustausch, 08.05.2023 - all rights reserved


Revision history of the documentation

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Revision history of the documentation

The following reversed chronological list shows the revision history of this documentation.

The revision history defines the time evolution of the documentation in the sense of a more precise phrasing and/or added parts.
However, the underlying generalInvoiceRequest_500.xsd schema is not changed due to such an entry.
  • Revision 1 from 08.05.2023 (initial version)


Revision history: Documentation of Revision 1

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Documentation of Revision 1

Rev. 1/08.05.2023: the following subparts of the documentation have been refined and/or added:
  • Initial documentation of the generalInvoiceRequest_500.xsd schema


Preface

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Preface

Audience of this documentation
The target audience of this documentation are primarily software developers of the Swiss healthcare sector.
An understanding of Swiss healthcare concepts (e.g. Tiers garant vs. Tiers payant and the like) as well as at least a basic knowledge about XSD schemas is presumed to be known.
How to use this documentation
There are two different views of this documentation.
  • the Hierarchical list view starts from the topmost object. By selecting a shown element one can explore the whole schema space in a recursive descent approach.
  • the Alphabetical list view is for those who are already familiar with the overall structure and concepts. As the name implies one can select from an alphabetical list of elements.

Comments and questions
Please address comments and questions concerning this documentation via either the website Forum Datenaustausch or the email address info@forum-datenaustausch.ch


Forum Datenaustausch

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Forum Datenaustausch

Der Verein "Forum Datenaustausch" (FoDa) fördert den effizienten und sicheren digitalen Datenaustausch zwischen Leistungserbringern und Kostenträgern im administrativen Gesundheitswesen. Er tut dies, indem er sich für folgende, grundsätzliche Ziele einsetzt:
  • Leistungserbringer und Kostenträger nutzen für die digitale Kommunikation untereinander die gleichen, gemeinsam entwickelten und festgelegten Standards.
  • Die digitale Kommunikation zwischen Leistungserbringern und Kostenträger ist sicher, verlässlich und Datenschutzkonform. Sie fördert die Effizienz der Prozesse und ist für alle Partner mit einem positiven Kosten-/Nutzenverhältnis verbunden.

Mitglieder des Forums sind nationale Verbände und Organisationen der Leistungserbringer und der Kostenträger, sowie Körperschaften und Anstalten des öffentlichen Rechts. Hier finden Sie die aktuelle Mitgliederliste.

Die vom Forum Datenaustausch freigegebenen Standards bzw. neue Standard-Versionen, wie die XML-Nachrichten zum elektronischen Datenaustausch, werden hier publiziert.
L'association "Forum Datenaustausch" (FoDa) promeut un échange de données numériques efficace et sûr entre les fournisseurs de prestations et les organismes payeurs dans le domaine administratif de la santé. Pour ce faire, elle s'engage en faveur des objectifs fondamentaux suivants:
  • Les fournisseurs de prestations et les organismes payeurs utilisent les mêmes normes, développées et définies en commun, pour la communication numérique entre eux.
  • La communication numérique entre les fournisseurs de prestations et les organismes payeurs est sûre, fiable et conforme à la protection des données. Elle favorise l'efficacité des processus et est liée à un rapport coûts/bénéfices positif pour tous les partenaires.

Les membres du forum sont des associations nationales et des organisations de prestataires de services et de payeurs, ainsi que des collectivités et des établissements de droit public. Vous trouverez ici la liste actuelle des membres.

Les normes validées par le forum ou les nouvelles versions de normes, comme les messages XML pour l'échange électronique de données, sont publiées ici.


Copyright (©) notice

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Copyright (©) notice

This is a normative standard for the Swiss Public Health Service

Permission to use, and distribute this schema and its accompanying documentation for any purpose and without fee is hereby granted in perpetuity, provided that the above copyright notice and this paragraph appear in all copies and this schema file is not altered. The copyright holders make no representation about the suitability of the schema for any purpose.

It is provided "as is" without expressed or implied warranty.


Purpose of the schema file

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Purpose of the schema file

This is the schema definition for a "General Invoice Request" process encoded in XML. The content is either an invoice or a reminder generated by a health care provider. The request is sent either directly or via 1 or more intermediates to the final recipient. The subchapter Purpose/Anatomy of a request provides a broad overview about the building blocks of a request.

Each individual request is defined by a unique triple of data denoted as object reference.
A "General Invoice Request" can hold a maximum of 3 object references, namely

  • an optional credit object reference from the "General Credit Request" process
  • a mandatory invoice object reference from the initial "General Invoice Request" process
  • an optional reminder object reference given if the process encodes a reminder
This set of object references by itself defines an ordered object reference chain (credit -> invoice -> reminder) with the topmost object reference as unique identification of the XML request. The subchapter Purpose/Object reference provides an in-depth description of the concepts of "object reference", "object reference chain", and "topmost object reference".

Besides the topmost object reference the XML request is further sub-specified by a request_subtype attribute (kind of process attribute), namely

  • the request_subtype=normal attribute (it is a normal request)
  • the request_subtype=copy attribute (it is a copy request)
  • the request_subtype=refund attribute (it is a refund request)
  • the request_subtype=regress attribute (it is a regress request)
  • the request_subtype=storno attribute (it is a storno request)
The subchapter Purpose/Process attributes provides an in-depth description of these attributes.

Upon receiving the XML request electronically the recipient might respond by [0,n] "General Invoice Response" messages, whereas the content per definition defines an answer to the topmost object reference - and only to that object!

This XML project is normative for the electronic invoice/reminder process in Switzerland.


Conventions, terms, and definitions used

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Conventions, terms, and definitions used

This paragraph describes the conventions, terms, and definitions used in the documentation of the XSD schema files. It is assumed that the reader has at least a basic understanding of XSD schemas. Therefore, if there is an ambiguous description or insufficient documentation regarding the XSD schemas itself, you need to look up the official XSD schema definitions at W3C at http://www.w3c.org, this is especially true when using the signature and encryption mechanism.

Character entities
Since some characters in a XML infoset are forbidden these characters must be encoded via character entities. The table shows these special characters and their character entity counterparts.
& => &amp;
' => &apos;
> => &gt;
< => &lt;
" => &quot;

Basic XSD data types used
boolean | boolean has the value space required to support the mathematical concept of binary-valued logic: {true, false}. An instance of a data type that is defined as boolean can have the following legal literal value {true, false, 1, 0}.
double | The double data type corresponds to IEEE double-precision 64-bit floating point type [IEEE 754-1985]. The basic value space of double consists of the values m x 2^e, where m is an integer whose absolute value is less than 2^53, and e is an integer between -1075 and 970, inclusive.
enumeration | enumeration constrains the value space to a specified set of values.
int | int is derived from a 32bit integer by setting the value of maxInclusive and minInclusive to be 2147483647 and -2147483648.
NMTOKEN | NMTOKEN represents a token concept. The value space of NMTOKEN is the set of tokens (strings) that match the production.
pattern | pattern is a constraint on the value space of a data type, which is achieved by constraining the lexical space to literals, which match a specific pattern. The value of pattern must be a regular expression.
string | The string data type represents character strings. The value space of string is the set of finite-length sequences of characters. A character is an atomic unit of communication.


Anatomy of a request

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Anatomy of a request

The following figure shows the various building blocks, their meanings and dependencies on each other, that eventually form a request.
The building block processing is a container for processing instructions e.g. transport routing.
The building block payload is the container that holds the explicit data.
The building block for reference objects
The building block body is the data container. If encryption is used the container body is the target and will be replaced by the encrypted data xenc:EncryptedData
The building block ds:Signature holds the Signature data, whereas the container payload defines the signed part
Please note, that from a principle point of view these building blocks apart from processing are once generated unchangeable. Since the intermediate must include routing information or external institutions must validate the data, the processing block is outside the signature and encryption area and thus changeable.


Object reference,...

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Object reference, ...

The following paragraphs define the concepts of object reference, object reference chain, and topmost object reference. These concepts are of high importance within the XML request/response system.

object reference

An object reference is an identification of an individual XML request defined by a unique triple of data, namely
  • timestamp (UNIX time) defined at the moment of generation
  • date of the object defined by the provider
  • id of the object defined by the provider
Each and every XML request is defined by such an object reference. All XML responses must copy the object reference from the request, thus the object reference is a clustered primary key!

object reference chain

As a consequence of the schema coded business logic most XML request schemas define more than just 1 object reference, e.g. a "General Invoice Request" can hold a maximum of 3 object references, namely
  • an optional credit object reference from the "General Credit Request" process
  • a mandatory invoice object reference from the initial "General Invoice Request" process
  • an optional reminder object reference given if the process encodes a reminder
whereas a "Hospital MCD Request" needs 2 object references
  • a mandatory invoice object reference from the "General Invoice Request" process
  • a mandatory mcd object reference from the " Hospital MCD Request" process
This set of object references by itself defines an ordered object reference chain (e.g. credit -> invoice -> reminder or invoice -> mcd) with the topmost object reference as unique identification of the XML request. Therefore the object reference chain defines -on business logic point of view- dependencies among different XML requests.

topmost object reference

The end node of an object reference chain is defined as topmost object reference, that is by definition the object reference of the XML request itself. Each request/response communication is always done for this topmost object reference – and only for that.

For example: a reminder XML request does reference an optional credit XML request (if the object reference was given in the initial invoice XML request). However, the reference of the initial invoice XML request for which a reminder process is started, is mandatory. The topmost object reference is then the object reference of the generated reminder process. Each XML response then references the topmost object reference for which it is a response. Such a response is never targeted for the corresponding invoice but only for the reminder!


Process attributes

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Process attributes

An XML request is primarily defined by its topmost object reference (see Purpose::Object reference). However, the XML request is further sub-characterized by a kind of process state selected from the request_subtype token list, namely

normal attribute (default)

The normal attribute defines the XML request as "normal" (initial) request.

copy attribute

The copy attribute defines the XML request as an identical copy of an initial request.

It is considered an error to send a XML request with turned on copy attribute without having prior sent a "normal" request.

refund attribute

The refund attribute acts on a normal XML infoset -notably sent and paid by the health care insurance- by setting
  • the quantity = 0 of all correctly invoiced services
  • the quantity = negated (multiplied by -1) of all invoiced services that should be refunded to the health care insurance

Consequently, the invoice amount becomes negative and its value defines the size of the planned refund towards the insurance company.
If the insurance company accepts the credit note, a response with a reimbursement element (defining the necessary payment parameters) is returned to the biller.

It is considered an error to send a XML request with turned on refund attribute without having prior sent a "normal" request.

regress attribute

The regress attribute acts on a normal invoice/reminder by setting the biller as a health care insurance. Thus defining an invoicing process between 2 health care insurances.

storno attribute

The storno acts on a prior defined "normal" XML infoset by negate all quantities in order to cancel XML request defined by the topmost reference object as a whole.
By definition the storno of an invoice/reminder is thus the same as the original XML infoset, but altered by
  • a negated quantity (multiplied by -1) of all original services
  • a negated amount_prepaid and amount_reminder (multiplied by -1)
This mechanism automatically produces negative amounts and vats.

If the storno acts on a already paid invoice/reminder, then the health care insurance sends a response with a reimbursement element (defining the necessary payment parameters) to the biller.

It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.


What is...

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

What is the difference between...

It is assumed that an original (new) invoice was produced which is further denoted as infoset1. The following list gives the difference between this infoset1 and all possible semantically different request_subtypes regarding the produced infoset.
...invoice and a copy of an invoice
infoset1 is changed insofar as the copy attribute is set (request/payload@request_subtype=copy attribute)
...invoice and a regress of an invoice
infoset1 is changed insofar as the regress attribute is set (request/payload@request_subtype=regress attribute).
Furthermore, biller content is a health care insurance thus defining an invoicing process between 2 health care insurances.
...invoice and a refund of an invoice
infoset1 is changed insofar as the refund attribute is set (request/payload@request_subtype=refund attribute).
Furthermore, all services that should be refunded are negated whereas those services that should left unchanged are multiplied by zero. As a result the service amounts changes the sign or become zero.
...invoice and a storno of an invoice
infoset1 is changed insofar as the storno attribute is set (request/payload@request_subtype=storno attribute).
Furthermore, the quantity of each service is multiplied by -1 and thus each amount changes the sign as well. The invoice storno is essentially a negated, antisymmetric normal invoice.
...invoice and a reminder
infoset1 is augmented by a reminder request object (request/payload/reminder element) to form infoset2


Notes about the signature

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Notes about the signature

XML signatures are digital signatures designed for use in XML transactions. The W3C standard defines a schema for capturing the result of a digital signature operation applied to an infoset. XML signatures add authentication, data integrity, and support for non-repudiation to the data that they sign.
However, it is beyond the scope of this documentation to explain all details of a signature or the signing process. Detailed information about all aspects of signatures can be found at W3C.

Boundary conditions and critical aspects
  • the signature is optional!
  • if an infoset is signed then the private certificate of the sender must be used and this certificate is applied to the payload element. This inherently qualifies for a detached signature.
    sender is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@from attribute.
  • the URI attribute of the reference element must use a XPointer syntax of the payload element, e.g. <ds:Reference URI="#xpointer(/invoice:request/invoice:payload)">
  • The signature algorithm is fixed to PKCS1 (RSA-SHA256) (RFC 2437: RSA Cryptography Specifications)
  • The digest algorithm is fixed to SHA-256
  • the used canonicalization algorithm must be http://www.w3.org/2001/10/xml-exc-c14n#, the exclusive XML Canonicalization
  • it is recommended to add the public key via the X509Data element such that a key store can be built at the recipient's site.

As an example the Signature element looks like
<Signature xmlns="http://www.w3.org/2000/09/xmldsig#">>
 <SignedInfo>
  <CanonicalizationMethod Algorithm="http://www.w3.org/2001/10/xml-exc-c14n#"/>
  <SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha256"/>
  <Reference URI="#xpointer(/invoice:request/invoice:payload)">
   <DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha256"/>
   <DigestValue>...</DigestValue>
  </Reference>
 </SignedInfo>
 <SignatureValue>...</SignatureValue>
 <KeyInfo>
  <X509Data>
  <X509Certificate>...</X509Certificate>
  </X509Data>
 </KeyInfo>
</Signature>


Notes about the encryption

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Notes about the encryption

XML Encryption is a specification, governed by a W3C recommendation, that defines how to encrypt the contents of an XML element. Although XML Encryption can be used to encrypt any kind of data, it is nonetheless known as "XML Encryption" because an XML element (either an EncryptedData or EncryptedKey element) contains or refers to the cipher text, keying information, and algorithms.
XML Encryption uses the KeyInfo element, which appears as the child of a EncryptedData element and provides information to a recipient about what keying material to use in decrypting encrypted data.

However, it is beyond the scope of this documentation to explain all details of a encryption or the encryption process. Detailed information about all aspects of encryption can be found at W3C.

Boundary conditions and critical aspects
  • The encryption is optional!
  • if an infoset is encrypted then the public certificate of the recipient must be used and this certificate is applied to the body element.
    recipient is used here in terms of the communication and therefore is defined as the EAN entity given in the transport@to attribute
  • The used X509 certificate for encryption must be the one with the highest serial number received by the counterpart XML so far.
    This allows for a seamless transfer to new certificates.
  • W3C's namespace http://www.w3.org/2001/04/xmlenc must be used - cf. XML Encryption Syntax and Processing
  • The encryption algorithm is fixed to PKCS1 (RSA-SHA256) (RFC 2437: RSA Cryptography Specifications)
  • The block encryption algorithm is fixed to AES-256
  • It is highly recommended to supply a comma separated serialization of the issuer (in X509 canonical form) and serial number of the public certificate in the <KeyName> element. This allows the recipient to identify the used public certificate prior the decryption process.
    This information becomes essential as soon as the validity of one certificate is running out and a new one is propagated.

As an example the EncryptedData element looks like
<EncryptedData xmlns="http://www.w3.org/2001/04/xmlenc#" Type="http://www.w3.org/2001/04/xmlenc#Element">
 <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#aes256-cbc"/>
 <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
  <EncryptedKey xmlns="http://www.w3.org/2001/04/xmlenc#">
   <EncryptionMethod Algorithm="http://www.w3.org/2001/04/xmlenc#rsa-oaep-mgf1p">
     <OAEPparams>...</OAEPparams>
     <ds:DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"/>
   </EncryptionMethod>
   <KeyInfo xmlns="http://www.w3.org/2000/09/xmldsig#">
    <KeyName>C=CH, S=ZH, L=Zurich, O=Health Insurance Company, OU=HI Manager App, serial=4E55FF58</KeyName>
   </KeyInfo>
   <CipherData>
    <CipherValue>...</CipherValue>
   </CipherData>
  </EncryptedKey>
 </KeyInfo>
 <CipherData>
  <CipherValue>...</CipherValue>
 </CipherData>
</EncryptedData>


Sequence of Sign & Crypt...

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Sequence of Sign & Crypt...

The signature and encryption boundary conditions are in detail documented in the subchapters «Purpose::Signature» and «Purpose::Encryption».
However, if both the signature and encryption processes are applied to a XML infoset it is of uttermost importance to apply the correct sequence of operation.

Sequence of operation
  1. the signature process is applied to the raw XML infoset
  2. the encryption process is applied to the signed XML infoset
Of course, the sequence of operation is reversed when a signed and encrypted XML infoset is loaded.
This sequence is required and must be obeyed otherwise the
decryption and the check of the signature validity is at risk!


Preamble of schema file

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Preamble of schema file

The preamble of the schema file is defined as follows:
<schema targetNamespace="http://www.forum-datenaustausch.ch/invoice"
        xmlns="http://www.w3.org/2001/XMLSchema"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:invoice="http://www.forum-datenaustausch.ch/invoice"
        elementFormDefault="qualified" attributeFormDefault="unqualified">
From this definition it is evident that all elements must be qualified that is defined with the namespace tag invoice followed by the element name. Furthermore, the target namespace and the specific namespace invoice maps to http://www.forum-datenaustausch.ch/invoice.
The xenc and ds namespaces are used by the encryption and signature elements which can optionally be used in an infoset.

Therefore, to define a correct XML infoset the elements must be defined like the following XML code snippet (for german as data language):
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<invoice:request xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xmlns:ds="http://www.w3.org/2000/09/xmldsig#"
        xmlns:xenc="http://www.w3.org/2001/04/xmlenc#"
        xmlns:invoice="http://www.forum-datenaustausch.ch/invoice"
        xmlns="http://www.forum-datenaustausch.ch/invoice"
        xsi:schemaLocation="http://www.forum-datenaustausch.ch/invoice generalInvoiceRequest_500.xsd"
        language="de" modus="production" validation_status="0" >
XML elements go here...

 </invoice:request>


Defined service attributes

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Defined service attributes

The definition of each service record includes an attribute "service_attributes". Each bit of that 32-bit value has a special meaning which is defined below.
The bit positions can be ANDed together to form the overall refinement/enhancement of a given service.

Defined bit positions as of May 2023
Bit Meaning
Bit 1 (0x000001) Code207: no drug substitution due to medical reasons. Applies to drug services only!
If this bit ("Code207") is set, the service provider declares that the drug prescribed must not be substituted due to medical reasons.
Bit 2 (0x000002) franchiseFree: Franchise exemption of given service
If this bit ("franchiseFree") is set, the service provider declares that the service was provided as franchise free.
Bit 3 (0x000004) drugOffLabelUse: off label use of a drug in accordance with Art. 71a-c KVV
If this bit ("drugOffLabelUse") is set, the service provider declares that the off-label prescription of the drug has been approved by the healthcare insurance by means of a prior accepted credit request.


Defined regulation attributes

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Defined regulation attributes

If role=enRolePharmacist then additional data must be supplied for each drug service record. One part of this additional data is "regulation_attributes" defined as 32-bit integer. Each bit position has a special meaning defined below. The bit positions can be ANDed together to form the overall refinement/enhancement of the regulation attribute coding.

Defined bit positions as of October 2022
Bit Code Meaning
Bit 1 (0x000001) code 100 "Nicht-SL Produkt ist vom Vertrauensarzt bewilligt worden"
"Produit non LS a été autorisé par le médecin-conseil"
Bit 2 (0x000002) code 101 "Notfall: Abgabe eines anderen Produktes als auf dem Rezept"
"Cas d'urgence: remise d'un autre produit que celui figurant sur l'ordonnance"
Bit 3 (0x000004) code 102 "Abgabe eines anderen Produktes als auf dem Rezept in Rücksprache mit dem Arzt"
"Remise d'un autre produit, après consultation du médecin, que celui figurant sur l'ordonnance"
Bit 4 (0x000008) code 103 "Abgabe einer grösseren Packung (nicht-SL) anstelle von mehreren kleineren Packungen (SL)"
"Remise d'un emballage plus grand (non LS) en lieu et place de plusieurs emballages plus petits (LS)"
Bit 5 (0x000010) code 104 "Abgabe einer kleineren Anzahl Packungen als verschrieben"
"Remise d'un nombre moins élevé d'emballages que le nombre prescrit"
Bit 6 (0x000020) code 105 "Abgabe einer kleineren Packung als verschrieben"
"Remise d'un plus petit emballage que la grandeur prescrite"
Bit 7 (0x000040) code 106 "SL-Limitation vom Vertrauensarzt aufgehoben"
"Limitation LS supprimée par le médecin-conseil"
Bit 8 (0x000080) code 107 "Lehnt der Arzt oder die Ärztin beziehungsweise der Chiropraktor oder die Chiropraktorin aus medizinischen Gründen eine Substitution des Originalpräparats ab, so kommt der Selbstbehalt von 20% nicht zur Anwendung."
"Refus de substitution du médicament original par le médecin ou le chiropraticien pour raisons médicales - 20% de participation ne s'applique pas."
Bit 9 (0x000100) code 108 "Lehnt der Apotheker oder die Apothekerin aus medizinischen Gründen eine Substitution des Originalpräparats ab, so kommt der Selbstbehalt von 20% nicht zur Anwendung."
"Refus de substitution du médicament original par le pharmacien ou la pharmacienne pour raisons médicales - 20% de participation ne s'applique pas."
Bit 10 (0x000200) code 109 "Dem Apotheker liegt eine Kostengutsprache nach Art. 71a-c KVV vor."
"Le pharmacien dispose d'une garantie de prise en charge des coûts selon l'art. 71a-c OAMal."


Rules for the rounding procedure

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Rules for the rounding procedure

The Forum Datenaustausch defines a couple of axiomatic rounding rules that apply to amounts.

These rounding rules are:

  • the amount of a service is calculated by the formula
    «amount = external_factor * quantity * TP * TPV * scale_factor»
    in full precision and the result is rounded to 2 significant decimal places.
  • for Tarmed services this is done for the medical and technical part independently and the amount is formed as
    amount = amount_mt + amount_tt
  • the total amount (balance@amount) is the sum over all 2-digit precision service amounts. Therefore, the amount implicitly has a 2-digit precision as well.
  • balance@amount_prepaid and balance@amount_reminder are rounded to 2 significant decimal places.
  • balance@amount_due is calculated by the formula
    «amount_due = amount - amount_prepaid + amount_reminder»
    and the result is rounded half up.
Please note, that the rounding error dx made in rounding a given number x to 2 significant decimal places is dependent on the magnitude of x. As a consequence this rounding error is not linear. It is in general not true that
n*dx(i) == dx(tot) for n>1
where dx(i) is the individual error and dx(tot) is the rounding error of total x(tot) = n*x(i) .

For instance for n=2 and x=1.0025 this results in
1.0025 -> 1.00 and 2*1.00 = 2.00
and
2*1.0025 = 2.005 -> 2.01


Hierarchical list of used XSD definitions

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Hierarchical list of used XSD definitions

The following subchapters list all XSD definitions of the schema in hierarchical order going from the topmost element request down as the appropriate definition is encountered.


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

element request

Annotation The request element is the root of the generalInvoiceRequest process.
The request is divided into 2 parts
  • the processing element supplies the necessary data for the transport and for actions done at the intermediate's site (e.g. printing a patient copy)
  • the payload element supplies the invoice/reminder data which will not be altered by intermediates
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:requestType
properties
content complex
children | invoice:processing invoice:payload ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
validation_status | long
attributes annotations
Name Notes
language language defines the used data language (name of the services etc.) encoded by a terminal set of ISO language specifiers. All responses will be encoded in the same language.
  • de: the data language is german
  • fr: the data language is french
  • it: the data language is italian
modus modus defines the operating modus encoded by a terminal set of tokens
  • production: the modus production (default value) is for normal processing
  • test: the modus test is for software developers to test the processing
    By definition there must not be any money flow!
validation_status validation_status defines the validity status of XML infoset after the infoset is generated and validated by a DOM. 0 or absence of the attribute means OK.
It is possible to knowingly encode an XML infoset that is well formed but invalid regarding its content (wrong regarding business rules). validation_status then signals such an error condition to the recipient.
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus NMTOKEN test the modus test is for software developers to test the processing
By definition there must not be any money flow!
source | <element name="request" type="invoice:requestType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element requestType/processing

Annotation | The processing element is a container for processing instructions primarely at an intermediate's site (e.g. printing a patient copy, transport routing etc.).
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:processingType
properties
isRef | 0
content | complex
children | invoice:transport invoice:instructions
attributes parameters
Name | Type | Use | Default | Fixed
print_copy_to_guarantor | boolean | false
send_copy_to_trustcenter | invoice:glnPartyType
send_tgcopy_to_portal | invoice:restCallType
define_gln_printcenter | invoice:glnPartyType | 2005555555003
define_gln_norecipient | invoice:glnPartyType | 2006666666008
attributes annotations
Name Notes
print_copy_to_guarantor print_copy_to_guarantor is a Boolean instruction for the first intermediate (the functionality is potentially cost-dependent) regarding a printed copy of the invoice to the guarantor's address, basically to fullfill the legal requirement of a "patient copy".

The attribute has a meaning only in a genuine normal invoice process of a Tiers Payant case. Therefore, the attribute must be discarded for all other Tiers systems and all other process types e.g. a reminder, storno, copy etc.

It should be noted that

  • this process is to be considered as 2nd process. Therefore, it is carried out with the best effort and without the possibility of error propagation to the sender. Under all circumstances, the processing of the 1st process (the delivery to transport@from) must not be affected by a potentially occurring error in the 2nd process!
  • all attachments of the XML infoset are ignored and not printed
send_copy_to_trustcenter send_copy_to_trustcenter instructs the 1st intermediate to send a copy of the XML infoset to the defined trust center.

It should be noted that

  • this process is to be considered as 2nd process. Therefore, it is carried out with the best effort and without the possibility of error propagation to the sender. Under all circumstances, the processing of the 1st process (the delivery to transport@from) must not be affected by a potentially occurring error in the 2nd process!
send_tgcopy_to_portal send_tgcopy_to_portal instructs the 1st intermediate to send a copy of the current TG XML infoset as well as the supplied parameters to the defined portal using a pseudo Restful Webservice syntax: e.g. https://portal.address.com/putCopy?biller=gln&insurance=gln&guid=guid.
Of course, the intermediate has to effectively transform the pseudo Restful service call into a POST Multiform/Form-Data call as defined below to transmit the XML infoset as well:

POST https://portal.address.com/putCopy HTTP/1.1
Accept: application/json
Content-Type: multipart/form-data;
boundary=A_UNIQUE_BOUNDARY_28947758029299
Content-Disposition: form-data; name="application/json"
{
"biller": "biller_gln",
"insurance": "insurance_gln",
"guid": "guid_value"
}
A_UNIQUE_BOUNDARY_28947758029299
Content-Disposition: form-data; name="name"; filename="tg_invoicerequest.xml"
Content-Type: application/xml
....here comes the xml infoset
A_UNIQUE_BOUNDARY_28947758029299

Please note as well, that if such a copy is performed than the counter restfulCall with getCopy (e.g. https://portal.address.com/getCopy?biller=gln&insurance=gln&guid=guid) is inserted into the QR code of the 'Rückerstattungsbeleg', such that the insurance company can scan the QR code to get all possibilities (one such possibility is the portal-fetch command) of fetching the original XML infoset.
define_gln_printcenter define_gln_printcenter defines the GLN for an abstract functionality, namely the print center, such that transport@to can be populated with this GLN and the first intermediate can be mandatorily instructed to print the XML infoset.

It should be noted that this print instruction must be performed by the 1st intermediate (the functionality is potentially cost-dependent), regardless of the chosen tiers system (i.e. TG, TS or TP).

define_gln_norecipient define_gln_norecipient defines the GLN for an abstract functionality, namely the non-delivery, such that transport@to is by definition defined as a non-existing party, which basically means that the first intermediate but at least the last intermediate must throw away the XML infoset without generating an error!

It should be noted that

  • it should be noted that at the 1st intermediate must be performed all 2nd processes, before the handover to the next intermediary hop or the final delivery to transport@to takes place.
that all 2nd processes must be . Therefore, it is carried out with the best effort and without the possibility of error propagation to the sender. Under all circumstances, the processing of the 1st process (the delivery to transport@from) must not be affected by a potentially occurring error in the 2nd process!
  • all attachments of the XML infoset are ignored and not printed
    • source | <element name="processing" type="invoice:processingType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element processingType/transport

Annotation | The transport element defines the routing of the infoset going from a sender party over any number of intermediates to a receiver party. All the involved parties are defined by Global Location Numbers (GLN) as defined by RefData
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:transportType
properties
isRef | 0
content | complex
children | invoice:via
attributes parameters
Name | Type | Use | Default | Fixed
from | invoice:glnPartyType | required
to | invoice:glnPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the XML infoset to the first defined intermediate
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the XML infoset from the last defined intermediate.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source | <element name="transport" type="invoice:transportType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element transportType/via

Annotation The optional via element defines one intermediate hop through which the XML infoset is routed.
It is in accordance with the standard that an intermediate -due to a technical necessity- can change the remaining list of intermediate hops in order to guarantee the delivery of the final recipient.
diagram
namespace http://www.forum-datenaustausch.ch/invoice
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
via | invoice:glnPartyType | required
sequence_id | unsignedShort | required
attributes annotations
Name | Notes
via | via is the GLN of an intermediate
sequence_id | sequence_id is a sequence number starting with 1 that defines a certain intermediate hop. In each new via element the sequence number is increased by 1 thus forming a chain of intermediate hops
source <element name="via" minOccurs="0" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="invoice:glnPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element processingType/instructions

Annotation The optional instructions container holds a set of instruction elements, each consisting of a token/value pair.

Note, that the semantic, grammar and nomenclature of these instructions are unstandardized and bilateral in nature between biller and debitor.

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:instructionsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:instruction
source | <element name="instructions" type="invoice:instructionsType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element instructionsType/instruction

Annotation The instruction element defines one specific instruction.

Note, that the semantic, grammar and nomenclature of such an instruction is unstandardized and bilateral in nature between biller and debitor.

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:instructionType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
token | invoice:stringType1_255 | required
value | invoice:stringType1_255 | required
attributes annotations
Name | Notes
token | token is the name of the token/value instruction coded as a string.
value | value is the value of the token/value instruction coded as a string.
source | <element name="instruction" type="invoice:instructionType" maxOccurs="unbounded"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element requestType/payload

Annotation | The payload element supplies the invoice/reminder data and will not be altered in the transport process. The payload can optionally be signed by at W3C signing process.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:payloadType
properties
isRef | 0
content | complex
children | invoice:credit invoice:invoice invoice:reminder invoice:body xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
request_type | derived by: NMTOKEN | invoice
request_subtype | derived by: NMTOKEN | normal
attributes annotations
Name Notes
request_type request_type defines the principle type of request encoded by a terminal set of tokens
  • invoice: the request is of type invoice
  • reminder: the request is of type reminder
request_subtype request_subtype specifies the XML infoset with respect to its modification from the standard data space. Such a modification can be seen as a request variation, subsuming a specific data set, where the set of discrete subtypes is encoded by a terminal set of tokens.
  • normal: normal defines the standard (normal) XML infoset describing an ordinary invoice/reminder
  • copy: copy qualifies the XML infoset as the exact copy of a previously defined XML infoset except for the copy flag.
  • refund: refund acts on a normal XML infoset -notably sent to and paid by a health care insurance- by setting
    • the quantity = 0 of all correctly invoiced services
    • the quantity = negated (multiplied by -1) of all invoiced services that should be refunded to the health care insurance
    • the topmost object reference is the one from the normal XML infoset

    Consequently, the invoice amount becomes negative and its value defines the size of the planned refund towards the insurance company.
    If the insurance company accepts the credit note, a response with a reimbursement element (defining the necessary payment parameters) is returned to the biller.

  • regress: regress acts on a normal invoice/reminder by setting the biller as a health care insurance. Thus defining an invoicing process between 2 health care insurances.
  • storno: storno acts on a prior defined normal XML infoset by negate all quantities in order to cancel the XML request defined by the topmost reference object as a whole.
    By definition the storno of an invoice/reminder is thus the same as the original XML infoset, but altered by
    • a negated quantity (multiplied by -1) of all original services
    • a negated amount_prepaid and amount_reminder (multiplied by -1)
    This mechanism automatically produces negative amounts and vats.

    If the storno acts on a already paid invoice/reminder, then the health care insurance sends a response with a reimbursement element (defining the necessary payment parameters) to the biller.

    It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.

attributes enumerations
Name | Extension | Base | Value | Annotations
request_subtype | NMTOKEN | normal | normal defines the standard (normal) XML infoset describing an ordinary invoice/reminder (Default)
request_subtype | NMTOKEN | copy | copy qualifies the XML infoset as the exact copy of a previously defined XML infoset except for the copy flag.
request_subtype | NMTOKEN | refund | refund acts on a normal XML infoset, notably sent to and paid by a health care insurance
request_subtype | NMTOKEN | regress | regress acts on a normal invoice/reminder by setting the biller as a health care insurance. Thus defining an invoicing process between 2 health care insurances.
request_subtype | NMTOKEN | storno | storno acts on a prior defined normal XML infoset by negate all quantities in order to cancel the invoice/reminder as a whole.
request_type | NMTOKEN | invoice | the request is of type invoice
request_type | NMTOKEN | reminder | the request is of type reminder
source | <element name="payload" type="invoice:payloadType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payloadType/credit

Annotation | The credit element defines the credit object reference that is copied from a prior sent "General Credit Request". Of course, there is no credit element if none was defined and sent before.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:creditType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | invoice:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the credit's infoset generation
This is one of 3 identifiers that form the credit object reference. request_timestamp will be generated once for a new credit object reference and thereafter always referenced!
request_date request_date is the main software's date of the credit request ("KoGu Falldatum")
This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id request_id is the main software's ID of the credit request ("KoGu Fallnummer")
This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source | <element name="credit" type="invoice:creditType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payloadType/invoice

Annotation The invoice element defines the unique invoice object reference.
This object is firstly produced when generating the original invoice. Any further processing (sending a copy or canceling the invoice) as well as generating a reminder to the invoice references this same object unaltered!
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:invoiceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | invoice:stringType1_35 | required
guid | invoice:guidType | required
attributes annotations
Name | Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the invoice's infoset generation
This is one of 3 identifiers that form the invoice object reference. request_timestamp will be generated once for a new invoice object reference and thereafter always referenced!
request_date request_date is the main software's date of the invoice request ("Rechnungsdatum")
This is one of 3 identifiers that form the invoice object reference. request_date must be identical for the same invoice object reference!
request_id request_id is the main software's ID of the invoice request ("Rechnungsnummer")
This is one of 3 identifiers that form the invoice object reference. request_id must be identical for the same invoice object reference!
guid | guid is an internally used unique identifier of the current XML infoset defined as a 32-character string
source | <element name="invoice" type="invoice:invoiceType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payloadType/reminder

Annotation The reminder element defines the unique reminder object. The corresponding invoice must be specified in the invoice object reference. Of course, there is no reminder element if the infoset defines an invoice.
This object is firstly produced when generating the first reminder (reminder level 1). Any further processing (increasing the reminder level, sending a copy or canceling the reminder) uses this same object unaltered!
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:reminderType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | invoice:stringType1_35 | required
guid | invoice:guidType | required
reminder_level | derived by: NMTOKEN | 1
reminder_text | invoice:stringType1_700
attributes annotations
Name | Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the reminder's infoset generation
This is one of 3 identifiers that form the reminder object reference. request_timestamp will be generated once for a new reminder object reference and thereafter always referenced!
request_date request_date is the main software's date of the reminder request ("Mahndatum")
This is one of 3 identifiers that form the reminder object reference. request_date must be identical for the same reminder object reference!
request_id request_id is the main software's ID of the reminder request ("Mahnnummer")
This is one of 3 identifiers that form the reminder object reference. request_id must be identical for the same reminder object reference!
guid | guid is an internally used unique identifier of the current XML infoset defined as a 32-character string
reminder_level reminder_level is the level of the reminder starting with 1 and ending with 3 encoded by a terminal set of tokens
  • 1: the level of the reminder is 1 (default)
  • 2: the level of the reminder is 2
  • 3: the level of the reminder is 3
reminder_text | reminder_text is a the reminder text formed as normal ASCII text string
attributes enumerations
Name | Extension | Base | Value | Annotations
reminder_level | NMTOKEN | 1 | the level of the reminder is 1 (default)
reminder_level | NMTOKEN | 2 | the level of the reminder is 2
reminder_level | NMTOKEN | 3 | the level of the reminder is 3
source | <element name="reminder" type="invoice:reminderType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payloadType/body

Annotation | The body element contains all the invoice/reminder data including the highly sensitive patient data (data privacy relevant). Therefore the body element can be replaced by the encrypted counterpart xenc:EncryptedData
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:bodyType
properties
isRef | 0
content | complex
children | invoice:prolog invoice:remark invoice:tiers_garant invoice:tiers_soldant invoice:tiers_payant invoice:esrQR invoice:esrQRRed invoice:law invoice:treatment invoice:services invoice:documents
attributes parameters
Name | Type | Use | Default | Fixed
role_title | invoice:stringType1_35
role | derived by: NMTOKEN | required
place | derived by: NMTOKEN | required
attributes annotations
Name | Notes
role role defines the principal role of the main provider ("what is the main provider") encoded by a terminal set of tokens
  • physician: the principal role of the service provider is physician
  • physiotherapist: the principal role of the service provider is physiotherapist including therapeutic masseurs
  • chiropractor: the principal role of the service provider is chiropractor
  • ergotherapist: the principal role of the service provider is ergotherapist
  • nutritionist: the principal role of the service provider is nutritionist including diet advisors, diabetic advisors
  • midwife: the principal role of the service provider is midwife
  • logotherapist: the principal role of the service provider is logotherapist
  • hospital: the principal role of the service provider is hospital
  • pharmacist: the principal role of the service provider is pharmacist
  • dentist: the principal role of the service provider is dentist including dental hygienists
  • labtechnician: the principal role of the service provider is labtechnician
  • dentaltechnician: the principal role of the service provider is dentaltechnician
  • othertechnician: the principal role of the service provider is othertechnician including shoemakers
  • psychologist: the principal role of the service provider is psychologist
  • wholesaler: the principal role of the service provider is wholesaler
  • nursingstaff: the principal role of the service provider is nursing staff including nursing auxiliaries
  • transport: the principal role of the service provider is transport including ambulances
  • druggist: the principal role of the service provider is druggist
  • naturopathicdoctor: the principal role of the service provider is naturopathic doctor (as per definition this is a doctor of none-conventional Western medicine/none-biomedicine)
  • naturopathictherapist: the principal role of the service provider is naturopathic therapist (as per definition this is therapist none-conventional Western medicine/none-biomedicine) including wellness therapists
  • other: the principal role of the service provider is other if none of the above applies
role_title | role_title optionally further defines the role. role_title is mandatory if the role=other is set!
place place defines the principal place of the main provider ("where is the main provider") encoded by a terminal set of tokens
  • practice: the main place of the service provision is at a practice
  • hospital: the main place of the service provision is at a hospital
  • lab: the main place of the service provision is at a lab
  • association: the main place of the service provision is at a association (e.g. Spitex)
  • company: the main place of the service provision is by a company (e.g. transports)
attributes enumerations
Name | Extension | Base | Value | Annotations
place | NMTOKEN | practice | the main place of the service provision is at a practice
place | NMTOKEN | hospital | the main place of the service provision is at a hospital
place | NMTOKEN | lab | the main place of the service provision is at a lab
place | NMTOKEN | association | the main place of the service provision is at a association (e.g. Spitex)
place | NMTOKEN | company | the main place of the service provision is by a company (e.g. transports)
role | NMTOKEN | physician | the principal role of the service provider is physician
role | NMTOKEN | physiotherapist | the principal role of the service provider is physiotherapist including therapeutic masseurs
role | NMTOKEN | chiropractor | the principal role of the service provider is chiropractor
role | NMTOKEN | ergotherapist | the principal role of the service provider is ergotherapist
role | NMTOKEN | nutritionist | the principal role of the service provider is nutritionist including diet advisors, diabetic advisors
role | NMTOKEN | midwife | the principal role of the service provider is midwife
role | NMTOKEN | logotherapist | the principal role of the service provider is logotherapist
role | NMTOKEN | hospital | the principal role of the service provider is hospital
role | NMTOKEN | pharmacist | the principal role of the service provider is pharmacist
role | NMTOKEN | dentist | the principal role of the service provider is dentist including dental hygienists
role | NMTOKEN | labtechnician | the principal role of the service provider is labtechnician
role | NMTOKEN | dentaltechnician | the principal role of the service provider is dentaltechnician
role | NMTOKEN | othertechnician | the principal role of the service provider is othertechnician including shoemakers
role | NMTOKEN | psychologist | the principal role of the service provider is psychologist
role | NMTOKEN | wholesaler | the principal role of the service provider is wholesaler
role | NMTOKEN | nursingstaff | the principal role of the service provider is nursing staff including nursing auxiliaries
role | NMTOKEN | transport | the principal role of the service provider is transport including ambulances
role | NMTOKEN | druggist | the principal role of the service provider is druggist
role | NMTOKEN | naturopathicdoctor | the principal role of the service provider is naturopathic doctor (as per definition this is a doctor of none-conventional Western medicine/none-biomedicine)
role | NMTOKEN | naturopathictherapist | the principal role of the service provider is naturopathic therapist (as per definition this is therapist none-conventional Western medicine/none-biomedicine) including wellness therapists
role | NMTOKEN | other | the principal role of the service provider is other if none of the above applies
source | <element name="body" type="invoice:bodyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/prolog

Annotation | The prolog element is a container that holds information about all involved software that eventually generated the infoset (XML generator, tariff validators, and main software).
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:prologType
properties
isRef | 0
content | complex
children | invoice:package invoice:generator
source | <element name="prolog" type="invoice:prologType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element prologType/package

Annotation | The package element defines the main software that supplies all data for the infoset
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:softwareType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | invoice:stringType1_50 | required
copyright | invoice:stringType1_50
description | invoice:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="package" type="invoice:softwareType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element softwareType/depends_on

Annotation The depends_on element defines a dependence upon a further software/module.
The dependence chain allows the definition of all involved software/modules that participated in the generation process.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:dependsOnType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
name | invoice:stringType1_50 | required
copyright | invoice:stringType1_50
description | invoice:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source | <element name="depends_on" type="invoice:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element prologType/generator

Annotation The generator element defines the infoset generator.
It is assumed that there is an architectural distinction between package (main software) and generator like in a Sumex1 environment. If this is not the case then just define the same data here as in the package element.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:softwareType
properties
isRef | 0
content | complex
children | invoice:depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | invoice:stringType1_50 | required
copyright | invoice:stringType1_50
description | invoice:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source | <element name="generator" type="invoice:softwareType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/remark

Annotation | The remark element supplies an optional remark for the invoice/reminder
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_350
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 350
source | <element name="remark" type="invoice:stringType1_350" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/tiers_garant

Annotation | The tiers_garant element defines the invoice/reminder running under Tiers Garant (TG)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:garantType
properties
isRef | 0
content | complex
children | invoice:biller invoice:debitor invoice:providers invoice:insurance invoice:patient invoice:guarantor invoice:referrer invoice:employer invoice:balance
source | <element name="tiers_garant" type="invoice:garantType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element garantType/biller

Annotation | The biller address element defines the biller or creditor in an invoice/reminder process.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:billerAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
uid_number | invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the biller's GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the treatment is carried out by the patient himself or a relative of the patient.
uid_number uid_number is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789
source | <element name="biller" type="invoice:billerAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element billerAddressType/company

Annotation | The biller is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:companyType
properties
isRef | 0
content | complex
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
source | <element name="company" type="invoice:companyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element companyType/companyname

Annotation | The companyname element supplies the name of a company
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="companyname" type="invoice:stringType1_35"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element companyType/department

Annotation | The department element supplies the name of a the involved department of a company
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="department" type="invoice:stringType1_35" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element companyType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="invoice:stringType1_35" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element companyType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:postalAddressType
properties
isRef | 0
content | complex
children | invoice:pobox invoice:street invoice:zip invoice:city invoice:country
source | <element name="postal" type="invoice:postalAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element postalAddressType/pobox

Annotation | The pobox element supplies the post office box part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="pobox" type="invoice:stringType1_35" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element postalAddressType/street

Annotation | The street element supplies the full street part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:streetType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
facets
minLength | 1
maxLength | 35
attributes parameters
Name | Type | Use | Default | Fixed
house_no | invoice:stringType1_9
attributes annotations
Name | Notes
house_no | house_no is the optional house number included in the street definition. Please note that the house number is an extracted copy from the full street definition.
source | <element name="street" type="invoice:streetType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element postalAddressType/zip

Annotation | The zip element supplies the zip part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:zipType
properties
isRef | 0
content | complex
facets
minLength | 1
maxLength | 9
attributes parameters
Name | Type | Use | Default | Fixed
statecode | invoice:stringType1_9
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
source | <element name="zip" type="invoice:zipType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element postalAddressType/city

Annotation | The city element supplies the city part of the postal address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="city" type="invoice:stringType1_35"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element postalAddressType/country

Annotation | The country element supplies the country part of the postal address.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:countryType
properties
isRef | 0
content | complex
facets
minLength | 0
maxLength | 35
attributes parameters
Name | Type | Use | Default | Fixed
countrycode | invoice:stringType1_3 | CH
attributes annotations
Name | Notes
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
source | <element name="country" type="invoice:countryType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element companyType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:phone
source | <element name="telecom" type="invoice:telecomAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element telecomAddressType/phone

Annotation | The phone element supplies a telephone number (either landline or mobile)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_25
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 25
source | <element name="phone" type="invoice:stringType1_25" maxOccurs="3"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element companyType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:email invoice:uri
source | <element name="online" type="invoice:onlineAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element onlineAddressType/email

Annotation | The email element supplies an email address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of invoice:stringType1_80
properties
isRef | 0
minOcc | 1
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 80
pattern .+@.+
source <element name="email" maxOccurs="3">
<simpleType>
<restriction base="invoice:stringType1_80">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element onlineAddressType/uri

Annotation | The uri element supplies any URI defined address (e.g. a homepage, facebook or twitter account etc.)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of anyURI
properties
isRef | 0
minOcc | 0
maxOcc | 3
content | simple
facets
minLength | 1
maxLength | 160
source <element name="uri" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="160"/>
</restriction>
</simpleType>
</element>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element billerAddressType/person

Annotation | The biller is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element personType/familyname

Annotation | The familyname element supplies the family name (or last name) of a person
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="familyname" type="invoice:stringType1_35"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element personType/givenname

Annotation | The givenname element supplies the forename or first name of a person
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_35
properties
isRef | 0
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="givenname" type="invoice:stringType1_35"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element personType/subaddressing

Annotation | The subaddressing element supplies further special information of a full address (e.g. c/o information and the like)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:stringType1_35
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
facets
minLength | 1
maxLength | 35
source | <element name="subaddressing" type="invoice:stringType1_35" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element personType/postal

Annotation | The postal element depicts the postal part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:postalAddressType
properties
isRef | 0
content | complex
children | invoice:pobox invoice:street invoice:zip invoice:city invoice:country
source | <element name="postal" type="invoice:postalAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element personType/telecom

Annotation | The telecom element depicts the telecom related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:telecomAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:phone
source | <element name="telecom" type="invoice:telecomAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element personType/online

Annotation | The online element depicts the online related part of a full address
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:onlineAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:email invoice:uri
source | <element name="online" type="invoice:onlineAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element garantType/debitor

Annotation | The debitor address element defines the deptor in an invoice/reminder process
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:debitorAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
uid | invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the debitor's GLN number as defined by RefData
Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789

Please note, that the UID is optional and possibly defined for legal entities. Thus the UID is always empty for natural persons.
source | <element name="debitor" type="invoice:debitorAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element debitorAddressType/company

Annotation | The debitor is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:companyType
properties
isRef | 0
content | complex
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
source | <element name="company" type="invoice:companyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element debitorAddressType/person

Annotation | The debitor is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element garantType/providers

Annotation | The providers element is the container holding the different flavors of the provider definitions basically differing in the unique key like GLN or ZSR
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:providersAddressType
properties
isRef | 0
content | complex
children | invoice:provider_gln invoice:provider_zsr
source | <element name="providers" type="invoice:providersAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element providersAddressType/provider_gln

Annotation | The provider_gln element defines the provider's address and its mandatory GLN.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:providerGLNAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
main_treating_provider | invoice:stringType1_100
gln | invoice:glnPartyType | required
gln_location | invoice:glnPartyType | required
attributes annotations
Name | Notes
main_treating_provider | The optional main_treating_provider is the full name of the case leading provider should that name be different from the one given in the address section
gln The gln is the provider's required GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the treatment is carried out by the patient himself or a relative of the patient.
gln_location | The gln_location codes the provider's workplace by a required GLN as defined by RefData If there is no such specific workplace then input the gln as the location gln basically defining the default location.
source | <element name="provider_gln" type="invoice:providerGLNAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element providerGLNAddressType/company

Annotation | The provider is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:companyType
properties
isRef | 0
content | complex
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
source | <element name="company" type="invoice:companyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element providerGLNAddressType/person

Annotation | The provider is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element providersAddressType/provider_zsr

Annotation | The optional provider_zsr element defines the provider's address and its mandatory ZSR number.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:providerZSRAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
zsr | invoice:zsrPartyType | required
attributes annotations
Name | Notes
zsr | zsr is the provider's required ZSR as defined by Santésuisse
source | <element name="provider_zsr" type="invoice:providerZSRAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element providerZSRAddressType/company

Annotation | The provider is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:companyType
properties
isRef | 0
content | complex
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
source | <element name="company" type="invoice:companyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element providerZSRAddressType/person

Annotation | The provider is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element garantType/insurance

Annotation | The insurance address element is the insurance, that is the party that provides the insurance protection.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:insuranceAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
attributes annotations
Name | Notes
gln | gln is the insurance's GLN as defined by RefData
source | <element name="insurance" type="invoice:insuranceAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element insuranceAddressType/company

Annotation | The insurance is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:companyType
properties
isRef | 0
content | complex
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
source | <element name="company" type="invoice:companyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element insuranceAddressType/person

Annotation | The insurance is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element garantType/patient

Annotation | The patient address element defines the patient with all relevant data
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:patientAddressType
properties
isRef | 0
content | complex
children | invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
sex | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn | invoice:ssnPartyType | required
mpi | invoice:stringType1_35
attributes annotations
Name | Notes
gender gender defines the social gender encoded by a terminal set of tokens
  • male: the patient decides to have a gender of male
  • female: the patient decides to have a gender of female
  • diverse: the patient decides to have a gender of diverse
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
birthdate | birthdate defines the birthdate of the patient
ssn the required ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
If for any reasons the SSN of the patient is unknown, than the unknownSSN = 7569999999991 must be defined to satisfy the schema validity!

Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
mpi | the optional mpi defines the forthcoming 'Master-Patient-Index' uniquely defining a patient in Switzerland/Liechtenstein by this index key.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the patient decides to have a gender of male
gender | NMTOKEN | female | the patient decides to have a gender of female
gender | NMTOKEN | diverse | the patient decides to have a gender of diverse
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
source | <element name="patient" type="invoice:patientAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element patientAddressType/person

Annotation | The patient's address given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element garantType/guarantor

Annotation | The guarantor address element is the legal representative of the patient. In most cases the guarantor is therefore the patient himself, in other situations it might be the parents of the patient or another officially mandated person/institution.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:guarantorAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType
uid | invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the guarantors's GLN number as defined by RefData
Please note, that the GLN is optional, because a GLN is not assigned to all entities Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789

Please note, that the UID is optional and possibly defined for legal entities. Thus the UID is always empty for natural persons.
source | <element name="guarantor" type="invoice:guarantorAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element guarantorAddressType/company

Annotation | The guarantor is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:companyType
properties
isRef | 0
content | complex
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
source | <element name="company" type="invoice:companyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element guarantorAddressType/person

Annotation | The guarantor is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element garantType/referrer

Annotation | The referrer address element defines an optional referrer who has referred the patient to the main provider.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:referrerAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
zsr | invoice:zsrPartyType
attributes annotations
Name | Notes
gln | gln is the referrer's GLN as defined by RefData
zsr | zsr is the referrer's ZSR as defined by Santésuisse
source | <element name="referrer" type="invoice:referrerAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element referrerAddressType/company

Annotation | The referrer is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:companyType
properties
isRef | 0
content | complex
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
source | <element name="company" type="invoice:companyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element referrerAddressType/person

Annotation | The referrer is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element garantType/employer

Annotation | The employer address element defines the employer of the patient (the employer might be important in an UVG case)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:employerAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType
reg_number | invoice:stringType1_35
attributes annotations
Name | Notes
gln | gln is the employer's GLN as defined by RefData
reg_number | reg_number is the employer's national BUR number as defined by Swiss Federal Statistical Office
source | <element name="employer" type="invoice:employerAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element employerAddressType/company

Annotation | The employer is a legal entity defined by a company address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:companyType
properties
isRef | 0
content | complex
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
source | <element name="company" type="invoice:companyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element employerAddressType/person

Annotation | The employer is a natural person defined by the person address element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element garantType/balance

Annotation | The balance element supplies all money and vat relevant information in the Tiers Garant (TG) case.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:balanceTGType
properties
isRef | 0
content | complex
children | invoice:vat
attributes parameters
Name | Type | Use | Default | Fixed
currency | string | CHF
amount | double | required
amount_reminder | double | 0
amount_prepaid | double | 0
amount_due | double | required
attributes annotations
Name | Notes
currency | currency is the currency used for the whole invoice/reminder. The currency is fixed by the XSD schema to "CHF" - Swiss Francs!
amount | amount is the total amount for the invoice/reminder accumulated over all 2-digit precision service amounts. Therefore, the amount implicitly has a 2-digit precision as well.
amount_reminder amount_reminder is an optional reminder charge rounded to 2 significant decimal places.
Of course, if the request is an invoice amount_reminder must be 0.00.
amount_prepaid | amount_prepaid is the advanced payment for the invoice/reminder rounded to 2 significant decimal places.
amount_due amount_due is the amount due for the invoice/reminder (and coded into the ESR payment transaction) calculated as
«amount + amount_reminder - amount_prepaid»

where the used summands are 2-digit precision amounts and the result is finally rounded half up ("Kaufmännisches Runden")
source | <element name="balance" type="invoice:balanceTGType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element balanceTGType/vat

Annotation | The vat element defines all vat related data as requested by the "Swiss Federal Tax Administration"
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:vatType
properties
isRef | 0
content | complex
children | invoice:vat_rate
attributes parameters
Name | Type | Use | Default | Fixed
vat_number | invoice:stringType1_15
vat | double | required
attributes annotations
Name | Notes
vat_number vat_number is the individual vat number of the biller as given by the "Swiss Federal Tax Administration". Both forms the old 6-digit number as well as the new UID dependent number is allowed. However, the electronic layout of the number must be supplied as suggested by the federal administration. In the electronic layout all punctuation characters ('-' and '.') as well as the language dependent attribute in the new form ('MWST','IVA', 'TVA') are striped.
Consequently, the vat number must be expanded appropriately prior to be printed, e.g.
  • Old vat number: electronic layout 799000 is printed as 799.000
  • New vat number: electronic: CHE123456789 is printed as CHE-123.456.789 MWST (for german language!)

Of course, if the biller has not been assigned such a vat number leave the field empty.
vat | vat is the overall vat portion for the invoice/reminder accumulated over 2-digit precision individual vats.
source | <element name="vat" type="invoice:vatType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element vatType/vat_rate

Annotation The vat_rate element defines the calculated vat for a given amount and a specific vat rate.
The "Swiss Federal Tax Administration" requests that the vat portion of all used vat rates must be given even vat rate 0%!
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:vatRateType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
vat_rate | derived by: double | required
amount | double | required
vat | double | required
attributes annotations
Name Notes
vat_rate vat_rate is the applicable vat rate given as a percentage factor
Note, that the vat rate 0% is a valid vat rate as well.
amount amount is the sum over 2-digit precision service amounts for which the given vat rate is applicable.
Note, that all amounts in this scheme are amounts that include the vat!
vat vat is the calculated vat portion of the given amount using the vat rate as
«(amount * vat_rate) / (100 + vat_rate)»

where the used amount is in 2-digit precision and the result is rounded to 2 significant decimal places.
source | <element name="vat_rate" type="invoice:vatRateType" maxOccurs="unbounded"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/tiers_soldant

Annotation | The tiers_soldant element defines the invoice/reminder running under Tiers Soldant (TS)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:soldantType
properties
isRef | 0
content | complex
children | invoice:biller invoice:debitor invoice:providers invoice:insurance invoice:patient invoice:guarantor invoice:referrer invoice:employer invoice:balance
attributes parameters
Name | Type | Use | Default | Fixed
allowTS | boolean | required
attributes annotations
Name Notes
allowTS allowTS confirms that the patient allows the usage of Tiers Soldant (TS). Furthermore, it implies the existence of a cession document signed by the patient and included as PDF attachment.
Please note, that if allowTS=false then the request should not be processed at the insurance's site but rejected due to the missing approval.
source | <element name="tiers_soldant" type="invoice:soldantType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element soldantType/biller

Annotation | The biller address element defines the biller or creditor in an invoice/reminder process.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:billerAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
uid_number | invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the biller's GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the treatment is carried out by the patient himself or a relative of the patient.
uid_number uid_number is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789
source | <element name="biller" type="invoice:billerAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element soldantType/debitor

Annotation | The debitor address element defines the deptor in an invoice/reminder process
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:debitorAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
uid | invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the debitor's GLN number as defined by RefData
Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789

Please note, that the UID is optional and possibly defined for legal entities. Thus the UID is always empty for natural persons.
source | <element name="debitor" type="invoice:debitorAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element soldantType/providers

Annotation | The providers element is the container holding the different flavors of the provider definitions basically differing in the unique key like GLN or ZSR
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:providersAddressType
properties
isRef | 0
content | complex
children | invoice:provider_gln invoice:provider_zsr
source | <element name="providers" type="invoice:providersAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element soldantType/insurance

Annotation | The insurance address element is the insurance, that is the party that provides the insurance protection.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:insuranceAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
attributes annotations
Name | Notes
gln | gln is the insurance's GLN as defined by RefData
source | <element name="insurance" type="invoice:insuranceAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element soldantType/patient

Annotation | The patient address element defines the patient with all relevant data
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:patientAddressType
properties
isRef | 0
content | complex
children | invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
sex | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn | invoice:ssnPartyType | required
mpi | invoice:stringType1_35
attributes annotations
Name | Notes
gender gender defines the social gender encoded by a terminal set of tokens
  • male: the patient decides to have a gender of male
  • female: the patient decides to have a gender of female
  • diverse: the patient decides to have a gender of diverse
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
birthdate | birthdate defines the birthdate of the patient
ssn the required ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
If for any reasons the SSN of the patient is unknown, than the unknownSSN = 7569999999991 must be defined to satisfy the schema validity!

Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
mpi | the optional mpi defines the forthcoming 'Master-Patient-Index' uniquely defining a patient in Switzerland/Liechtenstein by this index key.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the patient decides to have a gender of male
gender | NMTOKEN | female | the patient decides to have a gender of female
gender | NMTOKEN | diverse | the patient decides to have a gender of diverse
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
source | <element name="patient" type="invoice:patientAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element soldantType/guarantor

Annotation | The guarantor address element is the legal representative of the patient. In most cases the guarantor is therefore the patient himself, in other situations it might be the parents of the patient or another officially mandated person/institution.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:guarantorAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType
uid | invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the guarantors's GLN number as defined by RefData
Please note, that the GLN is optional, because a GLN is not assigned to all entities Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789

Please note, that the UID is optional and possibly defined for legal entities. Thus the UID is always empty for natural persons.
source | <element name="guarantor" type="invoice:guarantorAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element soldantType/referrer

Annotation | The referrer address element defines an optional referrer who has referred the patient to the main provider.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:referrerAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
zsr | invoice:zsrPartyType
attributes annotations
Name | Notes
gln | gln is the referrer's GLN as defined by RefData
zsr | zsr is the referrer's ZSR as defined by Santésuisse
source | <element name="referrer" type="invoice:referrerAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element soldantType/employer

Annotation | The employer address element defines the employer of the patient (the employer might be important in an UVG case)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:employerAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType
reg_number | invoice:stringType1_35
attributes annotations
Name | Notes
gln | gln is the employer's GLN as defined by RefData
reg_number | reg_number is the employer's national BUR number as defined by Swiss Federal Statistical Office
source | <element name="employer" type="invoice:employerAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element soldantType/balance

Annotation | The balance element supplies all money and vat relevant information in the Tiers Soldant (TS) case.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:balanceTPType
properties
isRef | 0
content | complex
children | invoice:vat
attributes parameters
Name | Type | Use | Default | Fixed
currency | string | CHF
amount | double | required
amount_reminder | double | 0
amount_due | double | required
attributes annotations
Name | Notes
currency | currency is the currency used for the whole invoice/reminder. The currency is fixed by the XSD schema to "CHF" - Swiss Francs!
amount | amount is the total amount for the invoice/reminder accumulated over all 2-digit precision service amounts. Therefore, the amount implicitly has a 2-digit precision as well.
amount_reminder amount_reminder is an optional reminder charge rounded to 2 significant decimal places.
Of course, if the request is an invoice amount_reminder must be 0.00.
amount_due amount_due is the amount due for the invoice/reminder (and coded into the ESR payment transaction) calculated as
«amount + amount_reminder - amount_prepaid»

where the used summands are 2-digit precision amounts and the result is finally rounded half up ("Kaufmännisches Runden")
source | <element name="balance" type="invoice:balanceTPType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element balanceTPType/vat

Annotation | The vat element defines all vat related data as requested by the "Swiss Federal Tax Administration"
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:vatType
properties
isRef | 0
content | complex
children | invoice:vat_rate
attributes parameters
Name | Type | Use | Default | Fixed
vat_number | invoice:stringType1_15
vat | double | required
attributes annotations
Name | Notes
vat_number vat_number is the individual vat number of the biller as given by the "Swiss Federal Tax Administration". Both forms the old 6-digit number as well as the new UID dependent number is allowed. However, the electronic layout of the number must be supplied as suggested by the federal administration. In the electronic layout all punctuation characters ('-' and '.') as well as the language dependent attribute in the new form ('MWST','IVA', 'TVA') are striped.
Consequently, the vat number must be expanded appropriately prior to be printed, e.g.
  • Old vat number: electronic layout 799000 is printed as 799.000
  • New vat number: electronic: CHE123456789 is printed as CHE-123.456.789 MWST (for german language!)

Of course, if the biller has not been assigned such a vat number leave the field empty.
vat | vat is the overall vat portion for the invoice/reminder accumulated over 2-digit precision individual vats.
source | <element name="vat" type="invoice:vatType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/tiers_payant

Annotation | The tiers_payant element defines the invoice/reminder running under Tiers Payant (TP)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:payantType
properties
isRef | 0
content | complex
children | invoice:biller invoice:debitor invoice:providers invoice:insurance invoice:patient invoice:insured invoice:guarantor invoice:referrer invoice:employer invoice:balance
attributes parameters
Name | Type | Use | Default | Fixed
allowModification | boolean | required
attributes annotations
Name | Notes
allowModification | allowModification gives or denies placet for the health care insurance to correct quantities of services. The service quantity can be changed in the range R0+ (positive real numbers including zero), which changes the amounts of individual services as well as the total invoice amount and the vat accounting.
source | <element name="tiers_payant" type="invoice:payantType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/biller

Annotation | The biller address element defines the biller or creditor in an invoice/reminder process.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:billerAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
uid_number | invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the biller's GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the treatment is carried out by the patient himself or a relative of the patient.
uid_number uid_number is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789
source | <element name="biller" type="invoice:billerAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/debitor

Annotation | The debitor address element defines the deptor in an invoice/reminder process
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:debitorAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
uid | invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the debitor's GLN number as defined by RefData
Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789

Please note, that the UID is optional and possibly defined for legal entities. Thus the UID is always empty for natural persons.
source | <element name="debitor" type="invoice:debitorAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/providers

Annotation | The providers element is the container holding the different flavors of the provider definitions basically differing in the unique key like GLN or ZSR
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:providersAddressType
properties
isRef | 0
content | complex
children | invoice:provider_gln invoice:provider_zsr
source | <element name="providers" type="invoice:providersAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/insurance

Annotation | The insurance address element is the insurance, that is the party that provides the insurance protection.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:insuranceAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
attributes annotations
Name | Notes
gln | gln is the insurance's GLN as defined by RefData
source | <element name="insurance" type="invoice:insuranceAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/patient

Annotation | The patient address element defines the patient with all relevant data
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:patientAddressType
properties
isRef | 0
content | complex
children | invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
sex | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn | invoice:ssnPartyType | required
mpi | invoice:stringType1_35
attributes annotations
Name | Notes
gender gender defines the social gender encoded by a terminal set of tokens
  • male: the patient decides to have a gender of male
  • female: the patient decides to have a gender of female
  • diverse: the patient decides to have a gender of diverse
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
birthdate | birthdate defines the birthdate of the patient
ssn the required ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
If for any reasons the SSN of the patient is unknown, than the unknownSSN = 7569999999991 must be defined to satisfy the schema validity!

Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
mpi | the optional mpi defines the forthcoming 'Master-Patient-Index' uniquely defining a patient in Switzerland/Liechtenstein by this index key.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the patient decides to have a gender of male
gender | NMTOKEN | female | the patient decides to have a gender of female
gender | NMTOKEN | diverse | the patient decides to have a gender of diverse
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
source | <element name="patient" type="invoice:patientAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/insured

Annotation The optional insured address element defines the mother's address of a newborn.
In fact if the following conditions are true then and only then the mother's address of a newborn must be supplied.
  • it is an invoice of a stationary DRG case
  • the DRG position defines a birth
  • the patient is the newborn
In all other circumstances the semantics of "insured" is unknown.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:insuredAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
sex | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn | invoice:ssnPartyType | 7569999999991
insured_id | invoice:stringType1_35
attributes annotations
Name | Notes
gender gender defines the social gender encoded by a terminal set of tokens
  • male: the patient decides to have a gender of male
  • female: the patient decides to have a gender of female
  • diverse: the patient decides to have a gender of diverse
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
birthdate | birthdate defines the birthdate of the insured
ssn ssn defines the social security number of the insured whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
insured_id | the insured_id defines the required 20-digits official identification number of the patient at the insurance. If the so-called insurance card number is unknown or unavailable (it might be a resident of a foreign country) than supply the proprietary customer number identifying the patient at that insurance.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the patient decides to have a gender of male
gender | NMTOKEN | female | the patient decides to have a gender of female
gender | NMTOKEN | diverse | the patient decides to have a gender of diverse
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
source | <element name="insured" type="invoice:insuredAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element insuredAddressType/person

Annotation | The insured's address given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/guarantor

Annotation | The guarantor address element is the legal representative of the patient. In most cases the guarantor is therefore the patient himself, in other situations it might be the parents of the patient or another officially mandated person/institution.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:guarantorAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType
uid | invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the guarantors's GLN number as defined by RefData
Please note, that the GLN is optional, because a GLN is not assigned to all entities Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789

Please note, that the UID is optional and possibly defined for legal entities. Thus the UID is always empty for natural persons.
source | <element name="guarantor" type="invoice:guarantorAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/referrer

Annotation | The referrer address element defines an optional referrer who has referred the patient to the main provider.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:referrerAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
zsr | invoice:zsrPartyType
attributes annotations
Name | Notes
gln | gln is the referrer's GLN as defined by RefData
zsr | zsr is the referrer's ZSR as defined by Santésuisse
source | <element name="referrer" type="invoice:referrerAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/employer

Annotation | The employer address element defines the employer of the patient (the employer might be important in an UVG case)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:employerAddressType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:company invoice:person
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType
reg_number | invoice:stringType1_35
attributes annotations
Name | Notes
gln | gln is the employer's GLN as defined by RefData
reg_number | reg_number is the employer's national BUR number as defined by Swiss Federal Statistical Office
source | <element name="employer" type="invoice:employerAddressType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element payantType/balance

Annotation The balance element supplies all money and vat relevant information in the Tiers Payant (TP) case.
Note, that there is no prepaid amount in TP since the debitor (in most cases the insurance) in general does not do any advanced payments.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:balanceTPType
properties
isRef | 0
content | complex
children | invoice:vat
attributes parameters
Name | Type | Use | Default | Fixed
currency | string | CHF
amount | double | required
amount_reminder | double | 0
amount_due | double | required
attributes annotations
Name | Notes
currency | currency is the currency used for the whole invoice/reminder. The currency is fixed by the XSD schema to "CHF" - Swiss Francs!
amount | amount is the total amount for the invoice/reminder accumulated over all 2-digit precision service amounts. Therefore, the amount implicitly has a 2-digit precision as well.
amount_reminder amount_reminder is an optional reminder charge rounded to 2 significant decimal places.
Of course, if the request is an invoice amount_reminder must be 0.00.
amount_due amount_due is the amount due for the invoice/reminder (and coded into the ESR payment transaction) calculated as
«amount + amount_reminder - amount_prepaid»

where the used summands are 2-digit precision amounts and the result is finally rounded half up ("Kaufmännisches Runden")
source | <element name="balance" type="invoice:balanceTPType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/esrQR

Annotation | The esrQR element supplies payment information for an "ESR with QR" or "ESR+ with QR" a "Pay in slip with QR" transaction.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:esrQRType
properties
isRef | 0
content | complex
children | invoice:creditor
attributes parameters
Name | Type | Use | Default | Fixed
subtype | derived by: NMTOKEN | esrQR
iban | derived by: string | required
reference_number | derived by: string | required
alternative_scheme1 | invoice:stringType1_100
alternative_scheme2 | invoice:stringType1_100
payment_reason | invoice:stringType1_140
payment_period | duration
attributes annotations
Name | Notes
subtype subtype is the EsrQR subtype specification encoded by a terminal set of tokens
  • esrQRplus: esrQRplus is an «ESR+ with QR without amount». Furthermore, any layouted print out must not set an amount inside the QR and in the amount fields.
  • esrQR: esrQR is an ordinary «ESR with QR» (Default).
iban iban is a mandatory IBAN of Switzerland or Liechtenstein (21 characters) that defines the creditor's account at the given bank.
The format of the IBAN is in the standard representation without whitespace. Pursuant to the guidelines, the IBAN should be divided up from the left in blocks of 4 separated by blanks when printed.
reference_number reference_number is a 27-digit reference number.
Pursuant to the guidelines the reference number should be divided up from the right in blocks of 5 separated by blanks when printed.
alternative_scheme1 | alternative_scheme1 defines the 1st optional alternative scheme as defined by the Swiss QR-Invoice standard. Since the exact layout of the supplied scheme is undefined and can not be validated/covered by a data pattern, it is in the responsibility of the invoice generator to check, validate and correctly process such an alternative scheme.
alternative_scheme2 | alternative_scheme2 defines the 2nd optional alternative scheme as defined by the Swiss QR-Invoice standard. Since the exact layout of the supplied scheme is undefined and can not be validated/covered by a data pattern, it is in the responsibility of the invoice generator to check, validate and correctly process such an alternative scheme.
payment_reason | The optional payment_reason consisting of a maximum of 140 characters defining the reason for the payment. The intent of the text is purely one of the creditor.
payment_period | payment_period is the payment period in which the invoice/reminder should be paid
attributes enumerations
Name | Extension | Base | Value | Annotations
subtype | NMTOKEN | esrQRplus | esrQRplus is an «ESR+ with QR without amount». Furthermore, any layouted print out must not set an amount inside the QR and in the amount fields.
subtype | NMTOKEN | esrQR | esrQR is an ordinary «ESR with QR» (Default).
source | <element name="esrQR" type="invoice:esrQRType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element esrQRType/creditor

Annotation The creditor element defines the creditor address. From a logical point of view, the creditor and the biller are the same. However, due to Anti-Money Laundering Act, Art. 95, 98 FC, the naming must be defined the same as for the bank account and this naming scheme might be different from the biller's address. Consequently, the creditor object is included explicitly into the XML infoset.

Note, that only the name, street (if available), zip and city and country of the address object is used for the printout.

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:esrAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
source | <element name="creditor" type="invoice:esrAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element esrAddressType/company

Annotation | The given address used in an ESR is a legal entity given by the company element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:companyType
properties
isRef | 0
content | complex
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
source | <element name="company" type="invoice:companyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element esrAddressType/person

Annotation | The given address used in an ESR is a natural person given by the person element
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:personType
properties
isRef | 0
content | complex
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
attributes parameters
Name | Type | Use | Default | Fixed
salutation | invoice:stringType1_35
title | invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source | <element name="person" type="invoice:personType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/esrQRRed

Annotation | The esrQRRed element supplies payment information for a "Pay in slip with QR" transaction
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:esrQRRedType
properties
isRef | 0
content | complex
children | invoice:creditor
attributes parameters
Name | Type | Use | Default | Fixed
subtype | derived by: NMTOKEN | esrQRRed
iban | derived by: string | required
reference_number | derived by: string
alternative_scheme1 | invoice:stringType1_100
alternative_scheme2 | invoice:stringType1_100
payment_reason | invoice:stringType1_140
payment_period | duration
attributes annotations
Name | Notes
subtype subtype is the PayInSlip with QR subtype specification encoded by a terminal set of tokens
  • esrQRRedplus: esrQRRedplus is an «PayInSlip+ with QR without amount». Furthermore, any layouted print out must not set an amount inside the QR and in the amount fields.
  • esrQRRed: esrQRRed is an ordinary «PayInSlip with QR» (Default).
iban iban is a mandatory IBAN of Switzerland or Liechtenstein (21 characters) that defines the creditor's account at the given bank.
The format of the IBAN is in the standard representation without whitespace. Pursuant to the guidelines, the IBAN should be divided up from the left in blocks of 4 separated by blanks when printed.
reference_number reference_number is an optional 25 character Creditor Reference number (ISO 11649)
Pursuant to the guidelines the reference number should be divided up from the right in blocks of 5 separated by blanks when printed.
alternative_scheme1 | alternative_scheme1 defines the 1st optional alternative scheme as defined by the Swiss QR-Invoice standard. Since the exact layout of the supplied scheme is undefined and can not be validated/covered by a data pattern, it is in the responsibility of the invoice generator to check, validate and correctly process such an alternative scheme.
alternative_scheme2 | alternative_scheme2 defines the 2nd optional alternative scheme as defined by the Swiss QR-Invoice standard. Since the exact layout of the supplied scheme is undefined and can not be validated/covered by a data pattern, it is in the responsibility of the invoice generator to check, validate and correctly process such an alternative scheme.
payment_reason | The optional payment_reason consisting of a maximum of 140 characters defining the reason for the payment. The intent of the text is purely one of the creditor.
payment_period | payment_period is the payment period in which the invoice/reminder should be paid
attributes enumerations
Name | Extension | Base | Value | Annotations
subtype | NMTOKEN | esrQRRedplus | esrQRRedplus is an «PayInSlip+ with QR without amount». Furthermore, any layouted print out must not set an amount inside the QR and in the amount fields.
subtype | NMTOKEN | esrQRRed | esrQRRed is an ordinary «PayInSlip with QR» (Default).
source | <element name="esrQRRed" type="invoice:esrQRRedType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element esrQRRedType/creditor

Annotation The creditor element defines the creditor address. From a logical point of view, the creditor and the biller are the same. However, due to Anti-Money Laundering Act, Art. 95, 98 FC, the naming must be defined the same as for the bank account and this naming scheme might be different from the biller's address. Consequently, the creditor object is included explicitly into the XML infoset.

Note, that only the name, street (if available), zip and city and country of the address object is used for the printout.

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:esrAddressType
properties
isRef | 0
content | complex
children | invoice:company invoice:person
source | <element name="creditor" type="invoice:esrAddressType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/law

Annotation | The law element defines the applicable law and all its needed parameters for the XML infoset. The scope of permissible laws is well-defined and fixed to the set of {"Krankenversicherungsgesetz", "Versicherungsvertragsgesetz", "Unfallversicherungsgesetz", "Invalidenversicherungsgesetz", "Militäversicherungsgesetz", "Obligationenrechtsgesetz"}
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:lawType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN | required
insured_id | invoice:stringType1_35
customer_no | invoice:stringType1_35
case_id | invoice:stringType1_35
case_date | dateTime
attributes annotations
Name Notes
type type is the type of applicable law encoded by a terminal set of tokens
  • KVG: the applicable law is "Krankenversicherungsgesetz" abbreviated {"KVG" | "LAMal" | "LAMal"} in the official national languages
  • VVG: the applicable law is "Versicherungsvertragsgesetz" abbreviated {"VVG" | "LCA" | "LCA"} in the official national languages
  • UVG: the applicable law is "Unfallversicherungsgesetz" abbreviated {"UVG" | "LAA" | "LAINF"} in the official national languages
  • IVG: the applicable law is "Invalidenversicherungsgesetz" abbreviated {"IVG" | "LAI" | "LAI"} in the official national languages
  • MVG: the applicable law is "Militäversicherungsgesetz" abbreviated {"MVG" | "LAM" | "LAM"} in the official national languages
  • ORG: the applicable law is "Obligationenrechtsgesetz" abbreviated {"ORG" | "CO" | "CO"} in the official national languages
insured_id insured_id is the patient's identification number at the insurance (the policy number).
It should be noted that the existence, form and specifications of insured_id is dependent on the law:
  • KVG: defines the required 20-digits official identification number of the patient at the insurance. If the so-called insurance card number is unknown or unavailable (it might be a resident of a foreign country) than supply the proprietary customer number identifying the patient at that insurance.
  • VVG: defines the optional VVG identification number of the patient.
  • UVG: defines the optional SSN ("social security number") as the UVG's identification number of the patient.
  • IVG: defines the required SSN ("social security number") as the IVG's identification number of the patient.
    If no SSN is supplied, a rejection must be expected.
  • MVG: defines the required SSN ("social security number") as the MVG's identification number of the patient.
    If no SSN is supplied, a rejection must be expected.
  • ORG: defines the optional SSN ("social security number") as the ORG's identification number of the patient.
customer_no the optional customer_no is the old proprietary KVG customer number.
Note that the customer_no should only be filled if no insured_id is defined. In fact the usage of the customer_no is deprecated since it is an outdated identification.
case_id case_id is the treatment/case identification number issued by by the insurance
It should be noted that the existence, form and specifications of case_id is dependent on the law:
  • KVG: there is currently no such case id known at the insurance site. Future contracts between provider and insurance might make such a case id necessary.
  • VVG: there is currently no such case id known at the insurance site. Future contracts between provider and insurance might make such a case id necessary.
  • UVG: defines the required accident number uniquely identifying the corresponding case at the insurance's site.
    If no accident number is supplied, a rejection must be expected.
  • IVG: defines the required case id having a well defined data pattern of ([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6}).
    If no case id is supplied, a rejection must be expected.
  • MVG: defines the optional case id
  • ORG: there is currently no such case id known.
case_date case_date is the treatment/case date issued by by the insurance
It should be noted that the existence, form and specifications of case_date is dependent on the law:
  • KVG: there is currently no such case date known at the insurance site.
  • VVG: there is currently no such case id known at the insurance site.
  • UVG: defines the optional accident date identifying the occurrence of the accident.
  • IVG: there is currently no such case id known at the insurance site.
  • MVG: defines the optional case date
  • ORG: there is currently no such case id known.
attributes enumerations
Name | Extension | Base | Value | Annotations
type | NMTOKEN | KVG | the applicable law is "Krankenversicherungsgesetz" abbreviated {"KVG" | "LAMal" | "LAMal"} in the official national languages
type | NMTOKEN | VVG | the applicable law is "Versicherungsvertragsgesetz" abbreviated {"VVG" | "LCA" | "LCA"} in the official national languages
type | NMTOKEN | UVG | the applicable law is "Unfallversicherungsgesetz" abbreviated {"UVG" | "LAA" | "LAINF"} in the official national languages
type | NMTOKEN | IVG | the applicable law is "Invalidenversicherungsgesetz" abbreviated {"IVG" | "LAI" | "LAI"} in the official national languages
type | NMTOKEN | MVG | the applicable law is "Militäversicherungsgesetz" abbreviated {"MVG" | "LAM" | "LAM"} in the official national languages
type | NMTOKEN | ORG | the applicable law is "Obligationenrechtsgesetz" abbreviated {"ORG" | "CO" | "CO"} in the official national languages
source | <element name="law" type="invoice:lawType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/treatment

Annotation | The treatment element defines the treatment parameters possibly augmented by extra parameters in case of a hospital invoice/reminder (place=hospital)
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:treatmentType
properties
isRef | 0
content | complex
children | invoice:diagnosis invoice:xtra_hospital
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required
date_end | dateTime | required
canton | derived by: NMTOKEN | required
treatment | derived by: NMTOKEN | ambulatory
reason | derived by: NMTOKEN | required
gestation_week13 | dateTime
birthdate_baby | dateTime
apid | invoice:stringType1_35
acid | invoice:stringType1_35
attributes annotations
Name | Notes
date_begin date_begin is the start of the treatment
Note, that the date of every service must be greater or equal date_begin otherwise it is a content error
date_end date_end is the end of the treatment
Note, that the date of every service must be less or equal date_end otherwise it is a content error
canton canton is Swiss canton or a country close to the border in which the treatment took place encoded by a terminal set of tokens.
Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.
  • AG: the canton is AG - Aargau
  • AI: the canton is AI - Appenzell Innerrhoden
  • AR: the canton is AR - Appenzell Ausserrhoden
  • BE: the canton is BE - Bern
  • BL: the canton is BL - Baselland
  • BS: the canton is BS - Basel
  • FR: the canton is FR - Fribourg
  • GE: the canton is GE - Geneva
  • GL: the canton is GL - Glarus
  • GR: the canton is GR - Graubünden
  • JU: the canton is JU - Jura
  • LU: the canton is LU - Lucerne
  • NE: the canton is NE - Neuchâtel
  • NW: the canton is NW - Nidwalden
  • OW: the canton is OW - Obwalden
  • SG: the canton is SG - St. Gallen
  • SH: the canton is SH - Schaffhausen
  • SO: the canton is SO - Solothurn
  • SZ: the canton is SZ - Schwyz
  • TI: the canton is TI - Ticino
  • TG: the canton is TG - Thurgau
  • UR: the canton is UR - Uri
  • VD: the canton is VD - Vaud
  • VS: the canton is VS - Valais
  • ZG: the canton is ZG - Zug
  • ZH: the canton is ZH - Zürich
  • LI: the country is LI - Liechtenstein
  • A: the country is A - Austria
  • D: the country is D - Germany
  • F: the country is F - France
  • I: the country is I - Italy
treatment treatment is the principle type of treatment encoded by a terminal set of tokens.
Please note, that if place=hospital there is additional data to supply in the xtra_hospital container.
  • ambulatory: the treatment type is ambulatory (default)
  • stationary: the treatment type is stationary
reason reason is the primary reason the treatment took place encoded by a terminal set of tokens
  • disease: the reason of treatment is a disease
  • accident: the reason of treatment is an accident
  • maternity: the reason of treatment is a maternity
  • prevention: the reason of treatment is prevention
  • birthdefect: the reason of treatment a birthdefect
  • unknown: the reason of treatment is unknown (or something not mentioned above)
gestation_week13 gestation_week13 is any day of the 13th gestation week as requested by Article 105 of the Swiss Federal Act on Health Insurance (KVV).
This date is set once only in the first invoice with treatment reason «maternity» and law type «KVG»
birthdate_baby the birthdate_baby is the birth date of the newborn and is supplied as soon as known. Please note that treatment@reason=maternity is required as well to signal an ongoing maternity case up until 8 weeks after the birth of the newborn.
This birthdate_baby is used by the insurance to verify the legality of specific services during the post pregnancy period.
apid | apid is an optional administrative patient identification of the main software, defined exclusively for the exchange with the insurers.
acid acid is an optional administrative case identification of the main software, defined exclusively for the exchange with the insurers.

Please note, that the acid cannot serve as a unique identification of the invoice/reminder as opposed to the unique object reference!

attributes enumerations
Name | Extension | Base | Value | Annotations
canton | NMTOKEN | AG | the canton is AG - Aargau
canton | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
canton | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
canton | NMTOKEN | BE | the canton is BE - Bern
canton | NMTOKEN | BL | the canton is BL - Baselland
canton | NMTOKEN | BS | the canton is BS - Basel
canton | NMTOKEN | FR | the canton is FR - Fribourg
canton | NMTOKEN | GE | the canton is GE - Geneva
canton | NMTOKEN | GL | the canton is GL - Glarus
canton | NMTOKEN | GR | the canton is GR - Graubünden
canton | NMTOKEN | JU | the canton is JU - Jura
canton | NMTOKEN | LU | the canton is LU - Lucerne
canton | NMTOKEN | NE | the canton is NE - Neuchâtel
canton | NMTOKEN | NW | the canton is NW - Nidwalden
canton | NMTOKEN | OW | the canton is OW - Obwalden
canton | NMTOKEN | SG | the canton is SG - St. Gallen
canton | NMTOKEN | SH | the canton is SH - Schaffhausen
canton | NMTOKEN | SO | the canton is SO - Solothurn
canton | NMTOKEN | SZ | the canton is SZ - Schwyz
canton | NMTOKEN | TI | the canton is TI - Ticino
canton | NMTOKEN | TG | the canton is TG - Thurgau
canton | NMTOKEN | UR | the canton is UR - Uri
canton | NMTOKEN | VD | the canton is VD - Vaud
canton | NMTOKEN | VS | the canton is VS - Valais
canton | NMTOKEN | ZG | the canton is ZG - Zug
canton | NMTOKEN | ZH | the canton is ZH - Zürich
canton | NMTOKEN | LI | the country is LI - Liechtenstein
canton | NMTOKEN | A | the country is A - Austria
canton | NMTOKEN | D | the country is D - Germany
canton | NMTOKEN | F | the country is F - France
canton | NMTOKEN | I | the country is I - Italy
reason | NMTOKEN | disease | the reason of treatment is a disease
reason | NMTOKEN | accident | the reason of treatment is an accident
reason | NMTOKEN | maternity | the reason of treatment is a maternity
reason | NMTOKEN | prevention | the reason of treatment is prevention
reason | NMTOKEN | birthdefect | the reason of treatment a birthdefect
reason | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
treatment | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment | NMTOKEN | stationary | the treatment type is stationary
source | <element name="treatment" type="invoice:treatmentType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element treatmentType/diagnosis

Annotation | The diagnosis element defines diagnoses for the treatment
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:diagnosisType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN | by_contract
code | invoice:stringType1_12
attributes annotations
Name | Notes
type type is the type of diagnosis catalog used encoded by a terminal set of tokens
  • ICD: the diagnosis catalog is ICD (e.g. ICD-10)
  • cantonal: the diagnosis catalog is the cantonal TI catalog
  • DRG: the diagnosis catalog is DRG (a DRG service position)
  • by_contract: the diagnosis is as defined by an individual contract (between provider and insurance)
  • freetext: the diagnosis is given as freetext
  • birthdefect: the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
  • ICPC: the diagnosis catalog is ICPC (e.g. ICPC-2)
code | code is the used code of the designated diagnosis catalog
attributes enumerations
Name | Extension | Base | Value | Annotations
type | stringType0_350 | NMTOKEN | ICD | the diagnosis catalog is ICD (e.g. ICD-10)
type | stringType0_350 | NMTOKEN | cantonal | the diagnosis catalog is the cantonal TI catalog
type | stringType0_350 | NMTOKEN | DRG | the diagnosis catalog is DRG (a DRG service position)
type | stringType0_350 | NMTOKEN | by_contract | the diagnosis is as defined by an individual contract (between provider and insurance)
type | stringType0_350 | NMTOKEN | freetext | the diagnosis is given as freetext
type | stringType0_350 | NMTOKEN | birthdefect | the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
type | stringType0_350 | NMTOKEN | ICPC | the diagnosis catalog is ICPC (e.g. ICPC-2)
source | <element name="diagnosis" type="invoice:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element treatmentType/xtra_hospital

Annotation | The xtra_hospital element defines further additional data for the treatment if and only if place=hospital
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:xtraHospitalType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:ambulatory invoice:stationary
source | <element name="xtra_hospital" type="invoice:xtraHospitalType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraHospitalType/ambulatory

Annotation | The ambulatory element defines additional data for an ambulatory treatment if place=hospital
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:xtraAmbulatoryType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
hospitalization_type | derived by: NMTOKEN
hospitalization_mode | derived by: NMTOKEN
class | derived by: NMTOKEN
section_major | invoice:stringType1_6
attributes annotations
Name | Notes
hospitalization_type hospitalization_type is the type of hospitalization encoded by a terminal set of tokens
  • regular: the type of hospitalization is regular ("a normal and planned hospitalization")
  • emergency: the type of hospitalization is emergency ("hospitalization due to an emergency")
hospitalization_mode hospitalization_mode is the mode of hospitalization encoded by a terminal set of tokens
  • cantonal: the mode of hospitalization is cantonal - patient's domicile is in the treatment canton)
  • noncantonal_indicated: the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but treatment is indicated
  • noncantonal_nonindicated: the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and treatment is not indicated
class hospitalization class is the class of insurance that covers the patient's stay encoded by a terminal set of tokens
  • private: the class of insurance is private (1st class insurance coverage)
  • semi_private: the class of insurance is semi_private (2nd class insurance coverage)
  • general: the class of insurance is general (3rd class insurance coverage)
  • hospital_comfort: the class of insurance is hospital_comfort
  • md_free_choice: the class of insurance is md_free_choice ("Freie Arztwahl")
section_major | section_major is the main section code (BfS section code) of the treatment as defined by Swiss Federal Statistical Office
attributes enumerations
Name | Extension | Base | Value | Annotations
class | NMTOKEN | private | the class of insurance is private (1st class insurance coverage)
class | NMTOKEN | semi_private | the class of insurance is semi_private (2nd class insurance coverage)
class | NMTOKEN | general | the class of insurance is general (3rd class insurance coverage)
class | NMTOKEN | hospital_comfort | the class of insurance is hospital_comfort
class | NMTOKEN | md_free_choice | the class of insurance is md_free_choice ("Freie Arztwahl")
hospitalization_mode | NMTOKEN | cantonal | the mode of hospitalization is cantonal - patient's domicile is in the treatment canton)
hospitalization_mode | NMTOKEN | noncantonal_indicated | the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but treatment is indicated
hospitalization_mode | NMTOKEN | noncantonal_nonindicated | the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and treatment is not indicated
hospitalization_type | NMTOKEN | regular | the type of hospitalization is regular ("a normal and planned hospitalization")
hospitalization_type | NMTOKEN | emergency | the type of hospitalization is emergency ("hospitalization due to an emergency")
source | <element name="ambulatory" type="invoice:xtraAmbulatoryType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraHospitalType/stationary

Annotation | The stationary element defines additional data for a stationary treatment if place=hospital
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:xtraStationaryType
properties
isRef | 0
content | complex
children | invoice:admission_type invoice:discharge_type invoice:provider_type invoice:bfs_residence_before_admission invoice:bfs_admission_type invoice:bfs_decision_for_discharge invoice:bfs_residence_after_discharge invoice:case_detail
attributes parameters
Name | Type | Use | Default | Fixed
hospitalization_date | dateTime | required
treatment_days | duration | required
hospitalization_type | derived by: NMTOKEN | regular
hospitalization_mode | derived by: NMTOKEN | cantonal
class | derived by: NMTOKEN | general
section_major | invoice:stringType1_6
has_expense_loading | boolean | true
attributes annotations
Name | Notes
hospitalization_date hospitalization_date is the date and time of the hospitalization.
Note, that this date must be less or equal the begin date of the treatment period
treatment_days treatment_days is the number of treatment days within the given treatment period.
The calculation of these treatment days is dependent on whether SwissDRG is used nor not!
The treatment days are calculated as
  • None-SwissDRG: «(treatment@date_end - treatment@date_begin + 1 - vacation_days)»
  • SwissDRG: «max(1,(treatment@date_end - treatment@date_begin - vacation_days))»
where vacation_days is the number of vacation days (the leave days when the patient was not in the hospital for treatment).

Note, that treatment_days is identical to the "length of stay" notion of a DRG service position (either APDRG or SwissDRG)

hospitalization_type hospitalization_type is the type of hospitalization encoded by a terminal set of tokens
  • regular: the type of hospitalization is regular ("a normal and planned hospitalization")
  • emergency: the type of hospitalization is emergency ("hospitalization due to an emergency")
hospitalization_mode hospitalization_mode is the mode of hospitalization encoded by a terminal set of tokens
  • cantonal: the mode of hospitalization is cantonal - patient's domicile is in the treatment canton)
  • noncantonal_indicated: the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but treatment is indicated
  • noncantonal_nonindicated: the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and treatment is not indicated
class hospitalization class is the class of insurance that covers the patient's stay encoded by a terminal set of tokens
  • private: the class of insurance is private (1st class insurance coverage)
  • semi_private: the class of insurance is semi_private (2nd class insurance coverage)
  • general: the class of insurance is general (3rd class insurance coverage)
  • hospital_comfort: the class of insurance is hospital_comfort
  • md_free_choice: the class of insurance is md_free_choice ("Freie Arztwahl")
section_major | section_major is the main section code (BfS section code) of the treatment as defined by Swiss Federal Statistical Office
has_expense_loading | has_expense_loading is a Boolean value if there is an expense loading by the patient ("Spitalkostenbeitrag")
attributes enumerations
Name | Extension | Base | Value | Annotations
class | NMTOKEN | private | the class of insurance is private (1st class insurance coverage)
class | NMTOKEN | semi_private | the class of insurance is semi_private (2nd class insurance coverage)
class | NMTOKEN | general | the class of insurance is general (3rd class insurance coverage)
class | NMTOKEN | hospital_comfort | the class of insurance is hospital_comfort
class | NMTOKEN | md_free_choice | the class of insurance is md_free_choice ("Freie Arztwahl")
hospitalization_mode | NMTOKEN | cantonal | the mode of hospitalization is cantonal - patient's domicile is in the treatment canton)
hospitalization_mode | NMTOKEN | noncantonal_indicated | the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but treatment is indicated
hospitalization_mode | NMTOKEN | noncantonal_nonindicated | the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and treatment is not indicated
hospitalization_type | NMTOKEN | regular | the type of hospitalization is regular ("a normal and planned hospitalization")
hospitalization_type | NMTOKEN | emergency | the type of hospitalization is emergency ("hospitalization due to an emergency")
source | <element name="stationary" type="invoice:xtraStationaryType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraStationaryType/admission_type

Annotation | The mandatory admission_type element defines the DRG grouper relevant admission mode. The element is populated by a number=name pair whose allowed value space is defined and given by Forum Datenaustausch/Generic list.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:grouperDataType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
number | invoice:stringType1_3 | required
name | invoice:stringType1_64 | required
attributes annotations
Name Notes
number number is the number part of a certain grouper data record.
For example, the 2nd choice of the grouper provider type is Maison des naissances in french. Therefore to code this combination use number="2" and name="Maison des naissances" for language="french".
name name is the language dependent name part of a grouper data record.
For example, the 2nd choice of the grouper provider type is Maison des naissances in french. Therefore to code this combination use number="2" and name="Maison des naissances" for language="french".

If name exceeds 64 characters then it is trimmed to 60 characters and the characters ("...") are appended.

source | <element name="admission_type" type="invoice:grouperDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraStationaryType/discharge_type

Annotation | The mandatory discharge_type element defines the DRG grouper relevant discharge/separation mode. The element is populated by a number=name pair whose allowed value space is defined and given by Forum Datenaustausch/Generic list.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:grouperDataType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
number | invoice:stringType1_3 | required
name | invoice:stringType1_64 | required
attributes annotations
Name Notes
number number is the number part of a certain grouper data record.
For example, the 2nd choice of the grouper provider type is Maison des naissances in french. Therefore to code this combination use number="2" and name="Maison des naissances" for language="french".
name name is the language dependent name part of a grouper data record.
For example, the 2nd choice of the grouper provider type is Maison des naissances in french. Therefore to code this combination use number="2" and name="Maison des naissances" for language="french".

If name exceeds 64 characters then it is trimmed to 60 characters and the characters ("...") are appended.

source | <element name="discharge_type" type="invoice:grouperDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraStationaryType/provider_type

Annotation | The mandatory provider_type element defines the DRG grouper relevant care provider. The element is populated by a number=name pair whose allowed value space is defined and given by Forum Datenaustausch/Generic list.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:grouperDataType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
number | invoice:stringType1_3 | required
name | invoice:stringType1_64 | required
attributes annotations
Name Notes
number number is the number part of a certain grouper data record.
For example, the 2nd choice of the grouper provider type is Maison des naissances in french. Therefore to code this combination use number="2" and name="Maison des naissances" for language="french".
name name is the language dependent name part of a grouper data record.
For example, the 2nd choice of the grouper provider type is Maison des naissances in french. Therefore to code this combination use number="2" and name="Maison des naissances" for language="french".

If name exceeds 64 characters then it is trimmed to 60 characters and the characters ("...") are appended.

source | <element name="provider_type" type="invoice:grouperDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraStationaryType/bfs_residence_before_admission

Annotation | The bfs_residence_before_admission element defines the residence from where the patient was admitted. The allowed number/name value space is defined by the BfS code 1.2.V02 of the current "hospital statistics" catalog.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:bfsDataType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | invoice:stringType1_3 | required
name | invoice:stringType1_64 | required
attributes annotations
Name Notes
code code is in fact not a code but a number of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use code="2" and name="Krankenheim, Pflegeheim" for language="german".
name name is the language dependent name of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use number="2" and name="Krankenheim, Pflegeheim" for language="german".

If name exceeds 64 characters then it is trimmed to 60 characters and the characters ("...") are appended.

source | <element name="bfs_residence_before_admission" type="invoice:bfsDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraStationaryType/bfs_admission_type

Annotation | The bfs_admission_type element defines the type of admission. The allowed number/name value space is defined by the BfS code 1.2.V03 of the current "hospital statistics" catalog.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:bfsDataType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | invoice:stringType1_3 | required
name | invoice:stringType1_64 | required
attributes annotations
Name Notes
code code is in fact not a code but a number of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use code="2" and name="Krankenheim, Pflegeheim" for language="german".
name name is the language dependent name of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use number="2" and name="Krankenheim, Pflegeheim" for language="german".

If name exceeds 64 characters then it is trimmed to 60 characters and the characters ("...") are appended.

source | <element name="bfs_admission_type" type="invoice:bfsDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraStationaryType/bfs_decision_for_discharge

Annotation | The bfs_decision_for_discharge element defines the reason why the patient was discharged. The allowed number/name value space is defined by the BfS code 1.5.V02 of the current "hospital statistics" catalog.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:bfsDataType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | invoice:stringType1_3 | required
name | invoice:stringType1_64 | required
attributes annotations
Name Notes
code code is in fact not a code but a number of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use code="2" and name="Krankenheim, Pflegeheim" for language="german".
name name is the language dependent name of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use number="2" and name="Krankenheim, Pflegeheim" for language="german".

If name exceeds 64 characters then it is trimmed to 60 characters and the characters ("...") are appended.

source | <element name="bfs_decision_for_discharge" type="invoice:bfsDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraStationaryType/bfs_residence_after_discharge

Annotation | The bfs_residence_after_discharge element defines the residence to where the patient was discharged. The allowed number/name value space is defined by the BfS code 1.5.V03 of the current "hospital statistics" catalog.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:bfsDataType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
code | invoice:stringType1_3 | required
name | invoice:stringType1_64 | required
attributes annotations
Name Notes
code code is in fact not a code but a number of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use code="2" and name="Krankenheim, Pflegeheim" for language="german".
name name is the language dependent name of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use number="2" and name="Krankenheim, Pflegeheim" for language="german".

If name exceeds 64 characters then it is trimmed to 60 characters and the characters ("...") are appended.

source | <element name="bfs_residence_after_discharge" type="invoice:bfsDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xtraStationaryType/case_detail

Annotation The case_detail elements are used to supply the complete history of the case in terms of opening, closing, possible relocation and re-opening of the DRG case described by BfS variables from the "Medical statistics Specification"

Note that the case details are optional. However, this situation might be covered by special contracts between service providers and insurances.

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:caseDetailType
properties
isRef | 0
minOcc | 0
maxOcc | unbounded
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
tariff_type | derived by: string
code | invoice:stringType1_30
date | dateTime | required
bfs_medstatistic_code | invoice:stringType1_35
acid | invoice:stringType1_35 | required
attributes annotations
Name | Notes
record_id | record_id is a sequence number (starting with 1 and incremented by 1 for each further record) that uniquely identifies the record
tariff_type | the optional tariff_type is the official 3-character designator of the tariff as given by Forum Datenaustausch
code | the optional code is the code of the service as given by the used tariff catalog
date | date is the date and time when the given BfS variable occurred
bfs_medstatistic_code the optional bfs_medstatistic_code supplies information about the case history in terms of admission, discharge, vacancy periods, re-location etc. all encoded and described by described by BfS variables from the "Medical statistics Specification". The variable is syntactically build as BfS_variable_number = BfS_variable_value, e.g. "1.2.V02 = 1" for coding "residence before admission=home" "1.5.V03=1" for defining "residence after discharge=home"

One single caseDetail entry defines one single event, whereas the variable content is neither case-sensitive nor whitespace-dependent.

acid | acid is the administrative case identification of the main software for the given case detail entry, defined exclusively for the exchange with the insurers.
source | <element name="case_detail" type="invoice:caseDetailType" minOccurs="0" maxOccurs="unbounded"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/services

Annotation | The services element is a container for all services applied within the given treatment period
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:servicesType
properties
isRef | 0
content | complex
children | invoice:service_ex invoice:service
source | <element name="services" type="invoice:servicesType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element servicesType/service_ex

Annotation | The service_ex element defines an extended service structure where some data exists in a dual form basically to describe 2 parts namely a medical and technical situation. The Tarmed tariff is the prototype of such an extended tariff structure.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:serviceExType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
tariff_type | derived by: string | required
code | invoice:stringType1_30 | required
ref_code | invoice:stringType1_30
name | invoice:stringType1_350 | required
session | derived by: int | 1
group_size | positiveInteger | 1
quantity | double | required
date_begin | dateTime | required
date_end | dateTime
provider_id | invoice:glnPartyType | required
responsible_id | invoice:glnPartyType | required
billing_role | derived by: NMTOKEN | both
medical_role | derived by: NMTOKEN | self_employed
body_location | derived by: NMTOKEN | none
treatment | derived by: NMTOKEN | ambulatory
unit_mt | double | required
unit_factor_mt | derived by: double | required
scale_factor_mt | double | 1.0
external_factor_mt | derived by: double | 1.0
amount_mt | double | 0.0
unit_tt | double | required
unit_factor_tt | derived by: double | required
scale_factor_tt | double | 1.0
external_factor_tt | derived by: double | 1.0
amount_tt | double | 0.0
amount | double | required
vat_rate | derived by: double | 0.0
section_code | invoice:stringType1_6
remark | invoice:stringType1_350
service_attributes | unsignedInt | 0
attributes annotations
Name | Notes
record_id record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
Note, that the sequence numbering is over all types of services!
tariff_type tariff_type is the official 3-character designator of the used tariff as given by Forum Datenaustausch
Currently, tariff type "001" for Tarmed is the only used tariff of that type.
code | code is the code of the service record as given by the used tariff catalog
ref_code ref_code is a back-reference code ("parent code") to a previously given service
Of course, ref_code is empty if the current service does not need such a back-reference
name | name is the official service name as given by the used tariff catalog
session session is the session number of the service. The session concept divide each day into a number of individual accomplished treatment units, starting each day with 1 and incrementing by 1 for each new treatment unit.

Some tariffs do not include a session concept, others like Tarmed heavily relay on this paradigm. For tariffs without a session concept simply input '1' as session number for all services.

group_size group_size defines the participating group size of a service whose quantity is calculated by the "Divisor Method". It should be noted that the group_size is declarative only with a default value equals to 1 implicitly meaning that it is NO service defined via the "Divisor Method" as the group size for such a service is always larger than 1.

Please note that in the "Divisor Method" the quantity is coded by definition as follows: quantity = effective_quantity / group_size.

quantity quantity is the used quantity of the current service
Note, that the quantity is defined as double, spanning negative, zero and positive fractional values!
  • negative quantities are used for service records in a storno (cf. attribute request/payload@storno)
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.25 for 02.0050 with a group of 4)
quantity must not be rounded but given in full precision.
date_begin | date_begin is the date when the service was (first) applied
date_end date_end is the date when the service was last applied.
Note that date_end is only necessary if a service was applied over a period of more than 1 day.
provider_id | provider_id is the provider's GTIN identification that physically applied the service
responsible_id | responsible_id is the responsible person's GTIN identification who has medical responsibility for the applied service
billing_role billing_role is the extended tariff defined billing role encoded by a terminal set of tokens.
  • mt: the billing role is mt (medical part only) - mt means that unit_tt=0 in most cases (there are exceptions defined in the tariff)!
  • tt: the billing role is tt (technical part only) - tt means that unit_mt=0 in most cases (there are exceptions defined in the tariff)!
  • both: the billing role is both (medical+technical part) - both means that both parts are billed. This is the default.
  • none: the billing role is none (neither medical nor technical part is billed) - none means that unit_mt=0 and unit_tt=0 in most cases!
medical_role medical_role is the extended tariff defined medical role encoded by a terminal set of tokens. Some rules in extended tariffs are based on the value of the medical_role and thus the medical_role needs to be known for a successful re-validation of these servies.
  • self_employed: the medical role is self_employed(default)
  • employee: the medical role is employee
body_location body_location is the extended tariff defined side location encoded by a terminal set of tokens.
  • none: the location is none (default) - no side specific location
  • left: the location is left - the service was applied on the left body side
  • right: the location is right - the service was applied on the right body side
treatment treatment is the treatment type under which the service was applied encoded by a terminal set of tokens.
  • ambulatory: the treatment type is ambulatory (default)
  • stationary: the treatment type is stationary
unit_mt unit_mt is the tax point of the medical part (TP(mt)) of the applied service
unit_mt is defined as double and must not be rounded but given in full precision.
unit_factor_mt unit_factor_mt is the tax point value of the medical part (TPV(mt)) of the applied service
unit_factor_mt is defined as double and must not be rounded but given in full precision.
scale_factor_mt scale_factor_mt is an internal scale factor of the medical part of the applied service
scale_factor_mt is defined as double and must not be rounded but given in full precision.
external_factor_mt external_factor_mt is a external scale factor (given by the main software) for the medical part of the applied service
external_factor_mt is used as a measure for giving discounts and can even be zero to supply a charge free service.
amount_mt amount_mt is the charged amount of the medical part of the applied service
Note, that amount_mt must fulfill the equation
«external_factor_mt * quantity * TP(mt) * TPV(mt) * scale_factor_mt»

calculated in full precision and the result rounded to 2 significant decimal places. This procedure is the reason for storing the multipliers in full precision.
unit_tt unit_tt is the tax point of the technical part (TP(tt)) of the applied service
unit_tt is defined as double and must not be rounded but given in full precision.
unit_factor_tt unit_factor_tt is the tax point value of the technical part (TPV(tt)) of the applied service
unit_factor_tt is defined as double and must not be rounded but given in full precision.
scale_factor_tt scale_factor_tt is an internal scale factor of the technical part of the applied service
scale_factor_tt is defined as double and must not be rounded but given in full precision.
external_factor_tt external_factor_tt is a external scale factor (given by the main software) for the technical part of the applied service
external_factor_tt is used as a measure for giving discounts and can even be zero to supply a charge free service.
amount_tt amount_tt is the charged amount of the technical part of the applied service
Note, that amount_tt must fulfill the equation
«external_factor_tt * quantity * TP(tt) * TPV(tt) * scale_factor_tt»

calculated in full precision and the result rounded to 2 significant decimal places. This procedure is the reason for storing the multipliers in full precision.
amount | amount is the charged amount of the applied service consisting of (amount_mt + amount_tt)
vat_rate | vat_rate is the applicable vat rate for the applied service given as a percentage factor
section_code | section_code is a section code (BfS section code) where the service was applied as defined by Swiss Federal Statistical Office - this code is only given for role=hospital!
remark | remark is an optional remark for the applied service
service_attributes service_attributes is a 32 bit integer where each bit defines a certain refinement/enhancement to the already supplied data.
The currently defined values are given in the purpose chapter ("Service attributes")
attributes enumerations
Name | Extension | Base | Value | Annotations
billing_role | NMTOKEN | mt | the billing role is mt (medical part only) - mt means that unit_tt=0 in most cases (there are exceptions defined in the tariff)!
billing_role | NMTOKEN | tt | the billing role is tt (technical part only) - tt means that unit_mt=0 in most cases (there are exceptions defined in the tariff)!
billing_role | NMTOKEN | both | the billing role is both (medical+technical part) - both means that both parts are billed. This is the default.
billing_role | NMTOKEN | none | the billing role is none (neither medical nor technical part is billed) - none means that unit_mt=0 and unit_tt=0 in most cases!
body_location | NMTOKEN | none | the location is none (default) - no side specific location
body_location | NMTOKEN | left | the location is left - the service was applied on the left body side
body_location | NMTOKEN | right | the location is right - the service was applied on the right body side
medical_role | NMTOKEN | self_employed | the medical role is self_employed(default)
medical_role | NMTOKEN | employee | the medical role is employee
treatment | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment | NMTOKEN | stationary | the treatment type is stationary
source | <element name="service_ex" type="invoice:serviceExType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element servicesType/service

Annotation | The service element describes the service of a simple tariff basically consisting of TP, TPV and amount.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:serviceType
properties
isRef | 0
content | complex
children | invoice:xtra_drg invoice:xtra_drug
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
tariff_type | derived by: string | required
code | invoice:stringType1_30 | required
ref_code | invoice:stringType1_30
name | invoice:stringType1_350 | required
session | derived by: int | 1
sl_indicationcode | invoice:stringType1_30
group_size | positiveInteger | 1
quantity | double | required
date_begin | dateTime | required
date_end | dateTime
provider_id | invoice:glnPartyType | required
responsible_id | invoice:glnPartyType | required
unit | double | required
unit_factor | derived by: double | 1.0
external_factor | derived by: double | 1.0
amount | double | required
vat_rate | derived by: double | 0
section_code | invoice:stringType1_6
remark | invoice:stringType1_350
service_attributes | unsignedInt | 0
attributes annotations
Name | Notes
record_id record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
Note, that the sequence numbering is over all types of services!
code | code is the code of the service record as given by the used tariff catalog
ref_code ref_code is a back-reference code ("parent code") to a previously given service
Of course, ref_code is empty if no back-reference concept is used for the current tariff catalog or if the current service does not need such a back-reference
name | name is the official service name as given by the used tariff catalog
session session is the session number of the service. The session concept divide each day into a number of individual accomplished treatment units, starting each day with 1 and incrementing by 1 for each new treatment unit.

Some tariffs do not include a session concept, others like Tarmed heavily relay on this paradigme. For tariffs without a session concept simply input 1 as session number for all services.

sl_indicationcode | the optional sl_indicationcode defines an indication code defined by the BAG in its SL List for the off-indication prescription/usage of a SL drug
group_size group_size defines the participating group size of a service whose quantity is calculated by the "Divisor Method". It should be noted that the group_size is declarative only with a default value equals to 1 implicitly meaning that it is NO service defined via the "Divisor Method" as the group size for such a service is always larger than 1.

Please note that in the "Divisor Method" the quantity is coded by definition as follows: quantity = effective_quantity / group_size.

quantity quantity is the used quantity of the current service
Note, that the quantity is defined as double, spanning negative, zero and positive fractional values!
  • negative quantities are used for service records in a storno (cf. attribute request/payload@storno)
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
quantity must not be rounded but given in full precision.
date_begin | date_begin is the date when the service was (first) applied
date_end date_end is the date when the service was last applied.
Note that date_end is only neccessary if the same service was applied each day over a period of more than 1 day.
provider_id | provider_id is the provider's GTIN identification that physically applied the service
responsible_id | responsible_id is the responsible person's GTIN identification who has medical responsibility for the applied service
unit unit is the tax point (TP) or the price of the applied service
unit is defined as double and must not be rounded but given in full precision.
unit_factor unit_factor is the tax point value (TPV) of the applied service
unit_factor is defined as double and must not be rounded but given in full precision.
external_factor external_factor is a external scale factor (given by the main software) for the applied service
external_factor is used as a measure for giving discounts and can even be zero to supply a charge free service.

In the DRG case the external factor is used for defining the splitting situation between insurance and canton.

amount amount is the charged amount of the applied service
Note, that amount must fulfill the equation:
«external_factor * quantity * TP * TPV »

for non-DRG services, whereas for DRG services the following equation holds true:
«cost_fraction * external_factor * quantity * TP * TPV »

Both equations are calculated in full precision and the result rounded to 2 significant decimal places. This procedure is the reason for storing the multipliers in full precision.
vat_rate | vat_rate is the applicable vat rate for the applied service given as a percentage factor
section_code | section_code is a section code (BfS section code) where the service was applied as defined by Swiss Federal Statistical Office - this code is only given for role=hospital!
remark | remark is an optional remark for the applied service
service_attributes service_attributes is a 32 bit integer where each bit defines a certain refinement/enhancement to the already supplied data.
The currently defined values are given in the purpose chapter ("Service attributes")
source | <element name="service" type="invoice:serviceType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element serviceType/xtra_drg

Annotation | The xtra_drg element is an optional data container for DRG services uniquely for defining the additional parameter of a 3-party splitting situation.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:xtraDRGType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
cost_fraction | derived by: double | 1.0
attributes annotations
Name Notes
cost_fraction cost_fraction defines the splitting between 2 insurances, whereas the attribute external_factor defines the splitting between the insurance and the canton.
A simple splitting situation between insurance and canton is defined solely by the external_factor. The cost_fraction is than set to 1 by definition.
source | <element name="xtra_drg" type="invoice:xtraDRGType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element serviceType/xtra_drug

Annotation | The xtra_drug element is an optional data container that additionally defines extended information about a supplied drug service. The information is solely supplied by role=pharmacist.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:xtraDrugType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
regulation_attributes | unsignedInt | 0
attributes annotations
Name Notes
regulation_attributes regulation_attributes is a 32 bit integer where each bit defines one specific regulation code as contracted between pharmacists and insurances

The currently defined values are given in the purpose chapter ("Regulation attributes")

source | <element name="xtra_drug" type="invoice:xtraDrugType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element bodyType/documents

Annotation | The documents element is a container for including documents, either inline (base64 coded) or offline (as URL reference).
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:documentsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | invoice:document
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source | <element name="documents" type="invoice:documentsType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element documentsType/document

Annotation | The document element defines one physical document of an allowed MIME type that is included in the infoset inline or Base64-coded.
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | invoice:documentType
properties
isRef | 0
minOcc | 1
maxOcc | unbounded
content | complex
children | invoice:base64
attributes parameters
Name | Type | Use | Default | Fixed
title | invoice:stringType1_35 | required
filename | invoice:filenameType | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title | title is the document's title on the primary system and thus describes the document in terms of its semantic content.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME type sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reducethe allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source | <element name="document" type="invoice:documentType" maxOccurs="unbounded"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element documentType/base64

Annotation | The base64 element defines the document inline and as BASE64-coded octet stream
diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="base64" type="base64Binary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:EncryptedData

Annotation The optional xenc:EncryptedData (as defined by W3C) encrypts and replaces the body element by using the public certificate of the end recipient of this infoset (mostly the insurance).
See the "notes about encryption" in the introduction chapter for further guidance about the encryption.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedDataType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexType payloadType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="EncryptedData" type="xenc:EncryptedDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:EncryptedType/EncryptionMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionMethodType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | xenc:KeySize xenc:OAEPparams
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:EncryptionMethodType/KeySize

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:KeySizeType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:EncryptionMethodType/OAEPparams

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="OAEPparams" type="base64Binary" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:KeyInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyInfoType
properties
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
complexTypes ds:SignatureType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="KeyInfo" type="ds:KeyInfoType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:KeyName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="KeyName" type="string"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:KeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:KeyValueType
properties
content | complex
mixed | true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
complexType ds:KeyInfoType
source | <element name="KeyValue" type="ds:KeyValueType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DSAKeyValueType
properties
content complex
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
complexType ds:KeyValueType
source | <element name="DSAKeyValue" type="ds:DSAKeyValueType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DSAKeyValueType/P

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="P" type="ds:CryptoBinary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DSAKeyValueType/Q

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Q" type="ds:CryptoBinary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DSAKeyValueType/G

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="G" type="ds:CryptoBinary" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DSAKeyValueType/Y

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Y" type="ds:CryptoBinary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DSAKeyValueType/J

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="J" type="ds:CryptoBinary" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DSAKeyValueType/Seed

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Seed" type="ds:CryptoBinary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DSAKeyValueType/PgenCounter

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="PgenCounter" type="ds:CryptoBinary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:RSAKeyValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RSAKeyValueType
properties
content complex
children | ds:Modulus ds:Exponent
used by
complexType ds:KeyValueType
source | <element name="RSAKeyValue" type="ds:RSAKeyValueType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:RSAKeyValueType/Modulus

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Modulus" type="ds:CryptoBinary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:RSAKeyValueType/Exponent

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CryptoBinary
properties
isRef | 0
content | simple
source | <element name="Exponent" type="ds:CryptoBinary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:RetrievalMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:RetrievalMethodType
properties
content complex
children | ds:Transforms
used by
complexType ds:KeyInfoType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source | <element name="RetrievalMethod" type="ds:RetrievalMethodType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:Transforms

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformsType
properties
content complex
children | ds:Transform
used by
complexTypes ds:ReferenceType ds:RetrievalMethodType
source | <element name="Transforms" type="ds:TransformsType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:Transform

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:TransformType
properties
content | complex
mixed | true
children | ds:XPath
used by
complexTypes ds:TransformsType xenc:TransformsType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="Transform" type="ds:TransformType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:TransformType/XPath

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="XPath" type="string"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:X509Data

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509DataType
properties
content complex
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
complexType ds:KeyInfoType
source | <element name="X509Data" type="ds:X509DataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:X509DataType/X509IssuerSerial

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:X509IssuerSerialType
properties
isRef | 0
content | complex
children | ds:X509IssuerName ds:X509SerialNumber
source | <element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:X509IssuerSerialType/X509IssuerName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509IssuerName" type="string"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:X509IssuerSerialType/X509SerialNumber

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
properties
isRef | 0
content | simple
source | <element name="X509SerialNumber" type="integer"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:X509DataType/X509SKI

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509SKI" type="base64Binary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:X509DataType/X509SubjectName

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
isRef | 0
content | simple
source | <element name="X509SubjectName" type="string"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:X509DataType/X509Certificate

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509Certificate" type="base64Binary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:X509DataType/X509CRL

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="X509CRL" type="base64Binary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:PGPData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:PGPDataType
properties
content complex
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
complexType ds:KeyInfoType
source | <element name="PGPData" type="ds:PGPDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:PGPDataType/PGPKeyID

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyID" type="base64Binary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:PGPDataType/PGPKeyPacket

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="PGPKeyPacket" type="base64Binary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:SPKIData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SPKIDataType
properties
content complex
children | ds:SPKISexp
used by
complexType ds:KeyInfoType
source | <element name="SPKIData" type="ds:SPKIDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:SPKIDataType/SPKISexp

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="SPKISexp" type="base64Binary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:MgmtData

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | string
properties
content simple
used by
complexType ds:KeyInfoType
source | <element name="MgmtData" type="string"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:CipherData

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherDataType
properties
content complex
children | xenc:CipherValue xenc:CipherReference
used by
complexType xenc:EncryptedType
source | <element name="CipherData" type="xenc:CipherDataType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:CipherDataType/CipherValue

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
content | simple
source | <element name="CipherValue" type="base64Binary"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:CipherReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:CipherReferenceType
properties
content complex
children | xenc:Transforms
used by
complexType xenc:CipherDataType
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="CipherReference" type="xenc:CipherReferenceType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:CipherReferenceType/Transforms

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:TransformsType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
children | ds:Transform
source | <element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:EncryptionProperties

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertiesType
properties
content complex
children | xenc:EncryptionProperty
used by
complexType xenc:EncryptedType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="EncryptionProperties" type="xenc:EncryptionPropertiesType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:EncryptionProperty

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptionPropertyType
properties
content | complex
mixed | true
used by
complexType xenc:EncryptionPropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source | <element name="EncryptionProperty" type="xenc:EncryptionPropertyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:Signature

Annotation The optional ds:Signature (as defined by W3C) signs the payload element by using the private certificate of the sending party represented by the transport@to GLN.
See the "notes about signature" in the introduction chapter for further guidance about the signature.

Note, that there will be no documentation of this element or any subparts as this is done by W3C already!
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureType
properties
content complex
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
complexType requestType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Signature" type="ds:SignatureType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:SignedInfo

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignedInfoType
properties
content complex
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignedInfo" type="ds:SignedInfoType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:CanonicalizationMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:CanonicalizationMethodType
properties
content | complex
mixed | true
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="CanonicalizationMethod" type="ds:CanonicalizationMethodType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:SignatureMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureMethodType
properties
content | complex
mixed | true
children | ds:HMACOutputLength
used by
complexType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="SignatureMethod" type="ds:SignatureMethodType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:SignatureMethodType/HMACOutputLength

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:HMACOutputLengthType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:Reference

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ReferenceType
properties
content complex
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
complexTypes ds:ManifestType ds:SignedInfoType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source | <element name="Reference" type="ds:ReferenceType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DigestMethod

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestMethodType
properties
content | complex
mixed | true
used by
complexType ds:ReferenceType
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="DigestMethod" type="ds:DigestMethodType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:DigestValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:DigestValueType
properties
content simple
used by
complexType ds:ReferenceType
source | <element name="DigestValue" type="ds:DigestValueType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:SignatureValue

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignatureValueType
properties
content complex
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureValue" type="ds:SignatureValueType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:Object

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ObjectType
properties
content | complex
mixed | true
used by
complexType ds:SignatureType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source | <element name="Object" type="ds:ObjectType"/>


Alphabetical list of used XSD definitions

Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023
All rights reserved

Alphabetical list of used XSD definitions

The following subchapters list all XSD definitions (simpleType, complexType etc.) used in the schema in alphabetical order.

B
balanceTGType
balanceTPType
bfsDataType
billerAddressType
bodyType
C
caseDetailType
companyType
countryType
creditType
D
debitorAddressType
dependsOnType
diagnosisType
documentType
documentsType
ds_CanonicalizationMethodType
ds_CryptoBinary
ds_DSAKeyValueType
ds_DigestMethodType
ds_DigestValueType
ds_HMACOutputLengthType
ds_KeyInfoType
ds_KeyValueType
ds_ManifestType
ds_ObjectType
ds_PGPDataType
ds_RSAKeyValueType
ds_ReferenceType
ds_RetrievalMethodType
ds_SPKIDataType
ds_SignatureMethodType
ds_SignaturePropertiesType
ds_SignaturePropertyType
ds_SignatureType
ds_SignatureValueType
ds_SignedInfoType
ds_TransformType
ds_TransformsType
ds_X509DataType
ds_X509IssuerSerialType
E
employerAddressType
esrAddressType
esrQRRedType
esrQRType
F
filenameType
G
garantType
glnPartyType
grouperDataType
guarantorAddressType
guidType
I
instructionType
instructionsType
insuranceAddressType
insuredAddressType
invoiceType
L
lawType
N
nonEmptyStringType
O
onlineAddressType
P
patientAddressType
payantType
payloadType
personType
postalAddressType
processingType
prologType
providerGLNAddressType
providerZSRAddressType
providersAddressType
R
referrerAddressType
reminderType
requestType
restCallType
S
serviceExType
serviceType
servicesType
softwareType
soldantType
ssnPartyType
streetType
stringType0_35
stringType0_350
stringType1_10
stringType1_100
stringType1_12
stringType1_140
stringType1_15
stringType1_160
stringType1_25
stringType1_255
stringType1_3
stringType1_30
stringType1_35
stringType1_350
stringType1_50
stringType1_6
stringType1_64
stringType1_70
stringType1_700
stringType1_80
stringType1_9
T
telecomAddressType
transportType
treatmentType
V
vatRateType
vatType
X
xenc_AgreementMethodType
xenc_CipherDataType
xenc_CipherReferenceType
xenc_EncryptedDataType
xenc_EncryptedKeyType
xenc_EncryptedType
xenc_EncryptionMethodType
xenc_EncryptionPropertiesType
xenc_EncryptionPropertyType
xenc_KeySizeType
xenc_ReferenceType
xenc_TransformsType
xtraAmbulatoryType
xtraDRGType
xtraDrugType
xtraHospitalType
xtraStationaryType
Z


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType balanceTGType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:vat
used by
element garantType/balance
attributes parameters
Name | Type | Use | Default | Fixed
currency | string | CHF
amount | double | required
amount_reminder | double | 0
amount_prepaid | double | 0
amount_due | double | required
attributes annotations
Name | Notes
currency | currency is the currency used for the whole invoice/reminder. The currency is fixed by the XSD schema to "CHF" - Swiss Francs!
amount | amount is the total amount for the invoice/reminder accumulated over all 2-digit precision service amounts. Therefore, the amount implicitly has a 2-digit precision as well.
amount_reminder amount_reminder is an optional reminder charge rounded to 2 significant decimal places.
Of course, if the request is an invoice amount_reminder must be 0.00.
amount_prepaid | amount_prepaid is the advanced payment for the invoice/reminder rounded to 2 significant decimal places.
amount_due amount_due is the amount due for the invoice/reminder (and coded into the ESR payment transaction) calculated as
«amount + amount_reminder - amount_prepaid»

where the used summands are 2-digit precision amounts and the result is finally rounded half up ("Kaufmännisches Runden")
source <complexType name="balanceTGType">
<sequence>
<element name="vat" type="invoice:vatType"/>
</sequence>
<attribute name="currency" type="string" fixed="CHF"/>
<attribute name="amount" type="double" use="required"/>
<attribute name="amount_reminder" type="double" default="0"/>
<attribute name="amount_prepaid" type="double" default="0"/>
<attribute name="amount_due" type="double" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType balanceTPType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:vat
used by
elements soldantType/balance payantType/balance
attributes parameters
Name | Type | Use | Default | Fixed
currency | string | CHF
amount | double | required
amount_reminder | double | 0
amount_due | double | required
attributes annotations
Name | Notes
currency | currency is the currency used for the whole invoice/reminder. The currency is fixed by the XSD schema to "CHF" - Swiss Francs!
amount | amount is the total amount for the invoice/reminder accumulated over all 2-digit precision service amounts. Therefore, the amount implicitly has a 2-digit precision as well.
amount_reminder amount_reminder is an optional reminder charge rounded to 2 significant decimal places.
Of course, if the request is an invoice amount_reminder must be 0.00.
amount_due amount_due is the amount due for the invoice/reminder (and coded into the ESR payment transaction) calculated as
«amount + amount_reminder - amount_prepaid»

where the used summands are 2-digit precision amounts and the result is finally rounded half up ("Kaufmännisches Runden")
source <complexType name="balanceTPType">
<sequence>
<element name="vat" type="invoice:vatType"/>
</sequence>
<attribute name="currency" type="string" fixed="CHF"/>
<attribute name="amount" type="double" use="required"/>
<attribute name="amount_reminder" type="double" default="0"/>
<attribute name="amount_due" type="double" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType bfsDataType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
elements xtraStationaryType/bfs_admission_type xtraStationaryType/bfs_decision_for_discharge xtraStationaryType/bfs_residence_after_discharge xtraStationaryType/bfs_residence_before_admission
attributes parameters
Name | Type | Use | Default | Fixed
code | invoice:stringType1_3 | required
name | invoice:stringType1_64 | required
attributes annotations
Name Notes
code code is in fact not a code but a number of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use code="2" and name="Krankenheim, Pflegeheim" for language="german".
name name is the language dependent name of the value space of a certain BfS code.
For example, one number/name pair combination of the BfS code 1.5.V03 (Aufenthalt nach Austritt) is 2 = Krankenheim, Pflegeheim in german. Therefore, for coding this combination use number="2" and name="Krankenheim, Pflegeheim" for language="german".

If name exceeds 64 characters then it is trimmed to 60 characters and the characters ("...") are appended.

source <complexType name="bfsDataType">
<attribute name="code" type="invoice:stringType1_3" use="required"/>
<attribute name="name" type="invoice:stringType1_64" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType billerAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:company invoice:person
used by
elements garantType/biller soldantType/biller payantType/biller
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
uid_number invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the biller's GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the treatment is carried out by the patient himself or a relative of the patient.
uid_number uid_number is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789
source <complexType name="billerAddressType">
<choice>
<element name="company" type="invoice:companyType"/>
<element name="person" type="invoice:personType"/>
</choice>
<attribute name="gln" type="invoice:glnPartyType" use="required"/>
<attribute name="uid_number" type="invoice:stringType1_15"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType bodyType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:prolog invoice:remark invoice:tiers_garant invoice:tiers_soldant invoice:tiers_payant invoice:esrQR invoice:esrQRRed invoice:law invoice:treatment invoice:services invoice:documents
used by
element payloadType/body
attributes parameters
Name | Type | Use | Default | Fixed
role_title invoice:stringType1_35
role | derived by: NMTOKEN | required
place | derived by: NMTOKEN | required
attributes annotations
Name | Notes
role role defines the principal role of the main provider ("what is the main provider") encoded by a terminal set of tokens
  • physician: the principal role of the service provider is physician
  • physiotherapist: the principal role of the service provider is physiotherapist including therapeutic masseurs
  • chiropractor: the principal role of the service provider is chiropractor
  • ergotherapist: the principal role of the service provider is ergotherapist
  • nutritionist: the principal role of the service provider is nutritionist including diet advisors, diabetic advisors
  • midwife: the principal role of the service provider is midwife
  • logotherapist: the principal role of the service provider is logotherapist
  • hospital: the principal role of the service provider is hospital
  • pharmacist: the principal role of the service provider is pharmacist
  • dentist: the principal role of the service provider is dentist including dental hygienists
  • labtechnician: the principal role of the service provider is labtechnician
  • dentaltechnician: the principal role of the service provider is dentaltechnician
  • othertechnician: the principal role of the service provider is othertechnician including shoemakers
  • psychologist: the principal role of the service provider is psychologist
  • wholesaler: the principal role of the service provider is wholesaler
  • nursingstaff: the principal role of the service provider is nursing staff including nursing auxiliaries
  • transport: the principal role of the service provider is transport including ambulances
  • druggist: the principal role of the service provider is druggist
  • naturopathicdoctor: the principal role of the service provider is naturopathic doctor (as per definition this is a doctor of none-conventional Western medicine/none-biomedicine)
  • naturopathictherapist: the principal role of the service provider is naturopathic therapist (as per definition this is therapist none-conventional Western medicine/none-biomedicine) including wellness therapists
  • other: the principal role of the service provider is other if none of the above applies
role_title | role_title optionally further defines the role. role_title is mandatory if the role=other is set!
place place defines the principal place of the main provider ("where is the main provider") encoded by a terminal set of tokens
  • practice: the main place of the service provision is at a practice
  • hospital: the main place of the service provision is at a hospital
  • lab: the main place of the service provision is at a lab
  • association: the main place of the service provision is at a association (e.g. Spitex)
  • company: the main place of the service provision is by a company (e.g. transports)
attributes enumerations
Name | Extension | Base | Value | Annotations
place | NMTOKEN | practice | the main place of the service provision is at a practice
place | NMTOKEN | hospital | the main place of the service provision is at a hospital
place | NMTOKEN | lab | the main place of the service provision is at a lab
place | NMTOKEN | association | the main place of the service provision is at a association (e.g. Spitex)
place | NMTOKEN | company | the main place of the service provision is by a company (e.g. transports)
role | NMTOKEN | physician | the principal role of the service provider is physician
role | NMTOKEN | physiotherapist | the principal role of the service provider is physiotherapist including therapeutic masseurs
role | NMTOKEN | chiropractor | the principal role of the service provider is chiropractor
role | NMTOKEN | ergotherapist | the principal role of the service provider is ergotherapist
role | NMTOKEN | nutritionist | the principal role of the service provider is nutritionist including diet advisors, diabetic advisors
role | NMTOKEN | midwife | the principal role of the service provider is midwife
role | NMTOKEN | logotherapist | the principal role of the service provider is logotherapist
role | NMTOKEN | hospital | the principal role of the service provider is hospital
role | NMTOKEN | pharmacist | the principal role of the service provider is pharmacist
role | NMTOKEN | dentist | the principal role of the service provider is dentist including dental hygienists
role | NMTOKEN | labtechnician | the principal role of the service provider is labtechnician
role | NMTOKEN | dentaltechnician | the principal role of the service provider is dentaltechnician
role | NMTOKEN | othertechnician | the principal role of the service provider is othertechnician including shoemakers
role | NMTOKEN | psychologist | the principal role of the service provider is psychologist
role | NMTOKEN | wholesaler | the principal role of the service provider is wholesaler
role | NMTOKEN | nursingstaff | the principal role of the service provider is nursing staff including nursing auxiliaries
role | NMTOKEN | transport | the principal role of the service provider is transport including ambulances
role | NMTOKEN | druggist | the principal role of the service provider is druggist
role | NMTOKEN | naturopathicdoctor | the principal role of the service provider is naturopathic doctor (as per definition this is a doctor of none-conventional Western medicine/none-biomedicine)
role | NMTOKEN | naturopathictherapist | the principal role of the service provider is naturopathic therapist (as per definition this is therapist none-conventional Western medicine/none-biomedicine) including wellness therapists
role | NMTOKEN | other | the principal role of the service provider is other if none of the above applies
source <complexType name="bodyType">
<sequence>
<element name="prolog" type="invoice:prologType"/>
<element name="remark" type="invoice:stringType1_350" minOccurs="0"/>
<choice>
<element name="tiers_garant" type="invoice:garantType"/>
<element name="tiers_soldant" type="invoice:soldantType"/>
<element name="tiers_payant" type="invoice:payantType"/>
</choice>
<choice>
<element name="esrQR" type="invoice:esrQRType"/>
<element name="esrQRRed" type="invoice:esrQRRedType"/>
</choice>
<element name="law" type="invoice:lawType"/>
<element name="treatment" type="invoice:treatmentType"/>
<element name="services" type="invoice:servicesType"/>
<element name="documents" type="invoice:documentsType" minOccurs="0"/>
</sequence>
<attribute name="role_title" type="invoice:stringType1_35"/>
<attribute name="role" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="physician"/>
<enumeration value="physiotherapist"/>
<enumeration value="chiropractor"/>
<enumeration value="ergotherapist"/>
<enumeration value="nutritionist"/>
<enumeration value="midwife"/>
<enumeration value="logotherapist"/>
<enumeration value="hospital"/>
<enumeration value="pharmacist"/>
<enumeration value="dentist"/>
<enumeration value="labtechnician"/>
<enumeration value="dentaltechnician"/>
<enumeration value="othertechnician"/>
<enumeration value="psychologist"/>
<enumeration value="wholesaler"/>
<enumeration value="nursingstaff"/>
<enumeration value="transport"/>
<enumeration value="druggist"/>
<enumeration value="naturopathicdoctor"/>
<enumeration value="naturopathictherapist"/>
<enumeration value="other"/>
</restriction>
</simpleType>
</attribute>
<attribute name="place" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="practice"/>
<enumeration value="hospital"/>
<enumeration value="lab"/>
<enumeration value="association"/>
<enumeration value="company"/>
</restriction>
</simpleType>
</attribute>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType caseDetailType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element xtraStationaryType/case_detail
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
tariff_type | derived by: string
code invoice:stringType1_30
date | dateTime | required
bfs_medstatistic_code invoice:stringType1_35
acid | invoice:stringType1_35 | required
attributes annotations
Name | Notes
record_id | record_id is a sequence number (starting with 1 and incremented by 1 for each further record) that uniquely identifies the record
tariff_type | the optional tariff_type is the official 3-character designator of the tariff as given by Forum Datenaustausch
code | the optional code is the code of the service as given by the used tariff catalog
date | date is the date and time when the given BfS variable occurred
bfs_medstatistic_code the optional bfs_medstatistic_code supplies information about the case history in terms of admission, discharge, vacancy periods, re-location etc. all encoded and described by described by BfS variables from the "Medical statistics Specification". The variable is syntactically build as BfS_variable_number = BfS_variable_value, e.g. "1.2.V02 = 1" for coding "residence before admission=home" "1.5.V03=1" for defining "residence after discharge=home"

One single caseDetail entry defines one single event, whereas the variable content is neither case-sensitive nor whitespace-dependent.

acid | acid is the administrative case identification of the main software for the given case detail entry, defined exclusively for the exchange with the insurers.
source <complexType name="caseDetailType">
<attribute name="record_id" use="required">
<simpleType>
<restriction base="int">
<minInclusive value="1"/>
<maxInclusive value="999999999"/>
</restriction>
</simpleType>
</attribute>
<attribute name="tariff_type">
<simpleType>
<restriction base="string">
<pattern value="[0-9A-Z]{3}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="code" type="invoice:stringType1_30"/>
<attribute name="date" type="dateTime" use="required"/>
<attribute name="bfs_medstatistic_code" type="invoice:stringType1_35"/>
<attribute name="acid" type="invoice:stringType1_35" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType companyType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:companyname invoice:department invoice:subaddressing invoice:postal invoice:telecom invoice:online
used by
elements billerAddressType/company debitorAddressType/company providerGLNAddressType/company providerZSRAddressType/company insuranceAddressType/company guarantorAddressType/company referrerAddressType/company employerAddressType/company esrAddressType/company
source <complexType name="companyType">
<sequence>
<element name="companyname" type="invoice:stringType1_35"/>
<element name="department" type="invoice:stringType1_35" minOccurs="0"/>
<element name="subaddressing" type="invoice:stringType1_35" minOccurs="0"/>
<element name="postal" type="invoice:postalAddressType"/>
<element name="telecom" type="invoice:telecomAddressType" minOccurs="0"/>
<element name="online" type="invoice:onlineAddressType" minOccurs="0"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType countryType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | extension of invoice:stringType0_35
properties
base invoice:stringType0_35
used by
element postalAddressType/country
facets
minLength | 0
maxLength | 35
attributes parameters
Name | Type | Use | Default | Fixed
countrycode | invoice:stringType1_3 | CH
attributes annotations
Name | Notes
countrycode | countrycode is the ISO designator of the country ("CH" is the default value)
Extensions
Annotation | Base
Definition for the country container (a subcontainer of an address definition) giving the country and its ISO designator | invoice:stringType0_35
source <complexType name="countryType">
<simpleContent>
<extension base="invoice:stringType0_35">
<attribute name="countrycode" type="invoice:stringType1_3" default="CH"/>
</extension>
</simpleContent>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType creditType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element payloadType/credit
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | invoice:stringType1_35 | required
attributes annotations
Name Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the credit's infoset generation
This is one of 3 identifiers that form the credit object reference. request_timestamp will be generated once for a new credit object reference and thereafter always referenced!
request_date request_date is the main software's date of the credit request ("KoGu Falldatum")
This is one of 3 identifiers that form the credit object reference. request_date must be identical for the same credit object reference!
request_id request_id is the main software's ID of the credit request ("KoGu Fallnummer")
This is one of 3 identifiers that form the credit object reference. request_id must be identical for the same credit object reference!
source <complexType name="creditType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="1924902000"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="invoice:stringType1_35" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType debitorAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:company invoice:person
used by
elements garantType/debitor soldantType/debitor payantType/debitor
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
uid invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the debitor's GLN number as defined by RefData
Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789

Please note, that the UID is optional and possibly defined for legal entities. Thus the UID is always empty for natural persons.
source <complexType name="debitorAddressType">
<choice>
<element name="company" type="invoice:companyType"/>
<element name="person" type="invoice:personType"/>
</choice>
<attribute name="gln" type="invoice:glnPartyType" use="required"/>
<attribute name="uid" type="invoice:stringType1_15"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType dependsOnType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element softwareType/depends_on
attributes parameters
Name | Type | Use | Default | Fixed
name | invoice:stringType1_50 | required
copyright invoice:stringType1_50
description invoice:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the dependent software/module
copyright | copyright defines the copyright notice of the dependent software/module
description | description supplies a short description of the dependent software/module
version version defines the version of the dependent software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the dependent software/module (should such an id exist)
source <complexType name="dependsOnType">
<attribute name="name" type="invoice:stringType1_50" use="required"/>
<attribute name="copyright" type="invoice:stringType1_50"/>
<attribute name="description" type="invoice:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType diagnosisType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | extension of invoice:stringType0_350
properties
base invoice:stringType0_350
used by
element treatmentType/diagnosis
facets
maxLength 350
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN | by_contract
code invoice:stringType1_12
attributes annotations
Name | Notes
type type is the type of diagnosis catalog used encoded by a terminal set of tokens
  • ICD: the diagnosis catalog is ICD (e.g. ICD-10)
  • cantonal: the diagnosis catalog is the cantonal TI catalog
  • DRG: the diagnosis catalog is DRG (a DRG service position)
  • by_contract: the diagnosis is as defined by an individual contract (between provider and insurance)
  • freetext: the diagnosis is given as freetext
  • birthdefect: the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
  • ICPC: the diagnosis catalog is ICPC (e.g. ICPC-2)
code | code is the used code of the designated diagnosis catalog
attributes enumerations
Name | Extension | Base | Value | Annotations
type | stringType0_350 | NMTOKEN | ICD | the diagnosis catalog is ICD (e.g. ICD-10)
type | stringType0_350 | NMTOKEN | cantonal | the diagnosis catalog is the cantonal TI catalog
type | stringType0_350 | NMTOKEN | DRG | the diagnosis catalog is DRG (a DRG service position)
type | stringType0_350 | NMTOKEN | by_contract | the diagnosis is as defined by an individual contract (between provider and insurance)
type | stringType0_350 | NMTOKEN | freetext | the diagnosis is given as freetext
type | stringType0_350 | NMTOKEN | birthdefect | the diagnosis is a birthdefect coded from the "Geburtsgebrechenliste"
type | stringType0_350 | NMTOKEN | ICPC | the diagnosis catalog is ICPC (e.g. ICPC-2)
Extensions
Annotation | Base
Definition for the diagnosis container | invoice:stringType0_350
source <complexType name="diagnosisType">
<simpleContent>
<extension base="invoice:stringType0_350">
<attribute name="type" default="by_contract">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="ICD"/>
<enumeration value="cantonal"/>
<enumeration value="DRG"/>
<enumeration value="by_contract"/>
<enumeration value="freetext"/>
<enumeration value="birthdefect"/>
<enumeration value="ICPC"/>
</restriction>
</simpleType>
</attribute>
<attribute name="code" type="invoice:stringType1_12"/>
</extension>
</simpleContent>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType documentsType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:document
used by
element bodyType/documents
attributes parameters
Name | Type | Use | Default | Fixed
number | unsignedLong | required
attributes annotations
Name | Notes
number | number defines total number of documents included in the infoset
source <complexType name="documentsType">
<sequence>
<element name="document" type="invoice:documentType" maxOccurs="unbounded"/>
</sequence>
<attribute name="number" type="unsignedLong" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType documentType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:base64
used by
element documentsType/document
attributes parameters
Name | Type | Use | Default | Fixed
title | invoice:stringType1_35 | required
filename | invoice:filenameType | required
mimeType | derived by: string | required
attributes annotations
Name | Notes
title | title is the document's title on the primary system and thus describes the document in terms of its semantic content.
filename filename defines the file name (without any path information) on the source system
This information is an aid for saving the file at the target location as well as for MIME type sniffing.
mimeType | mimeType defines the Multipurpose Internet Mail Extension (MIME) type of the document. The MIME type bassically allows a type definition of the document as given in IANA: MIME Media Types and is used to reducethe allowed document space to application/pdf, image/jpeg, and image/png by defining the appropriate pattern
source <complexType name="documentType">
<sequence>
<element name="base64" type="base64Binary"/>
</sequence>
<attribute name="title" type="invoice:stringType1_35" use="required"/>
<attribute name="filename" type="invoice:filenameType" use="required"/>
<attribute name="mimeType" use="required">
<simpleType>
<restriction base="string">
<pattern value="(application/pdf|image/jpeg|image/png)"/>
</restriction>
</simpleType>
</attribute>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:CanonicalizationMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:CanonicalizationMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="CanonicalizationMethodType" mixed="true">
<sequence>
<any namespace="##any" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:DigestMethodType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:DigestMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="DigestMethodType" mixed="true">
<sequence>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:DSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:P ds:Q ds:G ds:Y ds:J ds:Seed ds:PgenCounter
used by
element ds:DSAKeyValue
source <complexType name="DSAKeyValueType">
<sequence>
<sequence minOccurs="0">
<element name="P" type="ds:CryptoBinary"/>
<element name="Q" type="ds:CryptoBinary"/>
</sequence>
<element name="G" type="ds:CryptoBinary" minOccurs="0"/>
<element name="Y" type="ds:CryptoBinary"/>
<element name="J" type="ds:CryptoBinary" minOccurs="0"/>
<sequence minOccurs="0">
<element name="Seed" type="ds:CryptoBinary"/>
<element name="PgenCounter" type="ds:CryptoBinary"/>
</sequence>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:KeyInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
used by
elements ds:KeyInfo xenc:AgreementMethodType/OriginatorKeyInfo xenc:AgreementMethodType/RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="KeyInfoType" mixed="true">
<choice maxOccurs="unbounded">
<element ref="ds:KeyName"/>
<element ref="ds:KeyValue"/>
<element ref="ds:RetrievalMethod"/>
<element ref="ds:X509Data"/>
<element ref="ds:PGPData"/>
<element ref="ds:SPKIData"/>
<element ref="ds:MgmtData"/>
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
</choice>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:KeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:DSAKeyValue ds:RSAKeyValue
used by
element ds:KeyValue
source <complexType name="KeyValueType" mixed="true">
<choice>
<element ref="ds:DSAKeyValue"/>
<element ref="ds:RSAKeyValue"/>
<any namespace="##other" processContents="lax"/>
</choice>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:ManifestType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Reference
used by
element ds:Manifest
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="ManifestType">
<sequence>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:ObjectType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:Object
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="ObjectType" mixed="true">
<sequence minOccurs="0" maxOccurs="unbounded">
<any namespace="##any" processContents="lax"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
<!-- add a grep facet -->
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:PGPDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:PGPKeyID ds:PGPKeyPacket ds:PGPKeyPacket
used by
element ds:PGPData
source <complexType name="PGPDataType">
<choice>
<sequence>
<element name="PGPKeyID" type="base64Binary"/>
<element name="PGPKeyPacket" type="base64Binary" minOccurs="0"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<sequence>
<element name="PGPKeyPacket" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</choice>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:ReferenceType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms ds:DigestMethod ds:DigestValue
used by
element ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
URI | anyURI | optional
Type | anyURI | optional
source <complexType name="ReferenceType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
<element ref="ds:DigestMethod"/>
<element ref="ds:DigestValue"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="URI" type="anyURI" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:RetrievalMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transforms
used by
element ds:RetrievalMethod
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI
Type | anyURI | optional
source <complexType name="RetrievalMethodType">
<sequence>
<element ref="ds:Transforms" minOccurs="0"/>
</sequence>
<attribute name="URI" type="anyURI"/>
<attribute name="Type" type="anyURI" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:RSAKeyValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Modulus ds:Exponent
used by
element ds:RSAKeyValue
source <complexType name="RSAKeyValueType">
<sequence>
<element name="Modulus" type="ds:CryptoBinary"/>
<element name="Exponent" type="ds:CryptoBinary"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:SignatureMethodType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:HMACOutputLength
used by
element ds:SignatureMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="SignatureMethodType" mixed="true">
<sequence>
<element name="HMACOutputLength" type="ds:HMACOutputLengthType" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<!-- (0,unbounded) elements from (1,1) external namespace -->
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:SignaturePropertiesType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignatureProperty
used by
element ds:SignatureProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignaturePropertiesType">
<sequence>
<element ref="ds:SignatureProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:SignatureProperty

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertyType
properties
content | complex
mixed | true
used by
complexType ds:SignaturePropertiesType
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source | <element name="SignatureProperty" type="ds:SignaturePropertyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:SignaturePropertyType

diagram
namespace http://www.w3.org/2000/09/xmldsig#
properties
mixed true
used by
element ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | required
Id | ID | optional
source <complexType name="SignaturePropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (1,unbounded) namespaces -->
</choice>
<attribute name="Target" type="anyURI" use="required"/>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:SignatureType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SignedInfo ds:SignatureValue ds:KeyInfo ds:Object
used by
element ds:Signature
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureType">
<sequence>
<element ref="ds:SignedInfo"/>
<element ref="ds:SignatureValue"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="ds:Object" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:SignatureValueType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | extension of base64Binary
properties
base base64Binary
used by
element ds:SignatureValue
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignatureValueType">
<simpleContent>
<extension base="base64Binary">
<attribute name="Id" type="ID" use="optional"/>
</extension>
</simpleContent>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:SignedInfoType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:CanonicalizationMethod ds:SignatureMethod ds:Reference
used by
element ds:SignedInfo
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="SignedInfoType">
<sequence>
<element ref="ds:CanonicalizationMethod"/>
<element ref="ds:SignatureMethod"/>
<element ref="ds:Reference" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:SPKIDataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:SPKISexp
used by
element ds:SPKIData
source <complexType name="SPKIDataType">
<sequence maxOccurs="unbounded">
<element name="SPKISexp" type="base64Binary"/>
<any namespace="##other" processContents="lax" minOccurs="0"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:TransformsType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:Transform
used by
element ds:Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:TransformType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
properties
mixed true
children | ds:XPath
used by
element ds:Transform
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="TransformType" mixed="true">
<choice minOccurs="0" maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
<!-- (1,1) elements from (0,unbounded) namespaces -->
<element name="XPath" type="string"/>
</choice>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:X509DataType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerSerial ds:X509SKI ds:X509SubjectName ds:X509Certificate ds:X509CRL
used by
element ds:X509Data
source <complexType name="X509DataType">
<sequence maxOccurs="unbounded">
<choice>
<element name="X509IssuerSerial" type="ds:X509IssuerSerialType"/>
<element name="X509SKI" type="base64Binary"/>
<element name="X509SubjectName" type="string"/>
<element name="X509Certificate" type="base64Binary"/>
<element name="X509CRL" type="base64Binary"/>
<any namespace="##other" processContents="lax"/>
</choice>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType ds:X509IssuerSerialType

diagram
namespace | http://www.w3.org/2000/09/xmldsig#
children | ds:X509IssuerName ds:X509SerialNumber
used by
element ds:X509DataType/X509IssuerSerial
source <complexType name="X509IssuerSerialType">
<sequence>
<element name="X509IssuerName" type="string"/>
<element name="X509SerialNumber" type="integer"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType employerAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:company invoice:person
used by
elements garantType/employer soldantType/employer payantType/employer
attributes parameters
Name Type Use Default Fixed
gln invoice:glnPartyType
reg_number invoice:stringType1_35
attributes annotations
Name | Notes
gln | gln is the employer's GLN as defined by RefData
reg_number | reg_number is the employer's national BUR number as defined by Swiss Federal Statistical Office
source <complexType name="employerAddressType">
<choice>
<element name="company" type="invoice:companyType"/>
<element name="person" type="invoice:personType"/>
</choice>
<attribute name="gln" type="invoice:glnPartyType"/>
<attribute name="reg_number" type="invoice:stringType1_35"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType esrAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:company invoice:person
used by
elements esrQRRedType/creditor esrQRType/creditor
source <complexType name="esrAddressType">
<choice>
<element name="company" type="invoice:companyType"/>
<element name="person" type="invoice:personType"/>
</choice>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType esrQRRedType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:creditor
used by
element bodyType/esrQRRed
attributes parameters
Name | Type | Use | Default | Fixed
subtype | derived by: NMTOKEN | esrQRRed
iban | derived by: string | required
reference_number | derived by: string
alternative_scheme1 invoice:stringType1_100
alternative_scheme2 invoice:stringType1_100
payment_reason invoice:stringType1_140
payment_period | duration
attributes annotations
Name | Notes
subtype subtype is the PayInSlip with QR subtype specification encoded by a terminal set of tokens
  • esrQRRedplus: esrQRRedplus is an «PayInSlip+ with QR without amount». Furthermore, any layouted print out must not set an amount inside the QR and in the amount fields.
  • esrQRRed: esrQRRed is an ordinary «PayInSlip with QR» (Default).
iban iban is a mandatory IBAN of Switzerland or Liechtenstein (21 characters) that defines the creditor's account at the given bank.
The format of the IBAN is in the standard representation without whitespace. Pursuant to the guidelines, the IBAN should be divided up from the left in blocks of 4 separated by blanks when printed.
reference_number reference_number is an optional 25 character Creditor Reference number (ISO 11649)
Pursuant to the guidelines the reference number should be divided up from the right in blocks of 5 separated by blanks when printed.
alternative_scheme1 | alternative_scheme1 defines the 1st optional alternative scheme as defined by the Swiss QR-Invoice standard. Since the exact layout of the supplied scheme is undefined and can not be validated/covered by a data pattern, it is in the responsibility of the invoice generator to check, validate and correctly process such an alternative scheme.
alternative_scheme2 | alternative_scheme2 defines the 2nd optional alternative scheme as defined by the Swiss QR-Invoice standard. Since the exact layout of the supplied scheme is undefined and can not be validated/covered by a data pattern, it is in the responsibility of the invoice generator to check, validate and correctly process such an alternative scheme.
payment_reason | The optional payment_reason consisting of a maximum of 140 characters defining the reason for the payment. The intent of the text is purely one of the creditor.
payment_period | payment_period is the payment period in which the invoice/reminder should be paid
attributes enumerations
Name | Extension | Base | Value | Annotations
subtype | NMTOKEN | esrQRRedplus | esrQRRedplus is an «PayInSlip+ with QR without amount». Furthermore, any layouted print out must not set an amount inside the QR and in the amount fields.
subtype | NMTOKEN | esrQRRed | esrQRRed is an ordinary «PayInSlip with QR» (Default).
source <complexType name="esrQRRedType">
<sequence>
<element name="creditor" type="invoice:esrAddressType"/>
</sequence>
<attribute name="subtype" default="esrQRRed">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="esrQRRed"/>
<enumeration value="esrQRRedplus"/>
</restriction>
</simpleType>
</attribute>
<attribute name="iban" use="required">
<simpleType>
<restriction base="string">
<pattern value="(LI|CH)[0-9]{7}[0-9A-Z]{12}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="reference_number">
<simpleType>
<restriction base="string">
<pattern value="RF[0-9]{2}[0-9A-Z]{1,21}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="alternative_scheme1" type="invoice:stringType1_100"/>
<attribute name="alternative_scheme2" type="invoice:stringType1_100"/>
<attribute name="payment_reason" type="invoice:stringType1_140"/>
<attribute name="payment_period" type="duration"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType esrQRType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:creditor
used by
element bodyType/esrQR
attributes parameters
Name | Type | Use | Default | Fixed
subtype | derived by: NMTOKEN | esrQR
iban | derived by: string | required
reference_number | derived by: string | required
alternative_scheme1 invoice:stringType1_100
alternative_scheme2 invoice:stringType1_100
payment_reason invoice:stringType1_140
payment_period | duration
attributes annotations
Name | Notes
subtype subtype is the EsrQR subtype specification encoded by a terminal set of tokens
  • esrQRplus: esrQRplus is an «ESR+ with QR without amount». Furthermore, any layouted print out must not set an amount inside the QR and in the amount fields.
  • esrQR: esrQR is an ordinary «ESR with QR» (Default).
iban iban is a mandatory IBAN of Switzerland or Liechtenstein (21 characters) that defines the creditor's account at the given bank.
The format of the IBAN is in the standard representation without whitespace. Pursuant to the guidelines, the IBAN should be divided up from the left in blocks of 4 separated by blanks when printed.
reference_number reference_number is a 27-digit reference number.
Pursuant to the guidelines the reference number should be divided up from the right in blocks of 5 separated by blanks when printed.
alternative_scheme1 | alternative_scheme1 defines the 1st optional alternative scheme as defined by the Swiss QR-Invoice standard. Since the exact layout of the supplied scheme is undefined and can not be validated/covered by a data pattern, it is in the responsibility of the invoice generator to check, validate and correctly process such an alternative scheme.
alternative_scheme2 | alternative_scheme2 defines the 2nd optional alternative scheme as defined by the Swiss QR-Invoice standard. Since the exact layout of the supplied scheme is undefined and can not be validated/covered by a data pattern, it is in the responsibility of the invoice generator to check, validate and correctly process such an alternative scheme.
payment_reason | The optional payment_reason consisting of a maximum of 140 characters defining the reason for the payment. The intent of the text is purely one of the creditor.
payment_period | payment_period is the payment period in which the invoice/reminder should be paid
attributes enumerations
Name | Extension | Base | Value | Annotations
subtype | NMTOKEN | esrQRplus | esrQRplus is an «ESR+ with QR without amount». Furthermore, any layouted print out must not set an amount inside the QR and in the amount fields.
subtype | NMTOKEN | esrQR | esrQR is an ordinary «ESR with QR» (Default).
source <complexType name="esrQRType">
<sequence>
<element name="creditor" type="invoice:esrAddressType"/>
</sequence>
<attribute name="subtype" default="esrQR">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="esrQR"/>
<enumeration value="esrQRplus"/>
</restriction>
</simpleType>
</attribute>
<attribute name="iban" use="required">
<simpleType>
<restriction base="string">
<pattern value="(LI|CH)[0-9]{7}[0-9A-Z]{12}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="reference_number" use="required">
<simpleType>
<restriction base="string">
<pattern value="[0-9]{27}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="alternative_scheme1" type="invoice:stringType1_100"/>
<attribute name="alternative_scheme2" type="invoice:stringType1_100"/>
<attribute name="payment_reason" type="invoice:stringType1_140"/>
<attribute name="payment_period" type="duration"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType garantType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:biller invoice:debitor invoice:providers invoice:insurance invoice:patient invoice:guarantor invoice:referrer invoice:employer invoice:balance
used by
element bodyType/tiers_garant
source <complexType name="garantType">
<sequence>
<element name="biller" type="invoice:billerAddressType"/>
<element name="debitor" type="invoice:debitorAddressType"/>
<element name="providers" type="invoice:providersAddressType"/>
<element name="insurance" type="invoice:insuranceAddressType" minOccurs="0"/>
<element name="patient" type="invoice:patientAddressType"/>
<element name="guarantor" type="invoice:guarantorAddressType"/>
<element name="referrer" type="invoice:referrerAddressType" minOccurs="0"/>
<element name="employer" type="invoice:employerAddressType" minOccurs="0"/>
<element name="balance" type="invoice:balanceTGType"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType grouperDataType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
elements xtraStationaryType/admission_type xtraStationaryType/discharge_type xtraStationaryType/provider_type
attributes parameters
Name | Type | Use | Default | Fixed
number | invoice:stringType1_3 | required
name | invoice:stringType1_64 | required
attributes annotations
Name Notes
number number is the number part of a certain grouper data record.
For example, the 2nd choice of the grouper provider type is Maison des naissances in french. Therefore to code this combination use number="2" and name="Maison des naissances" for language="french".
name name is the language dependent name part of a grouper data record.
For example, the 2nd choice of the grouper provider type is Maison des naissances in french. Therefore to code this combination use number="2" and name="Maison des naissances" for language="french".

If name exceeds 64 characters then it is trimmed to 60 characters and the characters ("...") are appended.

source <complexType name="grouperDataType">
<attribute name="number" type="invoice:stringType1_3" use="required"/>
<attribute name="name" type="invoice:stringType1_64" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType guarantorAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:company invoice:person
used by
elements garantType/guarantor soldantType/guarantor payantType/guarantor
attributes parameters
Name Type Use Default Fixed
gln invoice:glnPartyType
uid invoice:stringType1_15
attributes annotations
Name Notes
gln gln is the guarantors's GLN number as defined by RefData
Please note, that the GLN is optional, because a GLN is not assigned to all entities Please note, that the GLN is required and therefore a pseudo GLN from the private sector (e.g. 2000000000008) must be used, if the debitor does not have an official GLN
uid uid is the UID number in the electronic layout as defined by the "Swiss Federal Tax Administration".
In the electronic layout all punctuation characters ('-' and '.') are striped. Consequently, the UID number must be expanded appropriately prior to be printed, e.g.
  • CHE123456789 in the electronic layout is printed as CHE-123.456.789

Please note, that the UID is optional and possibly defined for legal entities. Thus the UID is always empty for natural persons.
source <complexType name="guarantorAddressType">
<choice>
<element name="company" type="invoice:companyType"/>
<element name="person" type="invoice:personType"/>
</choice>
<attribute name="gln" type="invoice:glnPartyType"/>
<attribute name="uid" type="invoice:stringType1_15"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType instructionsType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:instruction
used by
element processingType/instructions
source <complexType name="instructionsType">
<sequence>
<element name="instruction" type="invoice:instructionType" maxOccurs="unbounded"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType instructionType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element instructionsType/instruction
attributes parameters
Name | Type | Use | Default | Fixed
token | invoice:stringType1_255 | required
value | invoice:stringType1_255 | required
attributes annotations
Name | Notes
token | token is the name of the token/value instruction coded as a string.
value | value is the value of the token/value instruction coded as a string.
source <complexType name="instructionType">
<attribute name="token" type="invoice:stringType1_255" use="required"/>
<attribute name="value" type="invoice:stringType1_255" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType insuranceAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:company invoice:person
used by
elements garantType/insurance soldantType/insurance payantType/insurance
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
attributes annotations
Name | Notes
gln | gln is the insurance's GLN as defined by RefData
source <complexType name="insuranceAddressType">
<choice>
<element name="company" type="invoice:companyType"/>
<element name="person" type="invoice:personType"/>
</choice>
<attribute name="gln" type="invoice:glnPartyType" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType insuredAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:person
used by
element payantType/insured
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
sex | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn | invoice:ssnPartyType | 7569999999991
insured_id invoice:stringType1_35
attributes annotations
Name | Notes
gender gender defines the social gender encoded by a terminal set of tokens
  • male: the patient decides to have a gender of male
  • female: the patient decides to have a gender of female
  • diverse: the patient decides to have a gender of diverse
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
birthdate | birthdate defines the birthdate of the insured
ssn ssn defines the social security number of the insured whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
insured_id | the insured_id defines the required 20-digits official identification number of the patient at the insurance. If the so-called insurance card number is unknown or unavailable (it might be a resident of a foreign country) than supply the proprietary customer number identifying the patient at that insurance.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the patient decides to have a gender of male
gender | NMTOKEN | female | the patient decides to have a gender of female
gender | NMTOKEN | diverse | the patient decides to have a gender of diverse
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
source <complexType name="insuredAddressType">
<sequence>
<element name="person" type="invoice:personType"/>
</sequence>
<attribute name="gender" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
<enumeration value="diverse"/>
</restriction>
</simpleType>
</attribute>
<attribute name="sex" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
</restriction>
</simpleType>
</attribute>
<attribute name="birthdate" type="dateTime" use="required"/>
<attribute name="ssn" type="invoice:ssnPartyType" default="7569999999991"/>
<attribute name="insured_id" type="invoice:stringType1_35"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType invoiceType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element payloadType/invoice
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | invoice:stringType1_35 | required
guid | invoice:guidType | required
attributes annotations
Name | Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the invoice's infoset generation
This is one of 3 identifiers that form the invoice object reference. request_timestamp will be generated once for a new invoice object reference and thereafter always referenced!
request_date request_date is the main software's date of the invoice request ("Rechnungsdatum")
This is one of 3 identifiers that form the invoice object reference. request_date must be identical for the same invoice object reference!
request_id request_id is the main software's ID of the invoice request ("Rechnungsnummer")
This is one of 3 identifiers that form the invoice object reference. request_id must be identical for the same invoice object reference!
guid | guid is an internally used unique identifier of the current XML infoset defined as a 32-character string
source <complexType name="invoiceType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="1924902000"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="invoice:stringType1_35" use="required"/>
<attribute name="guid" type="invoice:guidType" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType lawType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element bodyType/law
attributes parameters
Name | Type | Use | Default | Fixed
type | derived by: NMTOKEN | required
insured_id invoice:stringType1_35
customer_no invoice:stringType1_35
case_id invoice:stringType1_35
case_date | dateTime
attributes annotations
Name Notes
type type is the type of applicable law encoded by a terminal set of tokens
  • KVG: the applicable law is "Krankenversicherungsgesetz" abbreviated {"KVG" | "LAMal" | "LAMal"} in the official national languages
  • VVG: the applicable law is "Versicherungsvertragsgesetz" abbreviated {"VVG" | "LCA" | "LCA"} in the official national languages
  • UVG: the applicable law is "Unfallversicherungsgesetz" abbreviated {"UVG" | "LAA" | "LAINF"} in the official national languages
  • IVG: the applicable law is "Invalidenversicherungsgesetz" abbreviated {"IVG" | "LAI" | "LAI"} in the official national languages
  • MVG: the applicable law is "Militäversicherungsgesetz" abbreviated {"MVG" | "LAM" | "LAM"} in the official national languages
  • ORG: the applicable law is "Obligationenrechtsgesetz" abbreviated {"ORG" | "CO" | "CO"} in the official national languages
insured_id insured_id is the patient's identification number at the insurance (the policy number).
It should be noted that the existence, form and specifications of insured_id is dependent on the law:
  • KVG: defines the required 20-digits official identification number of the patient at the insurance. If the so-called insurance card number is unknown or unavailable (it might be a resident of a foreign country) than supply the proprietary customer number identifying the patient at that insurance.
  • VVG: defines the optional VVG identification number of the patient.
  • UVG: defines the optional SSN ("social security number") as the UVG's identification number of the patient.
  • IVG: defines the required SSN ("social security number") as the IVG's identification number of the patient.
    If no SSN is supplied, a rejection must be expected.
  • MVG: defines the required SSN ("social security number") as the MVG's identification number of the patient.
    If no SSN is supplied, a rejection must be expected.
  • ORG: defines the optional SSN ("social security number") as the ORG's identification number of the patient.
customer_no the optional customer_no is the old proprietary KVG customer number.
Note that the customer_no should only be filled if no insured_id is defined. In fact the usage of the customer_no is deprecated since it is an outdated identification.
case_id case_id is the treatment/case identification number issued by by the insurance
It should be noted that the existence, form and specifications of case_id is dependent on the law:
  • KVG: there is currently no such case id known at the insurance site. Future contracts between provider and insurance might make such a case id necessary.
  • VVG: there is currently no such case id known at the insurance site. Future contracts between provider and insurance might make such a case id necessary.
  • UVG: defines the required accident number uniquely identifying the corresponding case at the insurance's site.
    If no accident number is supplied, a rejection must be expected.
  • IVG: defines the required case id having a well defined data pattern of ([0-9]{14}|[0-9]{10}|[0-9]{9}|[0-9]{6}).
    If no case id is supplied, a rejection must be expected.
  • MVG: defines the optional case id
  • ORG: there is currently no such case id known.
case_date case_date is the treatment/case date issued by by the insurance
It should be noted that the existence, form and specifications of case_date is dependent on the law:
  • KVG: there is currently no such case date known at the insurance site.
  • VVG: there is currently no such case id known at the insurance site.
  • UVG: defines the optional accident date identifying the occurrence of the accident.
  • IVG: there is currently no such case id known at the insurance site.
  • MVG: defines the optional case date
  • ORG: there is currently no such case id known.
attributes enumerations
Name | Extension | Base | Value | Annotations
type | NMTOKEN | KVG | the applicable law is "Krankenversicherungsgesetz" abbreviated {"KVG" | "LAMal" | "LAMal"} in the official national languages
type | NMTOKEN | VVG | the applicable law is "Versicherungsvertragsgesetz" abbreviated {"VVG" | "LCA" | "LCA"} in the official national languages
type | NMTOKEN | UVG | the applicable law is "Unfallversicherungsgesetz" abbreviated {"UVG" | "LAA" | "LAINF"} in the official national languages
type | NMTOKEN | IVG | the applicable law is "Invalidenversicherungsgesetz" abbreviated {"IVG" | "LAI" | "LAI"} in the official national languages
type | NMTOKEN | MVG | the applicable law is "Militäversicherungsgesetz" abbreviated {"MVG" | "LAM" | "LAM"} in the official national languages
type | NMTOKEN | ORG | the applicable law is "Obligationenrechtsgesetz" abbreviated {"ORG" | "CO" | "CO"} in the official national languages
source <complexType name="lawType">
<attribute name="type" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="KVG"/>
<enumeration value="VVG"/>
<enumeration value="UVG"/>
<enumeration value="IVG"/>
<enumeration value="MVG"/>
<enumeration value="ORG"/>
</restriction>
</simpleType>
</attribute>
<attribute name="insured_id" type="invoice:stringType1_35"/>
<attribute name="customer_no" type="invoice:stringType1_35"/>
<attribute name="case_id" type="invoice:stringType1_35"/>
<attribute name="case_date" type="dateTime"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType onlineAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:email invoice:uri
used by
elements personType/online companyType/online
source <complexType name="onlineAddressType">
<sequence>
<element name="email" maxOccurs="3">
<simpleType>
<restriction base="invoice:stringType1_80">
<pattern value=".+@.+"/>
</restriction>
</simpleType>
</element>
<element name="uri" minOccurs="0" maxOccurs="3">
<simpleType>
<restriction base="anyURI">
<minLength value="1"/>
<maxLength value="160"/>
</restriction>
</simpleType>
</element>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType patientAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:person
used by
elements garantType/patient soldantType/patient payantType/patient
attributes parameters
Name | Type | Use | Default | Fixed
gender | derived by: NMTOKEN | required
sex | derived by: NMTOKEN | required
birthdate | dateTime | required
ssn | invoice:ssnPartyType | required
mpi invoice:stringType1_35
attributes annotations
Name | Notes
gender gender defines the social gender encoded by a terminal set of tokens
  • male: the patient decides to have a gender of male
  • female: the patient decides to have a gender of female
  • diverse: the patient decides to have a gender of diverse
sex sex defines the medical sex which is pre-dominantly induced by the actual hormonal balance of the body encoded by a terminal set of tokens
  • male: the sex of the patient is pre-dominantly male
  • female: the sex of the patient is pre-dominantly female
birthdate | birthdate defines the birthdate of the patient
ssn the required ssn defines the social security number of the patient whereupon 4 distinguished styles are allowed:
  • the old 11 digit Swiss SSN ("AHV-Nummer") as defined by Federal Social Insurance Office
  • the new 13 digit Swiss SSN ("SV-Nummer") beginning with 756 as defined by Federal Social Insurance Office
  • the new 4-10 digit SSN of Liechtenstein ("AHV-Nummer") as defined by Liechtensteinische AHV-IV-FAK
  • the 13 digit IDNR number of Liechtenstein ("IDNR-Nummer") beginning with 438
If for any reasons the SSN of the patient is unknown, than the unknownSSN = 7569999999991 must be defined to satisfy the schema validity!

Note, that the SSN is stored in the electronic flavor (digits only) whereas on any printed form it must be in its formatted print flavor as requested by the federal authorities.
mpi | the optional mpi defines the forthcoming 'Master-Patient-Index' uniquely defining a patient in Switzerland/Liechtenstein by this index key.
attributes enumerations
Name | Extension | Base | Value | Annotations
gender | NMTOKEN | male | the patient decides to have a gender of male
gender | NMTOKEN | female | the patient decides to have a gender of female
gender | NMTOKEN | diverse | the patient decides to have a gender of diverse
sex | NMTOKEN | male | the sex of the patient is pre-dominantly male
sex | NMTOKEN | female | the sex of the patient is pre-dominantly female
source <complexType name="patientAddressType">
<sequence>
<element name="person" type="invoice:personType"/>
</sequence>
<attribute name="gender" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
<enumeration value="diverse"/>
</restriction>
</simpleType>
</attribute>
<attribute name="sex" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="male"/>
<enumeration value="female"/>
</restriction>
</simpleType>
</attribute>
<attribute name="birthdate" type="dateTime" use="required"/>
<attribute name="ssn" type="invoice:ssnPartyType" use="required"/>
<attribute name="mpi" type="invoice:stringType1_35"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType payantType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:biller invoice:debitor invoice:providers invoice:insurance invoice:patient invoice:insured invoice:guarantor invoice:referrer invoice:employer invoice:balance
used by
element bodyType/tiers_payant
attributes parameters
Name | Type | Use | Default | Fixed
allowModification | boolean | required
attributes annotations
Name | Notes
allowModification | allowModification gives or denies placet for the health care insurance to correct quantities of services. The service quantity can be changed in the range R0+ (positive real numbers including zero), which changes the amounts of individual services as well as the total invoice amount and the vat accounting.
source <complexType name="payantType">
<sequence>
<element name="biller" type="invoice:billerAddressType"/>
<element name="debitor" type="invoice:debitorAddressType"/>
<element name="providers" type="invoice:providersAddressType"/>
<element name="insurance" type="invoice:insuranceAddressType"/>
<element name="patient" type="invoice:patientAddressType"/>
<element name="insured" type="invoice:insuredAddressType" minOccurs="0"/>
<element name="guarantor" type="invoice:guarantorAddressType"/>
<element name="referrer" type="invoice:referrerAddressType" minOccurs="0"/>
<element name="employer" type="invoice:employerAddressType" minOccurs="0"/>
<element name="balance" type="invoice:balanceTPType"/>
</sequence>
<attribute name="allowModification" type="boolean" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType payloadType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:credit invoice:invoice invoice:reminder invoice:body xenc:EncryptedData
used by
element requestType/payload
attributes parameters
Name | Type | Use | Default | Fixed
request_type | derived by: NMTOKEN | invoice
request_subtype | derived by: NMTOKEN | normal
attributes annotations
Name Notes
request_type request_type defines the principle type of request encoded by a terminal set of tokens
  • invoice: the request is of type invoice
  • reminder: the request is of type reminder
request_subtype request_subtype specifies the XML infoset with respect to its modification from the standard data space. Such a modification can be seen as a request variation, subsuming a specific data set, where the set of discrete subtypes is encoded by a terminal set of tokens.
  • normal: normal defines the standard (normal) XML infoset describing an ordinary invoice/reminder
  • copy: copy qualifies the XML infoset as the exact copy of a previously defined XML infoset except for the copy flag.
  • refund: refund acts on a normal XML infoset -notably sent to and paid by a health care insurance- by setting
    • the quantity = 0 of all correctly invoiced services
    • the quantity = negated (multiplied by -1) of all invoiced services that should be refunded to the health care insurance
    • the topmost object reference is the one from the normal XML infoset

    Consequently, the invoice amount becomes negative and its value defines the size of the planned refund towards the insurance company.
    If the insurance company accepts the credit note, a response with a reimbursement element (defining the necessary payment parameters) is returned to the biller.

  • regress: regress acts on a normal invoice/reminder by setting the biller as a health care insurance. Thus defining an invoicing process between 2 health care insurances.
  • storno: storno acts on a prior defined normal XML infoset by negate all quantities in order to cancel the XML request defined by the topmost reference object as a whole.
    By definition the storno of an invoice/reminder is thus the same as the original XML infoset, but altered by
    • a negated quantity (multiplied by -1) of all original services
    • a negated amount_prepaid and amount_reminder (multiplied by -1)
    This mechanism automatically produces negative amounts and vats.

    If the storno acts on a already paid invoice/reminder, then the health care insurance sends a response with a reimbursement element (defining the necessary payment parameters) to the biller.

    It is considered an error to send a XML request with turned on storno attribute without having prior sent a "normal" request.

attributes enumerations
Name | Extension | Base | Value | Annotations
request_subtype | NMTOKEN | normal | normal defines the standard (normal) XML infoset describing an ordinary invoice/reminder (Default)
request_subtype | NMTOKEN | copy | copy qualifies the XML infoset as the exact copy of a previously defined XML infoset except for the copy flag.
request_subtype | NMTOKEN | refund | refund acts on a normal XML infoset, notably sent to and paid by a health care insurance
request_subtype | NMTOKEN | regress | regress acts on a normal invoice/reminder by setting the biller as a health care insurance. Thus defining an invoicing process between 2 health care insurances.
request_subtype | NMTOKEN | storno | storno acts on a prior defined normal XML infoset by negate all quantities in order to cancel the invoice/reminder as a whole.
request_type | NMTOKEN | invoice | the request is of type invoice
request_type | NMTOKEN | reminder | the request is of type reminder
source <complexType name="payloadType">
<sequence>
<element name="credit" type="invoice:creditType" minOccurs="0"/>
<element name="invoice" type="invoice:invoiceType"/>
<element name="reminder" type="invoice:reminderType" minOccurs="0"/>
<choice>
<element name="body" type="invoice:bodyType"/>
<element ref="xenc:EncryptedData"/>
</choice>
</sequence>
<attribute name="request_type" default="invoice">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="invoice"/>
<enumeration value="reminder"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_subtype" default="normal">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="normal"/>
<enumeration value="copy"/>
<enumeration value="refund"/>
<enumeration value="regress"/>
<enumeration value="storno"/>
</restriction>
</simpleType>
</attribute>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType personType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:familyname invoice:givenname invoice:subaddressing invoice:postal invoice:telecom invoice:online
used by
elements billerAddressType/person debitorAddressType/person providerGLNAddressType/person providerZSRAddressType/person insuranceAddressType/person patientAddressType/person insuredAddressType/person guarantorAddressType/person referrerAddressType/person employerAddressType/person esrAddressType/person
attributes parameters
Name Type Use Default Fixed
salutation invoice:stringType1_35
title invoice:stringType1_35
attributes annotations
Name | Notes
salutation | salutation is the optional salutation of the person
title | title is optional title of the person
source <complexType name="personType">
<sequence>
<element name="familyname" type="invoice:stringType1_35"/>
<element name="givenname" type="invoice:stringType1_35"/>
<element name="subaddressing" type="invoice:stringType1_35" minOccurs="0"/>
<element name="postal" type="invoice:postalAddressType"/>
<element name="telecom" type="invoice:telecomAddressType" minOccurs="0"/>
<element name="online" type="invoice:onlineAddressType" minOccurs="0"/>
</sequence>
<attribute name="salutation" type="invoice:stringType1_35"/>
<attribute name="title" type="invoice:stringType1_35"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType postalAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:pobox invoice:street invoice:zip invoice:city invoice:country
used by
elements personType/postal companyType/postal
source <complexType name="postalAddressType">
<sequence>
<element name="pobox" type="invoice:stringType1_35" minOccurs="0"/>
<element name="street" type="invoice:streetType" minOccurs="0"/>
<element name="zip" type="invoice:zipType"/>
<element name="city" type="invoice:stringType1_35"/>
<element name="country" type="invoice:countryType"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType processingType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:transport invoice:instructions
used by
element requestType/processing
attributes parameters
Name | Type | Use | Default | Fixed
print_copy_to_guarantor | boolean | false
send_copy_to_trustcenter invoice:glnPartyType
send_tgcopy_to_portal invoice:restCallType
define_gln_printcenter | invoice:glnPartyType | 2005555555003
define_gln_norecipient | invoice:glnPartyType | 2006666666008
attributes annotations
Name Notes
print_copy_to_guarantor print_copy_to_guarantor is a Boolean instruction for the first intermediate (the functionality is potentially cost-dependent) regarding a printed copy of the invoice to the guarantor's address, basically to fullfill the legal requirement of a "patient copy".

The attribute has a meaning only in a genuine normal invoice process of a Tiers Payant case. Therefore, the attribute must be discarded for all other Tiers systems and all other process types e.g. a reminder, storno, copy etc.

It should be noted that

  • this process is to be considered as 2nd process. Therefore, it is carried out with the best effort and without the possibility of error propagation to the sender. Under all circumstances, the processing of the 1st process (the delivery to transport@from) must not be affected by a potentially occurring error in the 2nd process!
  • all attachments of the XML infoset are ignored and not printed
send_copy_to_trustcenter send_copy_to_trustcenter instructs the 1st intermediate to send a copy of the XML infoset to the defined trust center.

It should be noted that

  • this process is to be considered as 2nd process. Therefore, it is carried out with the best effort and without the possibility of error propagation to the sender. Under all circumstances, the processing of the 1st process (the delivery to transport@from) must not be affected by a potentially occurring error in the 2nd process!
send_tgcopy_to_portal send_tgcopy_to_portal instructs the 1st intermediate to send a copy of the current TG XML infoset as well as the supplied parameters to the defined portal using a pseudo Restful Webservice syntax: e.g. https://portal.address.com/putCopy?biller=gln&insurance=gln&guid=guid.
Of course, the intermediate has to effectively transform the pseudo Restful service call into a POST Multiform/Form-Data call as defined below to transmit the XML infoset as well:

POST https://portal.address.com/putCopy HTTP/1.1
Accept: application/json
Content-Type: multipart/form-data;
boundary=A_UNIQUE_BOUNDARY_28947758029299
Content-Disposition: form-data; name="application/json"
{
"biller": "biller_gln",
"insurance": "insurance_gln",
"guid": "guid_value"
}
A_UNIQUE_BOUNDARY_28947758029299
Content-Disposition: form-data; name="name"; filename="tg_invoicerequest.xml"
Content-Type: application/xml
....here comes the xml infoset
A_UNIQUE_BOUNDARY_28947758029299

Please note as well, that if such a copy is performed than the counter restfulCall with getCopy (e.g. https://portal.address.com/getCopy?biller=gln&insurance=gln&guid=guid) is inserted into the QR code of the 'Rückerstattungsbeleg', such that the insurance company can scan the QR code to get all possibilities (one such possibility is the portal-fetch command) of fetching the original XML infoset.
define_gln_printcenter define_gln_printcenter defines the GLN for an abstract functionality, namely the print center, such that transport@to can be populated with this GLN and the first intermediate can be mandatorily instructed to print the XML infoset.

It should be noted that this print instruction must be performed by the 1st intermediate (the functionality is potentially cost-dependent), regardless of the chosen tiers system (i.e. TG, TS or TP).

define_gln_norecipient define_gln_norecipient defines the GLN for an abstract functionality, namely the non-delivery, such that transport@to is by definition defined as a non-existing party, which basically means that the first intermediate but at least the last intermediate must throw away the XML infoset without generating an error!

It should be noted that

  • it should be noted that at the 1st intermediate must be performed all 2nd processes, before the handover to the next intermediary hop or the final delivery to transport@to takes place.
that all 2nd processes must be . Therefore, it is carried out with the best effort and without the possibility of error propagation to the sender. Under all circumstances, the processing of the 1st process (the delivery to transport@from) must not be affected by a potentially occurring error in the 2nd process!
  • all attachments of the XML infoset are ignored and not printed
    • source <complexType name="processingType">
    <sequence>
    <element name="transport" type="invoice:transportType"/>
    <element name="instructions" type="invoice:instructionsType" minOccurs="0"/>
    </sequence>
    <attribute name="print_copy_to_guarantor" type="boolean" default="false"/>
    <attribute name="send_copy_to_trustcenter" type="invoice:glnPartyType"/>
    <attribute name="send_tgcopy_to_portal" type="invoice:restCallType"/>
    <attribute name="define_gln_printcenter" type="invoice:glnPartyType" fixed="2005555555003"/>
    <attribute name="define_gln_norecipient" type="invoice:glnPartyType" fixed="2006666666008"/>
    </complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType prologType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:package invoice:generator
used by
element bodyType/prolog
source <complexType name="prologType">
<sequence>
<element name="package" type="invoice:softwareType" minOccurs="0"/>
<element name="generator" type="invoice:softwareType"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType providerGLNAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:company invoice:person
used by
element providersAddressType/provider_gln
attributes parameters
Name | Type | Use | Default | Fixed
main_treating_provider invoice:stringType1_100
gln | invoice:glnPartyType | required
gln_location | invoice:glnPartyType | required
attributes annotations
Name | Notes
main_treating_provider | The optional main_treating_provider is the full name of the case leading provider should that name be different from the one given in the address section
gln The gln is the provider's required GLN as defined by RefData
If in agreement with the health insurance, the GLN given can be a Swiss SSN (social security number), provided that the treatment is carried out by the patient himself or a relative of the patient.
gln_location | The gln_location codes the provider's workplace by a required GLN as defined by RefData If there is no such specific workplace then input the gln as the location gln basically defining the default location.
source <complexType name="providerGLNAddressType">
<choice>
<element name="company" type="invoice:companyType"/>
<element name="person" type="invoice:personType"/>
</choice>
<attribute name="main_treating_provider" type="invoice:stringType1_100"/>
<attribute name="gln" type="invoice:glnPartyType" use="required"/>
<attribute name="gln_location" type="invoice:glnPartyType" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType providersAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:provider_gln invoice:provider_zsr
used by
elements garantType/providers soldantType/providers payantType/providers
source <complexType name="providersAddressType">
<sequence>
<element name="provider_gln" type="invoice:providerGLNAddressType"/>
<element name="provider_zsr" type="invoice:providerZSRAddressType" minOccurs="0"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType providerZSRAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:company invoice:person
used by
element providersAddressType/provider_zsr
attributes parameters
Name | Type | Use | Default | Fixed
zsr | invoice:zsrPartyType | required
attributes annotations
Name | Notes
zsr | zsr is the provider's required ZSR as defined by Santésuisse
source <complexType name="providerZSRAddressType">
<choice>
<element name="company" type="invoice:companyType"/>
<element name="person" type="invoice:personType"/>
</choice>
<attribute name="zsr" type="invoice:zsrPartyType" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType referrerAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:company invoice:person
used by
elements garantType/referrer soldantType/referrer payantType/referrer
attributes parameters
Name | Type | Use | Default | Fixed
gln | invoice:glnPartyType | required
zsr invoice:zsrPartyType
attributes annotations
Name | Notes
gln | gln is the referrer's GLN as defined by RefData
zsr | zsr is the referrer's ZSR as defined by Santésuisse
source <complexType name="referrerAddressType">
<choice>
<element name="company" type="invoice:companyType"/>
<element name="person" type="invoice:personType"/>
</choice>
<attribute name="gln" type="invoice:glnPartyType" use="required"/>
<attribute name="zsr" type="invoice:zsrPartyType"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType reminderType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element payloadType/reminder
attributes parameters
Name | Type | Use | Default | Fixed
request_timestamp | derived by: unsignedLong | required
request_date | dateTime | required
request_id | invoice:stringType1_35 | required
guid | invoice:guidType | required
reminder_level | derived by: NMTOKEN | 1
reminder_text invoice:stringType1_700
attributes annotations
Name | Notes
request_timestamp request_timestamp is a UNIX timestamp defined at the moment of the reminder's infoset generation
This is one of 3 identifiers that form the reminder object reference. request_timestamp will be generated once for a new reminder object reference and thereafter always referenced!
request_date request_date is the main software's date of the reminder request ("Mahndatum")
This is one of 3 identifiers that form the reminder object reference. request_date must be identical for the same reminder object reference!
request_id request_id is the main software's ID of the reminder request ("Mahnnummer")
This is one of 3 identifiers that form the reminder object reference. request_id must be identical for the same reminder object reference!
guid | guid is an internally used unique identifier of the current XML infoset defined as a 32-character string
reminder_level reminder_level is the level of the reminder starting with 1 and ending with 3 encoded by a terminal set of tokens
  • 1: the level of the reminder is 1 (default)
  • 2: the level of the reminder is 2
  • 3: the level of the reminder is 3
reminder_text | reminder_text is a the reminder text formed as normal ASCII text string
attributes enumerations
Name | Extension | Base | Value | Annotations
reminder_level | NMTOKEN | 1 | the level of the reminder is 1 (default)
reminder_level | NMTOKEN | 2 | the level of the reminder is 2
reminder_level | NMTOKEN | 3 | the level of the reminder is 3
source <complexType name="reminderType">
<attribute name="request_timestamp" use="required">
<simpleType>
<restriction base="unsignedLong">
<minInclusive value="1420066800"/>
<maxInclusive value="1924902000"/>
</restriction>
</simpleType>
</attribute>
<attribute name="request_date" type="dateTime" use="required"/>
<attribute name="request_id" type="invoice:stringType1_35" use="required"/>
<attribute name="guid" type="invoice:guidType" use="required"/>
<attribute name="reminder_level" default="1">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="1"/>
<enumeration value="2"/>
<enumeration value="3"/>
</restriction>
</simpleType>
</attribute>
<attribute name="reminder_text" type="invoice:stringType1_700"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType requestType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:processing invoice:payload ds:Signature
used by
element request
attributes parameters
Name | Type | Use | Default | Fixed
language | derived by: NMTOKEN | required
modus | derived by: NMTOKEN | production
validation_status | long
attributes annotations
Name Notes
language language defines the used data language (name of the services etc.) encoded by a terminal set of ISO language specifiers. All responses will be encoded in the same language.
  • de: the data language is german
  • fr: the data language is french
  • it: the data language is italian
modus modus defines the operating modus encoded by a terminal set of tokens
  • production: the modus production (default value) is for normal processing
  • test: the modus test is for software developers to test the processing
    By definition there must not be any money flow!
validation_status validation_status defines the validity status of XML infoset after the infoset is generated and validated by a DOM. 0 or absence of the attribute means OK.
It is possible to knowingly encode an XML infoset that is well formed but invalid regarding its content (wrong regarding business rules). validation_status then signals such an error condition to the recipient.
attributes enumerations
Name | Extension | Base | Value | Annotations
language | NMTOKEN | de | the data language is german
language | NMTOKEN | fr | the data language is french
language | NMTOKEN | it | the data language is italian
modus | NMTOKEN | production | the modus production (default value) is for normal processing
modus NMTOKEN test the modus test is for software developers to test the processing
By definition there must not be any money flow!
source <complexType name="requestType">
<sequence>
<element name="processing" type="invoice:processingType"/>
<element name="payload" type="invoice:payloadType"/>
<element ref="ds:Signature" minOccurs="0"/>
</sequence>
<attribute name="language" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="de"/>
<enumeration value="fr"/>
<enumeration value="it"/>
</restriction>
</simpleType>
</attribute>
<attribute name="modus" default="production">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="production"/>
<enumeration value="test"/>
</restriction>
</simpleType>
</attribute>
<attribute name="validation_status" type="long"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType serviceExType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element servicesType/service_ex
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
tariff_type | derived by: string | required
code | invoice:stringType1_30 | required
ref_code invoice:stringType1_30
name | invoice:stringType1_350 | required
session | derived by: int | 1
group_size | positiveInteger | 1
quantity | double | required
date_begin | dateTime | required
date_end | dateTime
provider_id | invoice:glnPartyType | required
responsible_id | invoice:glnPartyType | required
billing_role | derived by: NMTOKEN | both
medical_role | derived by: NMTOKEN | self_employed
body_location | derived by: NMTOKEN | none
treatment | derived by: NMTOKEN | ambulatory
unit_mt | double | required
unit_factor_mt | derived by: double | required
scale_factor_mt | double | 1.0
external_factor_mt | derived by: double | 1.0
amount_mt | double | 0.0
unit_tt | double | required
unit_factor_tt | derived by: double | required
scale_factor_tt | double | 1.0
external_factor_tt | derived by: double | 1.0
amount_tt | double | 0.0
amount | double | required
vat_rate | derived by: double | 0.0
section_code invoice:stringType1_6
remark invoice:stringType1_350
service_attributes | unsignedInt | 0
attributes annotations
Name | Notes
record_id record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
Note, that the sequence numbering is over all types of services!
tariff_type tariff_type is the official 3-character designator of the used tariff as given by Forum Datenaustausch
Currently, tariff type "001" for Tarmed is the only used tariff of that type.
code | code is the code of the service record as given by the used tariff catalog
ref_code ref_code is a back-reference code ("parent code") to a previously given service
Of course, ref_code is empty if the current service does not need such a back-reference
name | name is the official service name as given by the used tariff catalog
session session is the session number of the service. The session concept divide each day into a number of individual accomplished treatment units, starting each day with 1 and incrementing by 1 for each new treatment unit.

Some tariffs do not include a session concept, others like Tarmed heavily relay on this paradigm. For tariffs without a session concept simply input '1' as session number for all services.

group_size group_size defines the participating group size of a service whose quantity is calculated by the "Divisor Method". It should be noted that the group_size is declarative only with a default value equals to 1 implicitly meaning that it is NO service defined via the "Divisor Method" as the group size for such a service is always larger than 1.

Please note that in the "Divisor Method" the quantity is coded by definition as follows: quantity = effective_quantity / group_size.

quantity quantity is the used quantity of the current service
Note, that the quantity is defined as double, spanning negative, zero and positive fractional values!
  • negative quantities are used for service records in a storno (cf. attribute request/payload@storno)
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.25 for 02.0050 with a group of 4)
quantity must not be rounded but given in full precision.
date_begin | date_begin is the date when the service was (first) applied
date_end date_end is the date when the service was last applied.
Note that date_end is only necessary if a service was applied over a period of more than 1 day.
provider_id | provider_id is the provider's GTIN identification that physically applied the service
responsible_id | responsible_id is the responsible person's GTIN identification who has medical responsibility for the applied service
billing_role billing_role is the extended tariff defined billing role encoded by a terminal set of tokens.
  • mt: the billing role is mt (medical part only) - mt means that unit_tt=0 in most cases (there are exceptions defined in the tariff)!
  • tt: the billing role is tt (technical part only) - tt means that unit_mt=0 in most cases (there are exceptions defined in the tariff)!
  • both: the billing role is both (medical+technical part) - both means that both parts are billed. This is the default.
  • none: the billing role is none (neither medical nor technical part is billed) - none means that unit_mt=0 and unit_tt=0 in most cases!
medical_role medical_role is the extended tariff defined medical role encoded by a terminal set of tokens. Some rules in extended tariffs are based on the value of the medical_role and thus the medical_role needs to be known for a successful re-validation of these servies.
  • self_employed: the medical role is self_employed(default)
  • employee: the medical role is employee
body_location body_location is the extended tariff defined side location encoded by a terminal set of tokens.
  • none: the location is none (default) - no side specific location
  • left: the location is left - the service was applied on the left body side
  • right: the location is right - the service was applied on the right body side
treatment treatment is the treatment type under which the service was applied encoded by a terminal set of tokens.
  • ambulatory: the treatment type is ambulatory (default)
  • stationary: the treatment type is stationary
unit_mt unit_mt is the tax point of the medical part (TP(mt)) of the applied service
unit_mt is defined as double and must not be rounded but given in full precision.
unit_factor_mt unit_factor_mt is the tax point value of the medical part (TPV(mt)) of the applied service
unit_factor_mt is defined as double and must not be rounded but given in full precision.
scale_factor_mt scale_factor_mt is an internal scale factor of the medical part of the applied service
scale_factor_mt is defined as double and must not be rounded but given in full precision.
external_factor_mt external_factor_mt is a external scale factor (given by the main software) for the medical part of the applied service
external_factor_mt is used as a measure for giving discounts and can even be zero to supply a charge free service.
amount_mt amount_mt is the charged amount of the medical part of the applied service
Note, that amount_mt must fulfill the equation
«external_factor_mt * quantity * TP(mt) * TPV(mt) * scale_factor_mt»

calculated in full precision and the result rounded to 2 significant decimal places. This procedure is the reason for storing the multipliers in full precision.
unit_tt unit_tt is the tax point of the technical part (TP(tt)) of the applied service
unit_tt is defined as double and must not be rounded but given in full precision.
unit_factor_tt unit_factor_tt is the tax point value of the technical part (TPV(tt)) of the applied service
unit_factor_tt is defined as double and must not be rounded but given in full precision.
scale_factor_tt scale_factor_tt is an internal scale factor of the technical part of the applied service
scale_factor_tt is defined as double and must not be rounded but given in full precision.
external_factor_tt external_factor_tt is a external scale factor (given by the main software) for the technical part of the applied service
external_factor_tt is used as a measure for giving discounts and can even be zero to supply a charge free service.
amount_tt amount_tt is the charged amount of the technical part of the applied service
Note, that amount_tt must fulfill the equation
«external_factor_tt * quantity * TP(tt) * TPV(tt) * scale_factor_tt»

calculated in full precision and the result rounded to 2 significant decimal places. This procedure is the reason for storing the multipliers in full precision.
amount | amount is the charged amount of the applied service consisting of (amount_mt + amount_tt)
vat_rate | vat_rate is the applicable vat rate for the applied service given as a percentage factor
section_code | section_code is a section code (BfS section code) where the service was applied as defined by Swiss Federal Statistical Office - this code is only given for role=hospital!
remark | remark is an optional remark for the applied service
service_attributes service_attributes is a 32 bit integer where each bit defines a certain refinement/enhancement to the already supplied data.
The currently defined values are given in the purpose chapter ("Service attributes")
attributes enumerations
Name | Extension | Base | Value | Annotations
billing_role | NMTOKEN | mt | the billing role is mt (medical part only) - mt means that unit_tt=0 in most cases (there are exceptions defined in the tariff)!
billing_role | NMTOKEN | tt | the billing role is tt (technical part only) - tt means that unit_mt=0 in most cases (there are exceptions defined in the tariff)!
billing_role | NMTOKEN | both | the billing role is both (medical+technical part) - both means that both parts are billed. This is the default.
billing_role | NMTOKEN | none | the billing role is none (neither medical nor technical part is billed) - none means that unit_mt=0 and unit_tt=0 in most cases!
body_location | NMTOKEN | none | the location is none (default) - no side specific location
body_location | NMTOKEN | left | the location is left - the service was applied on the left body side
body_location | NMTOKEN | right | the location is right - the service was applied on the right body side
medical_role | NMTOKEN | self_employed | the medical role is self_employed(default)
medical_role | NMTOKEN | employee | the medical role is employee
treatment | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment | NMTOKEN | stationary | the treatment type is stationary
source <complexType name="serviceExType">
<attribute name="record_id" use="required">
<simpleType>
<restriction base="int">
<minInclusive value="1"/>
<maxInclusive value="999999999"/>
</restriction>
</simpleType>
</attribute>
<attribute name="tariff_type" use="required">
<simpleType>
<restriction base="string">
<pattern value="[0-9A-Z]{3}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="code" type="invoice:stringType1_30" use="required"/>
<attribute name="ref_code" type="invoice:stringType1_30"/>
<attribute name="name" type="invoice:stringType1_350" use="required"/>
<attribute name="session" default="1">
<simpleType>
<restriction base="int">
<minInclusive value="1"/>
<maxInclusive value="999999"/>
</restriction>
</simpleType>
</attribute>
<attribute name="group_size" type="positiveInteger" default="1"/>
<attribute name="quantity" type="double" use="required"/>
<attribute name="date_begin" type="dateTime" use="required"/>
<attribute name="date_end" type="dateTime"/>
<attribute name="provider_id" type="invoice:glnPartyType" use="required"/>
<attribute name="responsible_id" type="invoice:glnPartyType" use="required"/>
<attribute name="billing_role" default="both">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="mt"/>
<enumeration value="tt"/>
<enumeration value="both"/>
<enumeration value="none"/>
</restriction>
</simpleType>
</attribute>
<attribute name="medical_role" default="self_employed">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="self_employed"/>
<enumeration value="employee"/>
</restriction>
</simpleType>
</attribute>
<attribute name="body_location" default="none">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="none"/>
<enumeration value="left"/>
<enumeration value="right"/>
</restriction>
</simpleType>
</attribute>
<attribute name="treatment" default="ambulatory">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="ambulatory"/>
<enumeration value="stationary"/>
</restriction>
</simpleType>
</attribute>
<attribute name="unit_mt" type="double" use="required"/>
<attribute name="unit_factor_mt" use="required">
<simpleType>
<restriction base="double">
<minExclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="scale_factor_mt" type="double" default="1.0"/>
<attribute name="external_factor_mt" default="1.0">
<simpleType>
<restriction base="double">
<minInclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="amount_mt" type="double" default="0.0"/>
<attribute name="unit_tt" type="double" use="required"/>
<attribute name="unit_factor_tt" use="required">
<simpleType>
<restriction base="double">
<minExclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="scale_factor_tt" type="double" default="1.0"/>
<attribute name="external_factor_tt" default="1.0">
<simpleType>
<restriction base="double">
<minInclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="amount_tt" type="double" default="0.0"/>
<attribute name="amount" type="double" use="required"/>
<attribute name="vat_rate" default="0.0">
<simpleType>
<restriction base="double">
<minInclusive value="0"/>
<maxInclusive value="100"/>
</restriction>
</simpleType>
</attribute>
<attribute name="section_code" type="invoice:stringType1_6"/>
<attribute name="remark" type="invoice:stringType1_350"/>
<attribute name="service_attributes" type="unsignedInt" default="0"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType servicesType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:service_ex invoice:service
used by
element bodyType/services
source <complexType name="servicesType">
<choice maxOccurs="unbounded">
<element name="service_ex" type="invoice:serviceExType"/>
<element name="service" type="invoice:serviceType"/>
</choice>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType serviceType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:xtra_drg invoice:xtra_drug
used by
element servicesType/service
attributes parameters
Name | Type | Use | Default | Fixed
record_id | derived by: int | required
tariff_type | derived by: string | required
code | invoice:stringType1_30 | required
ref_code invoice:stringType1_30
name | invoice:stringType1_350 | required
session | derived by: int | 1
sl_indicationcode invoice:stringType1_30
group_size | positiveInteger | 1
quantity | double | required
date_begin | dateTime | required
date_end | dateTime
provider_id | invoice:glnPartyType | required
responsible_id | invoice:glnPartyType | required
unit | double | required
unit_factor | derived by: double | 1.0
external_factor | derived by: double | 1.0
amount | double | required
vat_rate | derived by: double | 0
section_code invoice:stringType1_6
remark invoice:stringType1_350
service_attributes | unsignedInt | 0
attributes annotations
Name | Notes
record_id record_id is a record sequence number (starting with 1 and incremented by 1 for each further record) uniquely identifying the record
Note, that the sequence numbering is over all types of services!
code | code is the code of the service record as given by the used tariff catalog
ref_code ref_code is a back-reference code ("parent code") to a previously given service
Of course, ref_code is empty if no back-reference concept is used for the current tariff catalog or if the current service does not need such a back-reference
name | name is the official service name as given by the used tariff catalog
session session is the session number of the service. The session concept divide each day into a number of individual accomplished treatment units, starting each day with 1 and incrementing by 1 for each new treatment unit.

Some tariffs do not include a session concept, others like Tarmed heavily relay on this paradigme. For tariffs without a session concept simply input 1 as session number for all services.

sl_indicationcode | the optional sl_indicationcode defines an indication code defined by the BAG in its SL List for the off-indication prescription/usage of a SL drug
group_size group_size defines the participating group size of a service whose quantity is calculated by the "Divisor Method". It should be noted that the group_size is declarative only with a default value equals to 1 implicitly meaning that it is NO service defined via the "Divisor Method" as the group size for such a service is always larger than 1.

Please note that in the "Divisor Method" the quantity is coded by definition as follows: quantity = effective_quantity / group_size.

quantity quantity is the used quantity of the current service
Note, that the quantity is defined as double, spanning negative, zero and positive fractional values!
  • negative quantities are used for service records in a storno (cf. attribute request/payload@storno)
  • a zero quantity is used for "non-billable" and "pro memoria" services
  • positive quantities are used for "normal" services
  • fractional values are used whenever a part of the "full" service is used (e.g. quantity=0.5 for 500ml of a 1000ml infusion solution)
quantity must not be rounded but given in full precision.
date_begin | date_begin is the date when the service was (first) applied
date_end date_end is the date when the service was last applied.
Note that date_end is only neccessary if the same service was applied each day over a period of more than 1 day.
provider_id | provider_id is the provider's GTIN identification that physically applied the service
responsible_id | responsible_id is the responsible person's GTIN identification who has medical responsibility for the applied service
unit unit is the tax point (TP) or the price of the applied service
unit is defined as double and must not be rounded but given in full precision.
unit_factor unit_factor is the tax point value (TPV) of the applied service
unit_factor is defined as double and must not be rounded but given in full precision.
external_factor external_factor is a external scale factor (given by the main software) for the applied service
external_factor is used as a measure for giving discounts and can even be zero to supply a charge free service.

In the DRG case the external factor is used for defining the splitting situation between insurance and canton.

amount amount is the charged amount of the applied service
Note, that amount must fulfill the equation:
«external_factor * quantity * TP * TPV »

for non-DRG services, whereas for DRG services the following equation holds true:
«cost_fraction * external_factor * quantity * TP * TPV »

Both equations are calculated in full precision and the result rounded to 2 significant decimal places. This procedure is the reason for storing the multipliers in full precision.
vat_rate | vat_rate is the applicable vat rate for the applied service given as a percentage factor
section_code | section_code is a section code (BfS section code) where the service was applied as defined by Swiss Federal Statistical Office - this code is only given for role=hospital!
remark | remark is an optional remark for the applied service
service_attributes service_attributes is a 32 bit integer where each bit defines a certain refinement/enhancement to the already supplied data.
The currently defined values are given in the purpose chapter ("Service attributes")
source <complexType name="serviceType">
<choice minOccurs="0">
<element name="xtra_drg" type="invoice:xtraDRGType"/>
<element name="xtra_drug" type="invoice:xtraDrugType"/>
</choice>
<attribute name="record_id" use="required">
<simpleType>
<restriction base="int">
<minInclusive value="1"/>
<maxInclusive value="999999999"/>
</restriction>
</simpleType>
</attribute>
<attribute name="tariff_type" use="required">
<simpleType>
<restriction base="string">
<pattern value="[0-9A-Z]{3}"/>
</restriction>
</simpleType>
</attribute>
<attribute name="code" type="invoice:stringType1_30" use="required"/>
<attribute name="ref_code" type="invoice:stringType1_30"/>
<attribute name="name" type="invoice:stringType1_350" use="required"/>
<attribute name="session" default="1">
<simpleType>
<restriction base="int">
<minInclusive value="1"/>
<maxInclusive value="999999"/>
</restriction>
</simpleType>
</attribute>
<attribute name="sl_indicationcode" type="invoice:stringType1_30"/>
<attribute name="group_size" type="positiveInteger" default="1"/>
<attribute name="quantity" type="double" use="required"/>
<attribute name="date_begin" type="dateTime" use="required"/>
<attribute name="date_end" type="dateTime"/>
<attribute name="provider_id" type="invoice:glnPartyType" use="required"/>
<attribute name="responsible_id" type="invoice:glnPartyType" use="required"/>
<attribute name="unit" type="double" use="required"/>
<attribute name="unit_factor" default="1.0">
<simpleType>
<restriction base="double">
<minExclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="external_factor" default="1.0">
<simpleType>
<restriction base="double">
<minInclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
<attribute name="amount" type="double" use="required"/>
<attribute name="vat_rate" default="0">
<simpleType>
<restriction base="double">
<minInclusive value="0"/>
<maxInclusive value="100"/>
</restriction>
</simpleType>
</attribute>
<attribute name="section_code" type="invoice:stringType1_6"/>
<attribute name="remark" type="invoice:stringType1_350"/>
<attribute name="service_attributes" type="unsignedInt" default="0"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType softwareType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:depends_on
used by
elements prologType/generator prologType/package
attributes parameters
Name | Type | Use | Default | Fixed
name | invoice:stringType1_50 | required
copyright invoice:stringType1_50
description invoice:stringType1_50
version | unsignedInt
id | unsignedInt | 0
attributes annotations
Name | Notes
name | name defines the name of the software/module
copyright | copyright defines the copyright notice of the software/module
description | description supplies a short description of the software/module
version version defines the version of the software/module.
Since this is an integer coding use 100*main version + minor version as the version
id | id defines an unique id for the software/module (should such an id exist)
source <complexType name="softwareType">
<sequence>
<element name="depends_on" type="invoice:dependsOnType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="name" type="invoice:stringType1_50" use="required"/>
<attribute name="copyright" type="invoice:stringType1_50"/>
<attribute name="description" type="invoice:stringType1_50"/>
<attribute name="version" type="unsignedInt"/>
<attribute name="id" type="unsignedInt" default="0"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType soldantType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:biller invoice:debitor invoice:providers invoice:insurance invoice:patient invoice:guarantor invoice:referrer invoice:employer invoice:balance
used by
element bodyType/tiers_soldant
attributes parameters
Name | Type | Use | Default | Fixed
allowTS | boolean | required
attributes annotations
Name Notes
allowTS allowTS confirms that the patient allows the usage of Tiers Soldant (TS). Furthermore, it implies the existence of a cession document signed by the patient and included as PDF attachment.
Please note, that if allowTS=false then the request should not be processed at the insurance's site but rejected due to the missing approval.
source <complexType name="soldantType">
<sequence>
<element name="biller" type="invoice:billerAddressType"/>
<element name="debitor" type="invoice:debitorAddressType"/>
<element name="providers" type="invoice:providersAddressType"/>
<element name="insurance" type="invoice:insuranceAddressType"/>
<element name="patient" type="invoice:patientAddressType"/>
<element name="guarantor" type="invoice:guarantorAddressType"/>
<element name="referrer" type="invoice:referrerAddressType" minOccurs="0"/>
<element name="employer" type="invoice:employerAddressType" minOccurs="0"/>
<element name="balance" type="invoice:balanceTPType"/>
</sequence>
<attribute name="allowTS" type="boolean" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType streetType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | extension of invoice:stringType1_35
properties
base invoice:stringType1_35
used by
element postalAddressType/street
facets
minLength | 1
maxLength | 35
attributes parameters
Name Type Use Default Fixed
house_no invoice:stringType1_9
attributes annotations
Name | Notes
house_no | house_no is the optional house number included in the street definition. Please note that the house number is an extracted copy from the full street definition.
Extensions
Annotation | Base
Definition for the street container (a subcontainer of an address definition) supplying the full street including any house number | invoice:stringType1_35
source <complexType name="streetType">
<simpleContent>
<extension base="invoice:stringType1_35">
<attribute name="house_no" type="invoice:stringType1_9"/>
</extension>
</simpleContent>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType telecomAddressType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:phone
used by
elements personType/telecom companyType/telecom
source <complexType name="telecomAddressType">
<sequence>
<element name="phone" type="invoice:stringType1_25" maxOccurs="3"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType transportType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:via
used by
element processingType/transport
attributes parameters
Name | Type | Use | Default | Fixed
from | invoice:glnPartyType | required
to | invoice:glnPartyType | required
attributes annotations
Name Notes
from from is the GLN party that initially sent the XML infoset to the first defined intermediate
Note, that the private certificate of this GLN party is used for the optional signature as outlined in the subchapter Purpose/Signature.
to to is the GLN party that eventually receives the XML infoset from the last defined intermediate.
Note, that the public certificate of this GLN party is used for the optional encryption as outlined in the subchapter Purpose/Encryption.
source <complexType name="transportType">
<sequence>
<element name="via" minOccurs="0" maxOccurs="unbounded">
<complexType>
<attribute name="via" type="invoice:glnPartyType" use="required"/>
<attribute name="sequence_id" type="unsignedShort" use="required"/>
</complexType>
</element>
</sequence>
<attribute name="from" type="invoice:glnPartyType" use="required"/>
<attribute name="to" type="invoice:glnPartyType" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType treatmentType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:diagnosis invoice:xtra_hospital
used by
element bodyType/treatment
attributes parameters
Name | Type | Use | Default | Fixed
date_begin | dateTime | required
date_end | dateTime | required
canton | derived by: NMTOKEN | required
treatment | derived by: NMTOKEN | ambulatory
reason | derived by: NMTOKEN | required
gestation_week13 | dateTime
birthdate_baby | dateTime
apid invoice:stringType1_35
acid invoice:stringType1_35
attributes annotations
Name | Notes
date_begin date_begin is the start of the treatment
Note, that the date of every service must be greater or equal date_begin otherwise it is a content error
date_end date_end is the end of the treatment
Note, that the date of every service must be less or equal date_end otherwise it is a content error
canton canton is Swiss canton or a country close to the border in which the treatment took place encoded by a terminal set of tokens.
Please note that the countries except for Liechtenstein are code by a 1-character abbreviation due to name collisions with the canton abbreviations. Liechtenstein is coded by "LI" as in the prior standards.
  • AG: the canton is AG - Aargau
  • AI: the canton is AI - Appenzell Innerrhoden
  • AR: the canton is AR - Appenzell Ausserrhoden
  • BE: the canton is BE - Bern
  • BL: the canton is BL - Baselland
  • BS: the canton is BS - Basel
  • FR: the canton is FR - Fribourg
  • GE: the canton is GE - Geneva
  • GL: the canton is GL - Glarus
  • GR: the canton is GR - Graubünden
  • JU: the canton is JU - Jura
  • LU: the canton is LU - Lucerne
  • NE: the canton is NE - Neuchâtel
  • NW: the canton is NW - Nidwalden
  • OW: the canton is OW - Obwalden
  • SG: the canton is SG - St. Gallen
  • SH: the canton is SH - Schaffhausen
  • SO: the canton is SO - Solothurn
  • SZ: the canton is SZ - Schwyz
  • TI: the canton is TI - Ticino
  • TG: the canton is TG - Thurgau
  • UR: the canton is UR - Uri
  • VD: the canton is VD - Vaud
  • VS: the canton is VS - Valais
  • ZG: the canton is ZG - Zug
  • ZH: the canton is ZH - Zürich
  • LI: the country is LI - Liechtenstein
  • A: the country is A - Austria
  • D: the country is D - Germany
  • F: the country is F - France
  • I: the country is I - Italy
treatment treatment is the principle type of treatment encoded by a terminal set of tokens.
Please note, that if place=hospital there is additional data to supply in the xtra_hospital container.
  • ambulatory: the treatment type is ambulatory (default)
  • stationary: the treatment type is stationary
reason reason is the primary reason the treatment took place encoded by a terminal set of tokens
  • disease: the reason of treatment is a disease
  • accident: the reason of treatment is an accident
  • maternity: the reason of treatment is a maternity
  • prevention: the reason of treatment is prevention
  • birthdefect: the reason of treatment a birthdefect
  • unknown: the reason of treatment is unknown (or something not mentioned above)
gestation_week13 gestation_week13 is any day of the 13th gestation week as requested by Article 105 of the Swiss Federal Act on Health Insurance (KVV).
This date is set once only in the first invoice with treatment reason «maternity» and law type «KVG»
birthdate_baby the birthdate_baby is the birth date of the newborn and is supplied as soon as known. Please note that treatment@reason=maternity is required as well to signal an ongoing maternity case up until 8 weeks after the birth of the newborn.
This birthdate_baby is used by the insurance to verify the legality of specific services during the post pregnancy period.
apid | apid is an optional administrative patient identification of the main software, defined exclusively for the exchange with the insurers.
acid acid is an optional administrative case identification of the main software, defined exclusively for the exchange with the insurers.

Please note, that the acid cannot serve as a unique identification of the invoice/reminder as opposed to the unique object reference!

attributes enumerations
Name | Extension | Base | Value | Annotations
canton | NMTOKEN | AG | the canton is AG - Aargau
canton | NMTOKEN | AI | the canton is AI - Appenzell Innerrhoden
canton | NMTOKEN | AR | the canton is AR - Appenzell Ausserrhoden
canton | NMTOKEN | BE | the canton is BE - Bern
canton | NMTOKEN | BL | the canton is BL - Baselland
canton | NMTOKEN | BS | the canton is BS - Basel
canton | NMTOKEN | FR | the canton is FR - Fribourg
canton | NMTOKEN | GE | the canton is GE - Geneva
canton | NMTOKEN | GL | the canton is GL - Glarus
canton | NMTOKEN | GR | the canton is GR - Graubünden
canton | NMTOKEN | JU | the canton is JU - Jura
canton | NMTOKEN | LU | the canton is LU - Lucerne
canton | NMTOKEN | NE | the canton is NE - Neuchâtel
canton | NMTOKEN | NW | the canton is NW - Nidwalden
canton | NMTOKEN | OW | the canton is OW - Obwalden
canton | NMTOKEN | SG | the canton is SG - St. Gallen
canton | NMTOKEN | SH | the canton is SH - Schaffhausen
canton | NMTOKEN | SO | the canton is SO - Solothurn
canton | NMTOKEN | SZ | the canton is SZ - Schwyz
canton | NMTOKEN | TI | the canton is TI - Ticino
canton | NMTOKEN | TG | the canton is TG - Thurgau
canton | NMTOKEN | UR | the canton is UR - Uri
canton | NMTOKEN | VD | the canton is VD - Vaud
canton | NMTOKEN | VS | the canton is VS - Valais
canton | NMTOKEN | ZG | the canton is ZG - Zug
canton | NMTOKEN | ZH | the canton is ZH - Zürich
canton | NMTOKEN | LI | the country is LI - Liechtenstein
canton | NMTOKEN | A | the country is A - Austria
canton | NMTOKEN | D | the country is D - Germany
canton | NMTOKEN | F | the country is F - France
canton | NMTOKEN | I | the country is I - Italy
reason | NMTOKEN | disease | the reason of treatment is a disease
reason | NMTOKEN | accident | the reason of treatment is an accident
reason | NMTOKEN | maternity | the reason of treatment is a maternity
reason | NMTOKEN | prevention | the reason of treatment is prevention
reason | NMTOKEN | birthdefect | the reason of treatment a birthdefect
reason | NMTOKEN | unknown | the reason of treatment is unknown (or something not mentioned above)
treatment | NMTOKEN | ambulatory | the treatment type is ambulatory (default)
treatment | NMTOKEN | stationary | the treatment type is stationary
source <complexType name="treatmentType">
<sequence>
<element name="diagnosis" type="invoice:diagnosisType" minOccurs="0" maxOccurs="unbounded"/>
<element name="xtra_hospital" type="invoice:xtraHospitalType" minOccurs="0"/>
</sequence>
<attribute name="date_begin" type="dateTime" use="required"/>
<attribute name="date_end" type="dateTime" use="required"/>
<attribute name="canton" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="AG"/>
<enumeration value="AI"/>
<enumeration value="AR"/>
<enumeration value="BE"/>
<enumeration value="BL"/>
<enumeration value="BS"/>
<enumeration value="FR"/>
<enumeration value="GE"/>
<enumeration value="GL"/>
<enumeration value="GR"/>
<enumeration value="JU"/>
<enumeration value="LU"/>
<enumeration value="NE"/>
<enumeration value="NW"/>
<enumeration value="OW"/>
<enumeration value="SG"/>
<enumeration value="SH"/>
<enumeration value="SO"/>
<enumeration value="SZ"/>
<enumeration value="TI"/>
<enumeration value="TG"/>
<enumeration value="UR"/>
<enumeration value="VD"/>
<enumeration value="VS"/>
<enumeration value="ZG"/>
<enumeration value="ZH"/>
<enumeration value="LI"/>
<enumeration value="A"/>
<enumeration value="D"/>
<enumeration value="F"/>
<enumeration value="I"/>
</restriction>
</simpleType>
</attribute>
<attribute name="treatment" default="ambulatory">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="ambulatory"/>
<enumeration value="stationary"/>
</restriction>
</simpleType>
</attribute>
<attribute name="reason" use="required">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="disease"/>
<enumeration value="accident"/>
<enumeration value="maternity"/>
<enumeration value="prevention"/>
<enumeration value="birthdefect"/>
<enumeration value="unknown"/>
</restriction>
</simpleType>
</attribute>
<attribute name="gestation_week13" type="dateTime"/>
<attribute name="birthdate_baby" type="dateTime"/>
<attribute name="apid" type="invoice:stringType1_35"/>
<attribute name="acid" type="invoice:stringType1_35"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType vatRateType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element vatType/vat_rate
attributes parameters
Name | Type | Use | Default | Fixed
vat_rate | derived by: double | required
amount | double | required
vat | double | required
attributes annotations
Name Notes
vat_rate vat_rate is the applicable vat rate given as a percentage factor
Note, that the vat rate 0% is a valid vat rate as well.
amount amount is the sum over 2-digit precision service amounts for which the given vat rate is applicable.
Note, that all amounts in this scheme are amounts that include the vat!
vat vat is the calculated vat portion of the given amount using the vat rate as
«(amount * vat_rate) / (100 + vat_rate)»

where the used amount is in 2-digit precision and the result is rounded to 2 significant decimal places.
source <complexType name="vatRateType">
<attribute name="vat_rate" use="required">
<simpleType>
<restriction base="double">
<minInclusive value="0"/>
<maxInclusive value="100"/>
</restriction>
</simpleType>
</attribute>
<attribute name="amount" type="double" use="required"/>
<attribute name="vat" type="double" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType vatType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:vat_rate
used by
elements balanceTGType/vat balanceTPType/vat
attributes parameters
Name | Type | Use | Default | Fixed
vat_number invoice:stringType1_15
vat | double | required
attributes annotations
Name | Notes
vat_number vat_number is the individual vat number of the biller as given by the "Swiss Federal Tax Administration". Both forms the old 6-digit number as well as the new UID dependent number is allowed. However, the electronic layout of the number must be supplied as suggested by the federal administration. In the electronic layout all punctuation characters ('-' and '.') as well as the language dependent attribute in the new form ('MWST','IVA', 'TVA') are striped.
Consequently, the vat number must be expanded appropriately prior to be printed, e.g.
  • Old vat number: electronic layout 799000 is printed as 799.000
  • New vat number: electronic: CHE123456789 is printed as CHE-123.456.789 MWST (for german language!)

Of course, if the biller has not been assigned such a vat number leave the field empty.
vat | vat is the overall vat portion for the invoice/reminder accumulated over 2-digit precision individual vats.
source <complexType name="vatType">
<sequence>
<element name="vat_rate" type="invoice:vatRateType" maxOccurs="unbounded"/>
</sequence>
<attribute name="vat_number" type="invoice:stringType1_15"/>
<attribute name="vat" type="double" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:AgreementMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
used by
element xenc:AgreementMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="AgreementMethodType" mixed="true">
<sequence>
<element name="KA-Nonce" type="base64Binary" minOccurs="0"/>
<!-- <element ref="ds:DigestMethod" minOccurs="0"/> -->
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
<element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
<element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:AgreementMethodType/KA-Nonce

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | base64Binary
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="KA-Nonce" type="base64Binary" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:AgreementMethodType/OriginatorKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="OriginatorKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:AgreementMethodType/RecipientKeyInfo

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | ds:KeyInfoType
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | complex
mixed | true
children | ds:KeyName ds:KeyValue ds:RetrievalMethod ds:X509Data ds:PGPData ds:SPKIData ds:MgmtData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="RecipientKeyInfo" type="ds:KeyInfoType" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:CipherDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:CipherValue xenc:CipherReference
used by
element xenc:CipherData
source <complexType name="CipherDataType">
<choice>
<element name="CipherValue" type="base64Binary"/>
<element ref="xenc:CipherReference"/>
</choice>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:CipherReferenceType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:Transforms
used by
element xenc:CipherReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="CipherReferenceType">
<choice>
<element name="Transforms" type="xenc:TransformsType" minOccurs="0"/>
</choice>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:EncryptedDataType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
element xenc:EncryptedData
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedDataType">
<complexContent>
<extension base="xenc:EncryptedType"/>
</complexContent>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:EncryptedKeyType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | extension of xenc:EncryptedType
properties
base xenc:EncryptedType
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
used by
element xenc:EncryptedKey
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source <complexType name="EncryptedKeyType">
<complexContent>
<extension base="xenc:EncryptedType">
<sequence>
<element ref="xenc:ReferenceList" minOccurs="0"/>
<element name="CarriedKeyName" type="string" minOccurs="0"/>
</sequence>
<attribute name="Recipient" type="string" use="optional"/>
</extension>
</complexContent>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:ReferenceList

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
content complex
children | xenc:DataReference xenc:KeyReference
used by
complexType xenc:EncryptedKeyType
source <element name="ReferenceList">
<complexType>
<choice maxOccurs="unbounded">
<element name="DataReference" type="xenc:ReferenceType"/>
<element name="KeyReference" type="xenc:ReferenceType"/>
</choice>
</complexType>
</element>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:EncryptedKeyType/CarriedKeyName

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | string
properties
isRef | 0
minOcc | 0
maxOcc | 1
content | simple
source | <element name="CarriedKeyName" type="string" minOccurs="0"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:EncryptedType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
abstract true
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties
used by
complexTypes xenc:EncryptedDataType xenc:EncryptedKeyType
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
source <complexType name="EncryptedType" abstract="true">
<sequence>
<element name="EncryptionMethod" type="xenc:EncryptionMethodType" minOccurs="0"/>
<element ref="ds:KeyInfo" minOccurs="0"/>
<element ref="xenc:CipherData"/>
<element ref="xenc:EncryptionProperties" minOccurs="0"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
<attribute name="Type" type="anyURI" use="optional"/>
<attribute name="MimeType" type="string" use="optional"/>
<attribute name="Encoding" type="anyURI" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:EncryptionMethodType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
properties
mixed true
children | xenc:KeySize xenc:OAEPparams
used by
element xenc:EncryptedType/EncryptionMethod
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source <complexType name="EncryptionMethodType" mixed="true">
<sequence>
<element name="KeySize" type="xenc:KeySizeType" minOccurs="0"/>
<element name="OAEPparams" type="base64Binary" minOccurs="0"/>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="Algorithm" type="anyURI" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:EncryptionPropertiesType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | xenc:EncryptionProperty
used by
element xenc:EncryptionProperties
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source <complexType name="EncryptionPropertiesType">
<sequence>
<element ref="xenc:EncryptionProperty" maxOccurs="unbounded"/>
</sequence>
<attribute name="Id" type="ID" use="optional"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:EncryptionPropertyType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
properties
mixed true
used by
element xenc:EncryptionProperty
attributes parameters
Name | Type | Use | Default | Fixed
Target | anyURI | optional
Id | ID | optional
source <complexType name="EncryptionPropertyType" mixed="true">
<choice maxOccurs="unbounded">
<any namespace="##other" processContents="lax"/>
</choice>
<attribute name="Target" type="anyURI" use="optional"/>
<attribute name="Id" type="ID" use="optional"/>
<anyAttribute namespace="http://www.w3.org/XML/1998/namespace"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:ReferenceType

diagram
namespace http://www.w3.org/2001/04/xmlenc#
used by
elements xenc:ReferenceList/DataReference xenc:ReferenceList/KeyReference
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source <complexType name="ReferenceType">
<sequence>
<any namespace="##other" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="URI" type="anyURI" use="required"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xenc:TransformsType

diagram
namespace | http://www.w3.org/2001/04/xmlenc#
children | ds:Transform
used by
element xenc:CipherReferenceType/Transforms
source <complexType name="TransformsType">
<sequence>
<element ref="ds:Transform" maxOccurs="unbounded"/>
</sequence>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xtraAmbulatoryType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element xtraHospitalType/ambulatory
attributes parameters
Name | Type | Use | Default | Fixed
hospitalization_type | derived by: NMTOKEN
hospitalization_mode | derived by: NMTOKEN
class | derived by: NMTOKEN
section_major invoice:stringType1_6
attributes annotations
Name | Notes
hospitalization_type hospitalization_type is the type of hospitalization encoded by a terminal set of tokens
  • regular: the type of hospitalization is regular ("a normal and planned hospitalization")
  • emergency: the type of hospitalization is emergency ("hospitalization due to an emergency")
hospitalization_mode hospitalization_mode is the mode of hospitalization encoded by a terminal set of tokens
  • cantonal: the mode of hospitalization is cantonal - patient's domicile is in the treatment canton)
  • noncantonal_indicated: the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but treatment is indicated
  • noncantonal_nonindicated: the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and treatment is not indicated
class hospitalization class is the class of insurance that covers the patient's stay encoded by a terminal set of tokens
  • private: the class of insurance is private (1st class insurance coverage)
  • semi_private: the class of insurance is semi_private (2nd class insurance coverage)
  • general: the class of insurance is general (3rd class insurance coverage)
  • hospital_comfort: the class of insurance is hospital_comfort
  • md_free_choice: the class of insurance is md_free_choice ("Freie Arztwahl")
section_major | section_major is the main section code (BfS section code) of the treatment as defined by Swiss Federal Statistical Office
attributes enumerations
Name | Extension | Base | Value | Annotations
class | NMTOKEN | private | the class of insurance is private (1st class insurance coverage)
class | NMTOKEN | semi_private | the class of insurance is semi_private (2nd class insurance coverage)
class | NMTOKEN | general | the class of insurance is general (3rd class insurance coverage)
class | NMTOKEN | hospital_comfort | the class of insurance is hospital_comfort
class | NMTOKEN | md_free_choice | the class of insurance is md_free_choice ("Freie Arztwahl")
hospitalization_mode | NMTOKEN | cantonal | the mode of hospitalization is cantonal - patient's domicile is in the treatment canton)
hospitalization_mode | NMTOKEN | noncantonal_indicated | the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but treatment is indicated
hospitalization_mode | NMTOKEN | noncantonal_nonindicated | the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and treatment is not indicated
hospitalization_type | NMTOKEN | regular | the type of hospitalization is regular ("a normal and planned hospitalization")
hospitalization_type | NMTOKEN | emergency | the type of hospitalization is emergency ("hospitalization due to an emergency")
source <complexType name="xtraAmbulatoryType">
<attribute name="hospitalization_type">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="regular"/>
<enumeration value="emergency"/>
</restriction>
</simpleType>
</attribute>
<attribute name="hospitalization_mode">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="cantonal"/>
<enumeration value="noncantonal_indicated"/>
<enumeration value="noncantonal_nonindicated"/>
</restriction>
</simpleType>
</attribute>
<attribute name="class">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="private"/>
<enumeration value="semi_private"/>
<enumeration value="general"/>
<enumeration value="hospital_comfort"/>
<enumeration value="md_free_choice"/>
</restriction>
</simpleType>
</attribute>
<attribute name="section_major" type="invoice:stringType1_6"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xtraDRGType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element serviceType/xtra_drg
attributes parameters
Name | Type | Use | Default | Fixed
cost_fraction | derived by: double | 1.0
attributes annotations
Name Notes
cost_fraction cost_fraction defines the splitting between 2 insurances, whereas the attribute external_factor defines the splitting between the insurance and the canton.
A simple splitting situation between insurance and canton is defined solely by the external_factor. The cost_fraction is than set to 1 by definition.
source <complexType name="xtraDRGType">
<attribute name="cost_fraction" default="1.0">
<simpleType>
<restriction base="double">
<minInclusive value="0.0"/>
</restriction>
</simpleType>
</attribute>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xtraDrugType

diagram
namespace http://www.forum-datenaustausch.ch/invoice
used by
element serviceType/xtra_drug
attributes parameters
Name | Type | Use | Default | Fixed
regulation_attributes | unsignedInt | 0
attributes annotations
Name Notes
regulation_attributes regulation_attributes is a 32 bit integer where each bit defines one specific regulation code as contracted between pharmacists and insurances

The currently defined values are given in the purpose chapter ("Regulation attributes")

source <complexType name="xtraDrugType">
<attribute name="regulation_attributes" type="unsignedInt" default="0"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xtraHospitalType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:ambulatory invoice:stationary
used by
element treatmentType/xtra_hospital
source <complexType name="xtraHospitalType">
<choice>
<element name="ambulatory" type="invoice:xtraAmbulatoryType"/>
<element name="stationary" type="invoice:xtraStationaryType"/>
</choice>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType xtraStationaryType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
children | invoice:admission_type invoice:discharge_type invoice:provider_type invoice:bfs_residence_before_admission invoice:bfs_admission_type invoice:bfs_decision_for_discharge invoice:bfs_residence_after_discharge invoice:case_detail
used by
element xtraHospitalType/stationary
attributes parameters
Name | Type | Use | Default | Fixed
hospitalization_date | dateTime | required
treatment_days | duration | required
hospitalization_type | derived by: NMTOKEN | regular
hospitalization_mode | derived by: NMTOKEN | cantonal
class | derived by: NMTOKEN | general
section_major invoice:stringType1_6
has_expense_loading | boolean | true
attributes annotations
Name | Notes
hospitalization_date hospitalization_date is the date and time of the hospitalization.
Note, that this date must be less or equal the begin date of the treatment period
treatment_days treatment_days is the number of treatment days within the given treatment period.
The calculation of these treatment days is dependent on whether SwissDRG is used nor not!
The treatment days are calculated as
  • None-SwissDRG: «(treatment@date_end - treatment@date_begin + 1 - vacation_days)»
  • SwissDRG: «max(1,(treatment@date_end - treatment@date_begin - vacation_days))»
where vacation_days is the number of vacation days (the leave days when the patient was not in the hospital for treatment).

Note, that treatment_days is identical to the "length of stay" notion of a DRG service position (either APDRG or SwissDRG)

hospitalization_type hospitalization_type is the type of hospitalization encoded by a terminal set of tokens
  • regular: the type of hospitalization is regular ("a normal and planned hospitalization")
  • emergency: the type of hospitalization is emergency ("hospitalization due to an emergency")
hospitalization_mode hospitalization_mode is the mode of hospitalization encoded by a terminal set of tokens
  • cantonal: the mode of hospitalization is cantonal - patient's domicile is in the treatment canton)
  • noncantonal_indicated: the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but treatment is indicated
  • noncantonal_nonindicated: the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and treatment is not indicated
class hospitalization class is the class of insurance that covers the patient's stay encoded by a terminal set of tokens
  • private: the class of insurance is private (1st class insurance coverage)
  • semi_private: the class of insurance is semi_private (2nd class insurance coverage)
  • general: the class of insurance is general (3rd class insurance coverage)
  • hospital_comfort: the class of insurance is hospital_comfort
  • md_free_choice: the class of insurance is md_free_choice ("Freie Arztwahl")
section_major | section_major is the main section code (BfS section code) of the treatment as defined by Swiss Federal Statistical Office
has_expense_loading | has_expense_loading is a Boolean value if there is an expense loading by the patient ("Spitalkostenbeitrag")
attributes enumerations
Name | Extension | Base | Value | Annotations
class | NMTOKEN | private | the class of insurance is private (1st class insurance coverage)
class | NMTOKEN | semi_private | the class of insurance is semi_private (2nd class insurance coverage)
class | NMTOKEN | general | the class of insurance is general (3rd class insurance coverage)
class | NMTOKEN | hospital_comfort | the class of insurance is hospital_comfort
class | NMTOKEN | md_free_choice | the class of insurance is md_free_choice ("Freie Arztwahl")
hospitalization_mode | NMTOKEN | cantonal | the mode of hospitalization is cantonal - patient's domicile is in the treatment canton)
hospitalization_mode | NMTOKEN | noncantonal_indicated | the mode of hospitalization is noncantonal_indicated - patient's domicile is not in the treatment canton, but treatment is indicated
hospitalization_mode | NMTOKEN | noncantonal_nonindicated | the mode of hospitalization is noncantonal_nonindicated - patient's domicile is not in the treatment canton and treatment is not indicated
hospitalization_type | NMTOKEN | regular | the type of hospitalization is regular ("a normal and planned hospitalization")
hospitalization_type | NMTOKEN | emergency | the type of hospitalization is emergency ("hospitalization due to an emergency")
source <complexType name="xtraStationaryType">
<sequence>
<element name="admission_type" type="invoice:grouperDataType"/>
<element name="discharge_type" type="invoice:grouperDataType"/>
<element name="provider_type" type="invoice:grouperDataType"/>
<element name="bfs_residence_before_admission" type="invoice:bfsDataType"/>
<element name="bfs_admission_type" type="invoice:bfsDataType"/>
<element name="bfs_decision_for_discharge" type="invoice:bfsDataType"/>
<element name="bfs_residence_after_discharge" type="invoice:bfsDataType"/>
<element name="case_detail" type="invoice:caseDetailType" minOccurs="0" maxOccurs="unbounded"/>
</sequence>
<attribute name="hospitalization_date" type="dateTime" use="required"/>
<attribute name="treatment_days" type="duration" use="required"/>
<attribute name="hospitalization_type" default="regular">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="regular"/>
<enumeration value="emergency"/>
</restriction>
</simpleType>
</attribute>
<attribute name="hospitalization_mode" default="cantonal">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="cantonal"/>
<enumeration value="noncantonal_indicated"/>
<enumeration value="noncantonal_nonindicated"/>
</restriction>
</simpleType>
</attribute>
<attribute name="class" default="general">
<simpleType>
<restriction base="NMTOKEN">
<enumeration value="private"/>
<enumeration value="semi_private"/>
<enumeration value="general"/>
<enumeration value="hospital_comfort"/>
<enumeration value="md_free_choice"/>
</restriction>
</simpleType>
</attribute>
<attribute name="section_major" type="invoice:stringType1_6"/>
<attribute name="has_expense_loading" type="boolean" default="true"/>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

complexType zipType

diagram
namespace | http://www.forum-datenaustausch.ch/invoice
type | extension of invoice:stringType1_9
properties
base invoice:stringType1_9
used by
element postalAddressType/zip
facets
minLength | 1
maxLength | 9
attributes parameters
Name Type Use Default Fixed
statecode invoice:stringType1_9
attributes annotations
Name | Notes
statecode | statecode is an optional code for a state (e.g. the canton designator in Switzerland or the state in USA)
Extensions
Annotation | Base
Definition for the zip container (a subcontainer of an address definition) giving the zip code and a possible state code | invoice:stringType1_9
source <complexType name="zipType">
<simpleContent>
<extension base="invoice:stringType1_9">
<attribute name="statecode" type="invoice:stringType1_9"/>
</extension>
</simpleContent>
</complexType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:Manifest

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:ManifestType
properties
content complex
children | ds:Reference
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="Manifest" type="ds:ManifestType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element ds:SignatureProperties

Annotation
diagram
namespace | http://www.w3.org/2000/09/xmldsig#
type | ds:SignaturePropertiesType
properties
content complex
children | ds:SignatureProperty
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
source | <element name="SignatureProperties" type="ds:SignaturePropertiesType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:AgreementMethod

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:AgreementMethodType
properties
content | complex
mixed | true
children | xenc:KA-Nonce xenc:OriginatorKeyInfo xenc:RecipientKeyInfo
attributes parameters
Name | Type | Use | Default | Fixed
Algorithm | anyURI | required
source | <element name="AgreementMethod" type="xenc:AgreementMethodType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:EncryptedKey

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:EncryptedKeyType
properties
content complex
children | xenc:EncryptionMethod ds:KeyInfo xenc:CipherData xenc:EncryptionProperties xenc:ReferenceList xenc:CarriedKeyName
attributes parameters
Name | Type | Use | Default | Fixed
Id | ID | optional
Type | anyURI | optional
MimeType | string | optional
Encoding | anyURI | optional
Recipient | string | optional
source | <element name="EncryptedKey" type="xenc:EncryptedKeyType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:ReferenceList/DataReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="DataReference" type="xenc:ReferenceType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

element xenc:ReferenceList/KeyReference

Annotation
diagram
namespace | http://www.w3.org/2001/04/xmlenc#
type | xenc:ReferenceType
properties
isRef | 0
content | complex
attributes parameters
Name | Type | Use | Default | Fixed
URI | anyURI | required
source | <element name="KeyReference" type="xenc:ReferenceType"/>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType ds:CryptoBinary

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
elements ds:RSAKeyValueType/Exponent ds:DSAKeyValueType/G ds:DSAKeyValueType/J ds:RSAKeyValueType/Modulus ds:DSAKeyValueType/P ds:DSAKeyValueType/PgenCounter ds:DSAKeyValueType/Q ds:DSAKeyValueType/Seed ds:DSAKeyValueType/Y
source <simpleType name="CryptoBinary">
<restriction base="base64Binary"/>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType ds:DigestValueType

namespace | http://www.w3.org/2000/09/xmldsig#
type | base64Binary
used by
element ds:DigestValue
source <simpleType name="DigestValueType">
<restriction base="base64Binary"/>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType ds:HMACOutputLengthType

namespace | http://www.w3.org/2000/09/xmldsig#
type | integer
used by
element ds:SignatureMethodType/HMACOutputLength
source <simpleType name="HMACOutputLengthType">
<restriction base="integer"/>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType filenameType

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attribute documentType/@filename
facets
pattern ([A-Za-z0-9._-]{1,250}\.[A-Za-z0-9_-]{1,4})
source <simpleType name="filenameType">
<restriction base="string">
<pattern value="([A-Za-z0-9._-]{1,250}\.[A-Za-z0-9_-]{1,4})"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType glnPartyType

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes processingType/@define_gln_norecipient processingType/@define_gln_printcenter transportType/@from billerAddressType/@gln debitorAddressType/@gln providerGLNAddressType/@gln insuranceAddressType/@gln guarantorAddressType/@gln referrerAddressType/@gln employerAddressType/@gln providerGLNAddressType/@gln_location serviceExType/@provider_id serviceType/@provider_id serviceType/@responsible_id serviceExType/@responsible_id processingType/@send_copy_to_trustcenter transportType/@to transportType/via/@via
facets
pattern ([0-9]{13})
source <simpleType name="glnPartyType">
<restriction base="string">
<pattern value="([0-9]{13})"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType guidType

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes invoiceType/@guid reminderType/@guid
facets
pattern [A-Fa-f0-9]{32}
source <simpleType name="guidType">
<restriction base="string">
<pattern value="[A-Fa-f0-9]{32}"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType nonEmptyStringType

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
facets
minLength 1
source <simpleType name="nonEmptyStringType">
<restriction base="string">
<minLength value="1"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType restCallType

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attribute processingType/@send_tgcopy_to_portal
facets
pattern https://[a-zA-Z0-9:._%-]+/putCopy[?]biller[=][0-9]{13}.insurance[=][0-9]{0,13}.guid[=][a-zA-Z0-9]{32}
source <simpleType name="restCallType">
<restriction base="string">
<pattern value="https://[a-zA-Z0-9:._%-]+/putCopy[?]biller[=][0-9]{13}.insurance[=][0-9]{0,13}.guid[=][a-zA-Z0-9]{32}"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType ssnPartyType

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes patientAddressType/@ssn insuredAddressType/@ssn
facets
pattern [0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}|438[0-9]{10}
source <simpleType name="ssnPartyType">
<restriction base="string">
<pattern value="[0-9]{4,10}|[1-9][0-9]{10}|756[0-9]{10}|438[0-9]{10}"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType0_35

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
complexType countryType
facets
minLength | 0
maxLength | 35
source <simpleType name="stringType0_35">
<restriction base="string">
<minLength value="0"/>
<maxLength value="35"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType0_350

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
complexType diagnosisType
facets
maxLength 350
source <simpleType name="stringType0_350">
<restriction base="string">
<maxLength value="350"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_10

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
facets
minLength | 1
maxLength | 10
source <simpleType name="stringType1_10">
<restriction base="string">
<minLength value="1"/>
<maxLength value="10"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_100

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes esrQRRedType/@alternative_scheme1 esrQRType/@alternative_scheme1 esrQRRedType/@alternative_scheme2 esrQRType/@alternative_scheme2 providerGLNAddressType/@main_treating_provider
facets
minLength | 1
maxLength | 100
source <simpleType name="stringType1_100">
<restriction base="string">
<minLength value="1"/>
<maxLength value="100"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_12

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attribute diagnosisType/@code
facets
minLength | 1
maxLength | 12
source <simpleType name="stringType1_12">
<restriction base="string">
<minLength value="1"/>
<maxLength value="12"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_140

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes esrQRRedType/@payment_reason esrQRType/@payment_reason
facets
minLength | 1
maxLength | 140
source <simpleType name="stringType1_140">
<restriction base="string">
<minLength value="1"/>
<maxLength value="140"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_15

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes debitorAddressType/@uid guarantorAddressType/@uid billerAddressType/@uid_number vatType/@vat_number
facets
minLength | 1
maxLength | 15
source <simpleType name="stringType1_15">
<restriction base="string">
<minLength value="1"/>
<maxLength value="15"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_160

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
facets
minLength | 1
maxLength | 160
source <simpleType name="stringType1_160">
<restriction base="string">
<minLength value="1"/>
<maxLength value="160"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_25

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
element telecomAddressType/phone
facets
minLength | 1
maxLength | 25
source <simpleType name="stringType1_25">
<restriction base="string">
<minLength value="1"/>
<maxLength value="25"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_255

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes instructionType/@token instructionType/@value
facets
minLength | 1
maxLength | 255
source <simpleType name="stringType1_255">
<restriction base="string">
<minLength value="1"/>
<maxLength value="255"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_3

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes bfsDataType/@code countryType/@countrycode grouperDataType/@number
facets
minLength | 1
maxLength | 3
source <simpleType name="stringType1_3">
<restriction base="string">
<minLength value="1"/>
<maxLength value="3"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_30

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes serviceExType/@code serviceType/@code caseDetailType/@code serviceExType/@ref_code serviceType/@ref_code serviceType/@sl_indicationcode
facets
minLength | 1
maxLength | 30
source <simpleType name="stringType1_30">
<restriction base="string">
<minLength value="1"/>
<maxLength value="30"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_35

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
elements | postalAddressType/city companyType/companyname companyType/department personType/familyname personType/givenname postalAddressType/pobox personType/subaddressing companyType/subaddressing
complexType | streetType
attributes | treatmentType/@acid caseDetailType/@acid treatmentType/@apid caseDetailType/@bfs_medstatistic_code lawType/@case_id lawType/@customer_no insuredAddressType/@insured_id lawType/@insured_id patientAddressType/@mpi employerAddressType/@reg_number reminderType/@request_id creditType/@request_id invoiceType/@request_id bodyType/@role_title personType/@salutation personType/@title documentType/@title
facets
minLength | 1
maxLength | 35
source <simpleType name="stringType1_35">
<restriction base="string">
<minLength value="1"/>
<maxLength value="35"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_350

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
element | bodyType/remark
attributes | serviceExType/@name serviceType/@name serviceExType/@remark serviceType/@remark
facets
minLength | 1
maxLength | 350
source <simpleType name="stringType1_350">
<restriction base="string">
<minLength value="1"/>
<maxLength value="350"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_50

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes softwareType/@copyright dependsOnType/@copyright softwareType/@description dependsOnType/@description softwareType/@name dependsOnType/@name
facets
minLength | 1
maxLength | 50
source <simpleType name="stringType1_50">
<restriction base="string">
<minLength value="1"/>
<maxLength value="50"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_6

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes serviceExType/@section_code serviceType/@section_code xtraAmbulatoryType/@section_major xtraStationaryType/@section_major
facets
minLength | 1
maxLength | 6
source <simpleType name="stringType1_6">
<restriction base="string">
<minLength value="1"/>
<maxLength value="6"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_64

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes grouperDataType/@name bfsDataType/@name
facets
minLength | 1
maxLength | 64
source <simpleType name="stringType1_64">
<restriction base="string">
<minLength value="1"/>
<maxLength value="64"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_70

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
facets
minLength | 1
maxLength | 70
source <simpleType name="stringType1_70">
<restriction base="string">
<minLength value="1"/>
<maxLength value="70"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_700

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attribute reminderType/@reminder_text
facets
minLength | 1
maxLength | 700
source <simpleType name="stringType1_700">
<restriction base="string">
<minLength value="1"/>
<maxLength value="700"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_80

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
element onlineAddressType/email
facets
minLength | 1
maxLength | 80
source <simpleType name="stringType1_80">
<restriction base="string">
<minLength value="1"/>
<maxLength value="80"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType stringType1_9

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
complexType | zipType
attributes | streetType/@house_no zipType/@statecode
facets
minLength | 1
maxLength | 9
source <simpleType name="stringType1_9">
<restriction base="string">
<minLength value="1"/>
<maxLength value="9"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType zsrPartyType

namespace | http://www.forum-datenaustausch.ch/invoice
type | restriction of string
used by
attributes providerZSRAddressType/@zsr referrerAddressType/@zsr
facets
pattern ([A-Z][0-9]{6})
source <simpleType name="zsrPartyType">
<restriction base="string">
<pattern value="([A-Z][0-9]{6})"/>
</restriction>
</simpleType>


Documentation of generalInvoiceRequest_500.xsd

Copyright (©) by Forum Datenaustausch, 08.05.2023

simpleType xenc:KeySizeType

namespace | http://www.w3.org/2001/04/xmlenc#
type | integer
used by
element xenc:EncryptionMethodType/KeySize
source <simpleType name="KeySizeType">
<restriction base="integer"/>
</simpleType>